Volume control disabled after plugging in and unplugging headphones, Help Please...

Discussion in 'MacBook' started by audeo13, Oct 16, 2011.

  1. audeo13 macrumors newbie

    Oct 16, 2011
    To go into a bit more detail, I have a Macbook 2,1 from 2007 running Snow leopard 10.6.8. Approximately a day ago, the volume controls stopped working for the internal speakers after using a headset for a good length of time. Sound does come out, but I cannot raise, lower or mute the volume by using the F3,F4 & F5 keys that correspond to volume or even by using the volume icon in my menu bar.

    The little screen appears and it looks like the volume is going up, complete with the little water drop sounds, but it doesn't actually adjust the volume. If I plug the headphones back in, volume control is restored but even that is no longer working properly. Everything is correctly set in System Preferences - Sound - Output - Built-in. Interesting enough, while checking those settings, I discovered that while none of the other volume controls work, the Output Volume bar in the Sound settings does allow me to adjust volume and mute. Weird right?

    My current troubleshooting to date:

    • Restarted - problem continued.

    • Rechecked System Preferences and Audio Midi in Utilities. All good there.

    • Ran Applejack - cleared out a bunch of stuff, then restarted. Problem seemed to correct itself initially, but as soon as I plugged the headset back in, it began again. Had to restart again to get it working.

    • Reset the PRAM - not sure if that got it working again or if it was just the reset itself that did it, but again, it only worked initially. As soon as I plugged the headset back in, the volume control was toast again.

    I have scoured various mac forums and gone over any and all posts that may apply, but have found no solutions as of yet. To answer some common questions I saw:

    No, there is no red light coming out of the audio port.

    My speaker settings have been checked and rechecked, they are correct and my volume setting is not greyed out or anything; the volume indicators appear when I press the button - they go up and down as if they are changing the volume, they just don't actually change the volume.

    I have all current salient updates to OS X installed.

    The only other thing of note I can mention is that a few days ago, I noticed my charger was acting a little odd. When it gets near a full charge, it's starts blinking, alternating from green to orange until it finishes charging. Sometimes it hangs at 99% without the orange light going off, but when I unplug it, it shows itself as 100% charged. I've not thought much of it though, because quite honestly, this battery is going on 5 years almost and still gives me over 2 hours of usage on a full charge. Not great, no, but can't complain considering it's age. It's still charging consistently and the diagnostics give me a health read of normal and a cycle count of 1619.

    Without fail, as soon as I plug the headset in, it disables the volume control (again, I still have sound, just no control over it). If I could just leave it as is, I would, but I work online all day and go a little nuts without music. My partner, unfortunately, also works online all day and the music drives him nuts. Maybe notsomuch the classical or jazz, but the fact that I like to blast The Hives or SOAD as well pretty much means I need a headset about 70% of the time.

    I would be leaning towards it being a hardware problem if it weren't for the fact that it consistently resets itself and I still have control through the Output Volume bar in the Sound settings (Sys.Pref.) even after the headset buggers everything else. If it were a hardware problem it wouldn't be doing that right?

    Anyhow, I figured I'd ask the Yodas on here before bothering with actual tech support at a store. The laptop is waaaaay beyond it's warranty date and I live in Chile, where the Mac techs are 1) few and far between and 2) skills are questionable to begin with.

    Cheers and thanks in advance ;)
  2. Detrius macrumors 68000

    Sep 10, 2008
    Asheville, NC
    Create a new user, log in as that user, and see if the problem goes away.

    If it doesn't, install a clean OS on a separate drive. See if the problem is gone there.

    This splits the cause into three distinct areas: user settings, OS or system settings, and hardware. It's basic divide and conquer troubleshooting.
  3. dsample macrumors newbie

    Oct 25, 2011
    I have exactly the same problem, and it too started after the upgrade to 10.6.8

    I don't know if it makes any difference, but I'm using a iPhone compatible headset, plugged into the 3.5mm headphone socket.

    This is the first thread I've found that mentions 10.6.8 and exactly the issue I have. All previous threads I've found are really old and are about the volume buttons not working, and the answer is always "reset the PRAM", but this doesn't help.

    When I reboot the volume starts off working fine, but as soon as I plug headphones in the volume keys and the master volume control on the menubar are completely disconnected to the actual volume. As audeo13 says, it goes through the motions... OSD appears, 'drip' sound (but obviously, not reflecting the actual volume), even the mute button doesn't work, even though it shows being muted.

    The 'headphones'/'Internal Speakers' indicator in the Sound preferences panel shows the correct state.

    All master volume indications/controls are disconnected from each other (show completely different volumes), and none of them influence the actual volume:

    • OSD and keyboard controls
    • Menubar control
    • Sound preference 'Output volume' control

    It very rarely resolves itself after several times plugging/unplugging of the headset, but usually only a reboot seems to fix it :(

    Included a screenshot of the three volume controls 'disconnected' just for the sake of it... none of the ones pictured is the actual volume level.

    [​IMG]Click for large view - Uploaded with Skitch


    I started off being able to control the sound this way as a last resort, but today even the sound preference panel stopped doing anything.
  4. Hituro macrumors newbie

    Nov 24, 2011
    I am having exactly this problem. I have a MacBook Pro 2.4Ghz Core Duo running 10.6.8. On starting up the volume controls work normally with no issues, but when I plug in a set of headphones to the audio jack the volume control buttons and menu slider stop having any effect on volume, with only the audio control panel slider working.

    When the headphones are removed the problem persists until I restart.

    This is a recent issue, though I am not sure how recent.
  5. dsample macrumors newbie

    Oct 25, 2011

    I think I've found a workaround that will re-enable the controls after removing the headphones, maybe someone else could confirm it... I think it would confirm that it's some sort of race condition in the audio drivers which is somehow causing itself some confusion.

    1. Headphones plugged in, only 'Sound' system preferences panel works.
    2. After removing headphones all controls stop working
    3. Plug the headphones back in, and keep pressing the volume buttons on the keyboard (just to hear when the audio is redirected to the headphones)
    4. As soon as you hear the volume 'blip' noises through the headphones, pull the headphones out of the socket
    5. Hopefully once removed the volume controls will work again

    I haven't found a way to make the volume controls work when you plug in the headphones, but at least for me, the Sound system prefs panel works most of the time in that situation.
  6. Hituro macrumors newbie

    Nov 24, 2011
    Will that re-enable the keyboard and menu controls, or just the preferences panel?
  7. dsample macrumors newbie

    Oct 25, 2011
    For me, that method re-enables all of the controls. But it's only temporary. As soon as you plug the headphones in again you're back to step 1.
  8. Hituro macrumors newbie

    Nov 24, 2011
    Wow, that works!

    And it rather suggests that the issue is with the detection of the switch to and from headphone mode?
  9. dsample macrumors newbie

    Oct 25, 2011
    Well, it's detecting the switch, otherwise you'd hear nothing through the headphones, but I'm thinking it's getting into some sort of confusion inside the sound control logic.

    How the heck do we report this to Apple in a way they won't just tell us we're doing something wrong though?
  10. Hituro macrumors newbie

    Nov 24, 2011
    That I don't know. There are threads and threads of this stuff on the apple support forum, but they are about a slightly different issue (controls don't work with the headphones in, or controls don't work after sleep and password unlock). I've sent in a bug report, but I don't expect any effect from that.
  11. nergllak macrumors newbie

    Apr 1, 2008
    same problem

    Just started last week. 1 year old MBP, 10.6.8
  12. jelliot macrumors newbie

    Dec 1, 2011
    Workaround - confirmed

    Just to confirm that this worked for me too.

    One clarification - it seems that you actually have to be pressing the volume up/down keys when you insert/remove the headphones. I tried doing it with just music playing and the problem wasn't fixed.

    Thanks for the workaround - now lets hope apple can fix this properly!!
  13. kintekobo macrumors newbie

    Dec 30, 2011
    Another country heard from!

    I have the exact same issues with my MacBook Pro as everyone else on this thread seems to be having. Not exactly sure when it started but I don't remember seeing this a couple of months ago.

    Has anyone had anything from Apple on this? It should be quite easy for them to replicate since it is so repeatable when you have a system that is suffering from the issue. Every time I remove the headphones the hardware keys stop controlling the volume/mute and if I re-insert the headphones and remove them after a few seconds then it will restore functionality, sometimes needs a couple of tries but it does do it. Problem is of course that that only fixes it until the next time the headphones are inserted/removed. Sigh!

    I wonder how many other people are seeing this issue. It is kind of hard to tell from just Googling for it since there seem to be a very large number of people who have been having similar, but not identical problems with sound either not working or being uncontrollable.

    I have been through all of the tricks recommended here, short of a full re-installation of the O/S but nothing seems to stop it re occurring.

    In case there is a commonality with other people my system is -

    Model Name: MacBook Pro
    Model Identifier: MacBookPro6,2
    Processor Name: Intel Core i7
    Processor Speed: 2.66 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache (per core): 256 KB
    L3 Cache: 4 MB
    Memory: 8 GB
    Processor Interconnect Speed: 4.8 GT/s
    Boot ROM Version: MBP61.0057.B0C
    SMC Version (system): 1.58f16
    Serial Number (system): xxxxxxxxxxx
    Hardware UUID: xxxxxxxxxxxxxxx
    Sudden Motion Sensor:
    State: Enabled
    OS Version 10.6.8

  14. BasK macrumors newbie

    Jan 19, 2012
    Finally found this thread, I've exactly the same problem. Is there still no fix known?
  15. arkaycee macrumors newbie

    Feb 14, 2012
    Same here

    mid-2010 MacBook Pro, Mac OS X 10.6.8. Have used the same pair of headphones since I've had this Mac, and about two weeks ago suddenly started having this problem, and now I can't stop having it if I go from headphones to not without doing the volume-change-while-pulling-headphones thing or rebooting/re-setting the PRAM.
  16. michael.ruta macrumors newbie

    Feb 14, 2012
    i have the exact same problem

    mid 2010, 10.6.8,

    problem started to occur after i recovered my os from a terrible boot up failure

    volume controls becomes fine after every logout, but won't work again after i plug & unplug a pair of headphones
  17. madmacfan macrumors 6502

    Feb 19, 2012
    London, United Kingdom
    I have the same problem, but found an easy fix

    Hi there. I have this problem on my late 07 macbook, but have stumbled upon an easy fix. Simply take a matchstick and wiggle it around in the headphone jack. You should see that the red light inside the headphone jack has gone and the volume now works and is not greyed out. I believe the fault is that the microswitch inside the headphone jack gets stuck. but I have found this method to work for me every time.
  18. rpolich macrumors newbie

    Mar 25, 2012
    Same exact problem

    So glad I'm not the only one experiencing this. After digging through multiple forums of people with slightly different problems, it was nice to see the exact issue I'm having represented.

    Are there any solutions yet? I'm sorry, but jamming a matchstick into my headphone jack just doesn't strike me as a sensible thing to do every time I unplug my headphones. I feel like there's a greater hardware/software issue going on.
  19. monkeypuffs macrumors newbie


    Mar 26, 2012
    Same problem, roughly same specs, also on 10.6.8

    Hey people on this thread - michael.ruta, arkaycee, nergllak. I also have a MacBook Pro 15" (Macbook Pro 5,4 / Intel Core 2 Duo) on Mac OS 10.6.8 as well and have started experiencing this problem last month (seems to be roughly the same time as some of you here).

    Also have been using the same earphones all alone, official apple earphones mind you. Discovered the method that dsample posted about on my own while furiously plugging it in and out in a rage, and have been using that to get around this problem, but wish I could find an actual solution! Anyone knows why this happens?

    Seems like we're all on 10.6.8. Any connection there I wonder?
  20. ronaldinio macrumors newbie

    Jun 6, 2011
    My Solution

    I'm having the same problem...it's happened a couple of times and it's annoying. I had logmein installed (a remote access app)...I disabled it, and then reenabled it, and the volume started working...

    Try closing apps that are running in the tray...perhaps they're interfering...

    worked for me!

    Good luck.

  21. okevin macrumors newbie


    Apr 15, 2012
    Philadelphia, PA
    Volume control disabled after plugging in headphones

    I just started having the same problem today.
    I am also on 10.6.8.
    Seems like a physical problem with the headphone jack, as I just plugged and unplugged the iphone headphone jack about 10 times in a row and it is temporarily fixed, but also wondering if it is about the iphone jack on my headphones.
    If I plug in the headphones with the Iphone jack, when plugged in, the volume control does not work right. If I plug in headphones with a regular headphone jack, the volume does work while plugged in. At least right now.
    Still trying to isolate the problem.
    Thanks to all who have contributed clues here.
    I have attached the screen grab showing the 3 volume methods all at different levels. This was taken with Iphone headphone plug plugged in.

    Attached Files:

  22. Ofilippelli macrumors newbie

    Apr 27, 2012
    Same problem but with different headphones

    For the first time today I plugged in an Audio-technica Quite Point headphone set and the volume control stopped working i follow your advise here with the original apple headphones and it didn't fix it. So I plugged in the Audio-Technica headphones follow your advise and it fixed it. Thanks! Hope this helps someone else. Omar
  23. okevin macrumors newbie


    Apr 15, 2012
    Philadelphia, PA
    headphones disable volume controls

    Tonight when I had this problem I plugged and unplugged the Iphone headphone plug and it did not work, but when I plugged and unplugged a regular headphone plug 6 or 7 times in a row in rapid succession, it worked.
    Maybe the regular headphone plug is a better bet to reset this voodoo problem.
  24. ChiisuMac macrumors newbie

    May 10, 2012
    I have this issue

    I also have 10.6.8 and it is a software issue as I use to have Lion on this mac but due to a recent issue lost the OS and I just haven't purchased it yet. Anyway, a easier fix to this issue is to stick a mic jack (not earphone jack) halfway into the headset jack, look at the volume control icon you will notice it switches try it out.
  25. Zorrito macrumors newbie

    Jun 4, 2012
    I solved my problem. Go to...
    System Preferences - Sound - Output - Internal Speakers - Balance Slider

    I moved the slider left to right and right to left while itunes was on music playing. Suddenly Volume Slider turned on from being greyed out. Now it is working perfectly. :)

    Hope this helps...

Share This Page