Wake from sleep - Ethernet - Self Assigned IP

Discussion in 'OS X El Capitan (10.11)' started by PLOdonk, Aug 17, 2016.

  1. PLOdonk macrumors newbie

    Joined:
    Aug 17, 2016
    #1
    Hello,

    I'm somewhat new to OSx but I know my way around it.

    Whenever I open my Macbook from sleep it will take a few minutes for the internet to connect. The network settings will say something to the effect of "Received IP address, no internet connection". It's usually much quicker to restart my computer and connect then to try connecting after waking from sleep. Do you know what the problem could be?

    A few things I've tried:
    1) Assign a manual IP address
    2) Change to google DNS servers
    3) Reset DHCP server
    4) Reset Router
    5) Replace Router
    6) Roll back to Yosemite (never an issue in Yosemite)
    7) Use Ethernet (same problem on Ethernet - Connected to a router on a wireless bridge)

    Our Macbook Air does the same thing. I have 2 other PC's and other devices in the house that do not have any problems receiving an IP address or dropping connections. Also, I never had a problem prior to upgrading to El Capitan.

    The problem has been around for the past year or so..but it's really starting to irritate me now. I've purchased 3 different routers in the past year so it can't be a problem with the network. I've used a Netgear R6300, Linksys WRT1900ac and most recently a Linksys WRT1900acs.

    Please help ~ I've tried using the search feature on the forum but it all mentions WIFI. It doesn't matter if it's ethernet or WIFI for me.

    Thank you,
    Paul
     
  2. george_i macrumors newbie

    george_i

    Joined:
    May 31, 2015
    Location:
    Athens-Greece
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    You have only one router handling DHCP, correct?

    If so, have you tried a DHCP reservation on the router for the Mac? Note: There would different reservation IPs for ethernet and wifi as the MAC (ethernet) addresses are different.
     

Share This Page