Wake up taking 30 seconds plus MBPr

Discussion in 'MacBook Pro' started by njean777, Jun 30, 2012.

  1. njean777 macrumors 6502

    Joined:
    Oct 17, 2009
    #1
    Hey guys and girls, having a bit of trouble with my MBPr. When I wake it up from sleep it takes anywhere from 20-45 seconds to fully wake up and turn on the display, now I use to have a MBA and it would take about 5 seconds to wake up, but never as long as the MBPr. Any suggestions why it might be doing this at all? I never had the problem with my prior MBA or MBP (with traditional HD)
     
  2. hi-there macrumors member

    Joined:
    Mar 8, 2007
    Location:
    Melbourne
    #2
    It should wake up in < 5 seconds... in fact within 1 - 2 seconds. What apps have you installed or any external storage in use?
     
  3. njean777 thread starter macrumors 6502

    Joined:
    Oct 17, 2009
    #3
    umm nothing out of the ordinary. Caffine, alfred, amazon cloud, fantastical, flux, aperture, safari, mail, kindle, iTunes, activity monitor is all that is running
     
  4. dhartung02 macrumors 6502

    Joined:
    Sep 9, 2007
    Location:
    Little Rock, AR
    #4
    Agree - with that SSD installed you should see wake times happen almost instantaneously!
     
  5. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #5
  6. Intenost macrumors member

    Intenost

    Joined:
    Feb 3, 2008
    Location:
    Boston, MA
    #6
    Is your fan blasting while it's sleeping? Mine is, and when I wake it up I can see it's got the kernel_task running at 600%+ of CPU, so it's slow to do anything until that process starts to ramp down, and the fans also go from full to non-audible. I'm taking it to the Genius bar shortly.
     
  7. Qbiinz macrumors newbie

    Joined:
    Jul 15, 2010
    #7
    ya know I've noticed a bit of lag when waking up from sleep as well. mines not quite as extreme as 20-45 seconds, but it does take up to 10 sec for my screen to come on after i open it. i thought i would be a little faster than that.
     
  8. njean777 thread starter macrumors 6502

    Joined:
    Oct 17, 2009
    #8
  9. cruggles macrumors regular

    Joined:
    Feb 2, 2010
    #9
    Hang on, that link is years old.

    Macbook Pros in my experience (2010 model 15" MBP) don't hibernate (save RAM to disk) unless they are about to run out of battery power.

    They sleep (lightly) by shutting down all but RAM for an almost instant power-on. Isn't that happening in the rMBP?
     
  10. Djhomefries macrumors member

    Joined:
    Jun 25, 2012
    #10
    MacBook Pros love to sleep, often taking daytime naps. But don't take my word for it!
     
  11. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #11
    I don't think the link's age is relevant in this case since disabling deep sleep still works. I believe the 30 days of standby on battery that Apple quotes is achieved through deep sleep.

    I have a rMBP running with hibernatemode=0, just like my 2010 MBA, and it works just like I'd expect it to.
     
  12. cruggles macrumors regular

    Joined:
    Feb 2, 2010
    #12
    I still don't get it... my MBP never hibernates unless the battery is low. Why do you need an app for that?
     
  13. randomnut macrumors member

    Joined:
    Aug 17, 2011
    #13
    I created a separate post about this earlier. My rMBP is also taking around 30seconds or more to wake up from sleep.

    Not good enough. This machine was clearly released before the software was ready to support it. Either that or there's something seriously wrong with the SSD.
     
  14. astrorider, Jul 1, 2012
    Last edited: Jul 1, 2012

    astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #14
    I think there's a couple things going on. Hibernation only occurs when the battery is low, but supporting hibernation and achieving 30 days of standby requires your laptop to do some operations that slow the time it takes to go to sleep and the time it takes to wake up.

    1.) When your computer goes to sleep by default it writes its contents of RAM to the hard drive (in /var/vm there's a sleepimage file that's the size of your RAM). Disabling deep sleep allows you to delete this and your machine won't take the time to write this when it goes to sleep.

    2.) When you put your computer to sleep and wake it up within a short time (I don't recall what the time is) it will wake up more quickly than when you wake it up after a longer period of time. The machine goes into some lower power mode that isn't a full on hibernation, but is how Apple's able to achieve a 30 day standby when on battery. Disabling deep sleep turns this off and translates into your computer always waking up instantly.

    If you're unhappy with how quickly your machine wakes up from sleep and want to save 8-16GB of disk space depending on how much RAM you have, and you're willing to give up a long standby on battery and the safety net it provides if your battery runs completely out, give disabling deep sleep a try (setting hibernatemode=0). You can always change it back to the default using the same command (setting hibernatemode=3).
     
  15. baypharm macrumors 65816

    baypharm

    Joined:
    Nov 15, 2007
    #15
    Thank God I didn't buy one! My 2009 CD2 17" comes alive as soon as the screen is opened. Instantly. No waiting. I'm running Lion.
     
  16. Djhomefries macrumors member

    Joined:
    Jun 25, 2012
    #16
    I wouldn't generalize that all MBPr's are affected with the issue. In fact, a generalization that is accurate is that the MBPr is the best laptop Apple has ever made.
     
  17. randomnut macrumors member

    Joined:
    Aug 17, 2011
    #17
    Not with how long it takes to wake from sleep it's not.
     
  18. leenak macrumors 68020

    Joined:
    Mar 10, 2011
    #18
    So how are you putting it to sleep and how are you waking it up? I just tried twice and it took 2 seconds max to wake up.

    I went to apple-> sleep.

    Screen went dark.

    I push power button, 2 seconds later, system comes on.
     
  19. randomnut macrumors member

    Joined:
    Aug 17, 2011
    #19
    I am doing it by normal usage patterns. By closing the lid. Come back to it 15-20 mins later and open the lid again, and it takes an age to wake up.

    Using that method you described it is faster, but that is not typical usage.
     
  20. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #20
    This sounds like what I was describing in post 14 with respect to putting the machine to sleep for a short period and waking it up vs putting it to sleep for a long period and waking it up. The machine is going into a standby mode to further preserve battery and it's taking longer to wake up. This doesn't occur if you disable deep sleep, if so inclined.
     
  21. Gilj macrumors member

    Joined:
    Jul 13, 2010
    #21
    Do you have an external drive connected when you put the machine to sleep?
     
  22. leenak macrumors 68020

    Joined:
    Mar 10, 2011
    #22
    Oh, I'll have to try that sometime. I'm not sure what the difference on OSX's sleep vs hibernate but I've had the screen go dark after a while, I hit space bar and it comes right back.
     
  23. randomnut macrumors member

    Joined:
    Aug 17, 2011
    #23
    Isn't hibernation something else? E.g where you see a faded shot of the desktop with the progress bar loading until it snaps into life? or was that only in Snow Leopard....?

    If Lion still does that then this machine isn't entering hibernation.
     
  24. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #24
    Not hibernation, more of a lower-power standby mode. Still, setting hibernatemode=0 (i.e. disabling deep sleep) also eliminates the slow wake-up.

    Same complaints were made about the 2011 Macbook Air .
     
  25. mykelala01 macrumors 6502

    mykelala01

    Joined:
    May 17, 2009
    #25
    That is really strange. My macbook pro late 08. Wake up instantly. Have you consider clean install without apps or anything? See how it perform. So you can do trouble shooting. It takes time but at least you know if it the software or the hardware causing the issue.
     

Share This Page