waking from sleep issue

Discussion in 'Mac Pro' started by camner, Aug 22, 2013.

  1. camner macrumors regular

    Joined:
    Jun 19, 2009
    #1
    Just recently I've run into an odd wake-from-sleep issue I'd love some help with. It's a 2010 Mac Pro 5,1 running 10.8.4.

    I'll describe the symptom and what I've tried thus far:

    Symptom: Machine goes to sleep, and monitor goes to standby mode, as expected. Light on front of MP starts to "breathe." All is as it should be.

    I wake up MP by hitting any key...light on MP goes to steady, as expected. Monitor briefly wakes up, then immediately goes into standby mode.

    The MP appears to be awake, but the monitor indicates there is no signal from the computer.

    I can hold the power button down to force the MP to power down, and then I can successfully reboot. This sequence is repeatable as often as I'd like.

    What I've tried, all without success:
    1. Reset PRAM
    2. Reset SMC by powering down, unplugging MP for 20 seconds, plugging back in for at least 5 sec, and then rebooting
    3. removing all PCIe cards except for by ATI 5770
    4. booting from a drive with a completely fresh install of 10.8.4
    5. connecting the monitor via a display port to HDMI cable instead of the DVI cable I usually use
    6. deleting the com.apple.powermanagement.plist file
    7. removing and reseating the video card

    I've plumb run out of ideas as to how to troubleshoot this further.

    Does anyone have any ideas about what else I might try or any idea about what might be causing this? It just started suddenly about 48 hours ago, without any software installs or any other changes that might account for this.

    Thanks!
     
  2. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #2
    Your options are: wait for 10.8.5, get the mavericks beta, or switch to an Nvidia video card. These nasty bugs are directly related to the AMD drivers. It took forever to track the actual source.

    Symptoms include: a failure to wake up form sleep, extended time thinking about sleep with the cursor on a black screen that lingers.

    In the mean time, If you can'w wake up, try hot plugging USB device or a MDP cable. Something is blocking power management from waking up.

    Why does it start? No clue.
     
  3. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #3
    Try another video card if possible. I've had similar issue with flashed 5770, but mine didn't want to wake one of my 2 displays, let's say, once for 20 "wakings". All other ATI models I've used (all flashed: 2600XT, 5850, 5870, 6850, 6870, 7870, 7950, 7970) didn't have this problem.
     
  4. camner thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #4
    Thanks for the response. The only thing that puzzles me about this is why it would just start to happen without any software upgrades in the meantime. I didn't upgrade the OS or install anything in the last week, and it just started to happen, and now it happens consistently.

    I'm also a bit confused about your comment that "something is blocking power management from waking up." Are you referring to the video card or to the machine? Because the machine itself is at least partially awakening (the power button light gets bright and stays on and the monitor obviously receives a signal because it starts to power up--its power button turns from yellow to green--before powering down again)

    ----------

    This is an Apple OEM 5770, not flashed if this makes a difference.

    Alas, I don't know anyone I can borrow a video card from to test this. I (perhaps foolishly?) sold my old video card from a previous machine because I thought I could use the money!
     
  5. 666sheep, Aug 23, 2013
    Last edited: Aug 23, 2013

    666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #5
    Flashed or Apple shouldn't matter in this case. I'm suspecting your card is going bad. Especially if problem has started suddenly, without any changes in software/OS. Or maybe it's the display itself?
     
  6. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #6
    you sure the machine is actually waking up and only graphics not responding (eg if you have network shares to other machine are these still accessible etc) or are you just assuming its kicked back to life other than display?

    Try pulling the RAM and then booting and sleeping with just a single stick installed per processor at a time, my hexcore 4,1 (with 5,1 firmware) would spit the dummy out resuming from sleep thanks to one DIMM in a set (would work fine with the remaining dimms and any others I threw at it)
     
  7. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #7
    This happens for me with a 7950 or 6870 not a 680 gtx only on 10.8.4. 10.8. 5 fixed wake from sleep, just delays falling asleep for 10 seconds. It started for no apparent reason other than 10.8.3 update. 10.9 has no problem.
     
  8. camner thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #8
    Thanks for the response. No, I'm not 100% sure that the machine is fully awakening and only failing to produce the video. So, I guess I am assuming its kicked back to life other than the display. I didn't think about testing to see if I can see the network shares to other machines....should have thought of that! I'll try that next.

    I did try pulling the RAM sticks out and only have 1 in at a time. That didn't change anything, so I'm figuring it isn't RAM. The other possibility is the power supply, of course.

    I did try booting off of an old 10.7.5 drive I had lying around, as well as trying a completely fresh 10.8.4 install, and the symptoms didn't change, so I'm figuring that this is the case of the well-documented frustration of the "10.8.5 sleep" issue.
     
  9. camner thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #9
    It turned out to be the video card. Changed the card, voilá, sleep issue disappeared.

    Thanks to everyone for their help.
     
  10. camner, Sep 13, 2013
    Last edited: Sep 13, 2013

    camner thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #10
    Well, I spoke too soon! The new video card worked perfectly for 9 days. Now the same symptom is back! :mad:

    Further investigation shows that trying to reset SMC by removing the power cord, waiting 15 seconds, reconnecting doesn't work. The computer won't start up. BUT, if I remove the power cord for 5 seconds and immediately reinsert, the computer starts up. Hmmm..


    Are there other things to try?
     

Share This Page