WARNING: Do NOT install High Sierra from USB 1st time!

Discussion in 'macOS High Sierra (10.13)' started by SteveJobzniak, Apr 23, 2018.

  1. SteveJobzniak, Apr 23, 2018
    Last edited: Apr 23, 2018

    SteveJobzniak macrumors 6502

    SteveJobzniak

    Joined:
    Dec 24, 2015
    #1
    This is a warning to save time for other people. The High Sierra 10.13.4 installer is bugged. It CANNOT install firmware updates when booted from USB. According to one thread below, it's due to an inability to "bless" the USB drive. In my opinion, it seems more like the USB-booted installer version fails to place the firmware installer onto the proper startup disk.

    Here's what happens: You boot High Sierra from USB, and it says that you need a new firmware. You try to click the "Shut Down" button but just get a spinning beachball and nothing happens. There are countless forum threads about that problem here and on other sites.

    Solution: You MUST have a WORKING Sierra 10.12.6 (preferably) installation, or possibly any other working older OS that has the App Store. Then go into the Mac App Store and download "High Sierra" from THERE. Run the regular DESKTOP installer and it will show the same "You need a new firmware, push this button to shut down". In THIS scenario the button finally WORKS. It asks for admin password to "install a helper tool", and then shuts down the machine (and from there you just start it up while continuing to hold the power button until it does a long beep and flashes the firmware).

    There is NO way to install the firmware via USB. So don't repeat my mistake... I accidentally assumed it would all work from USB, so I booted the USB, ran Disk Utility, nuked my old El Capitan OS, and tried to install High Sierra... Then went on a tedious 3 hour journey of reinstalling El Capitan from recovery, then installing Sierra (not High Sierra) 10.12.6, and finally installing High Sierra from the Mac App Store. WHEW. Do NOT repeat my mistake! ;-) Run your INITIAL High Sierra installer from a working OS or you will get stuck too.

    After your firmware has been updated by the desktop installer app, you are free to do further installs from USB (that's what I did, to get a full, fresh APFS install by nuking the disk).

    PS: I finally have a Mac Pro 4,1 -> 5,1 with the latest "MP51.0085.B00" firmware and High Sierra. Just letting others know that their "5.1 hacks" will accept this latest firmware update exactly as if it was a real 5.1 machine.

    References:

    https://forums.macrumors.com/thread...3-4-mas-full-installer-mp51-0085-b00.2112641/

    https://forums.macrumors.com/threads/high-sierra-firmware-fails-to-install.2090884/

    https://apple.stackexchange.com/questions/299769/mac-pro-4-1-flashed-high-sierra-firmware-update
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Is this model-specific info that should be in that particular forum?
     
  3. tsialex macrumors 68040

    tsialex

    Joined:
    Jun 13, 2016
    Location:
    Brazil
    #3
    I’ve lost at least a day testing this when 10.13.4 arrived, only way to update the firmware was from macOS. It never worked booting via createinstallmedia pendrive. Clearly Apple did not test updating the firmware via USB.
     
  4. SteveJobzniak thread starter macrumors 6502

    SteveJobzniak

    Joined:
    Dec 24, 2015
    #4
    I think this affects every Mac that needs a firmware update before being allowed to install High Sierra. Which is most Macs since they all came out before APFS, and need this new firmware to support APFS startup drives.

    Exactly. I assume the "install firmware" screen was not properly tested via USB. I suspect all Apple HQ macs already had the latest firmware.
     
  5. Partron22 macrumors 68020

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    I installed from (over, a dirty install) Sierra USB boot SSD, using terminal to avoid conversion to APFS.
    All is running nicely even with no firmware update dialog: linkage
     
  6. hnr2802 macrumors newbie

    Joined:
    May 3, 2010
    #6
    Hi, guys here’s my solution. yesterday I tried to install HS from USB for the first time in my cMP but when i try to click the "Shut Down" button, nothing happens. So i Shutdown from the top Menu drop down instead. When the mac completely switched off, Hold down the power button until the power indicator light flashes, or you hear a long tone, then release the power button. Tadaa.. A gray screen with an Apple logo and progress bar will appear while the update is taking place.
     
  7. Surrat macrumors 6502

    Surrat

    Joined:
    Jun 20, 2014
    Location:
    United States
    #7
    I have updated 5 mac pros with the usb thumbdrive for 10.13.4, some clean install, some not.

    Your right that when you click the shut down button at the bottom it does not work, and yes its bugged.
    But, all you have to do, is use the apple logo in the upper left to tell it to shut down, and upon reboot holding the power button down, the update will load like it should.

    Due to the update writing data to the EFI partition of the hard drive, you MUST have a formatted and working hard drive before you can run the update.
     
  8. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #8
    This is only a problem on the Mac Pro 5,1. Later computers don't use the same firmware update mechanism and won't have a problem.
     
  9. Mr. 123 macrumors regular

    Joined:
    Sep 20, 2016
    #9
    Just updating to high Sierra from Sierra through the Computer (not USB) is fine right?
     
  10. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #10
    I was about to say ...

    I've recently updated 20+ Mac Mini's and doing one as I type this. All with a 10.13.4 USB drive.
     
  11. MSastre macrumors 6502

    MSastre

    Joined:
    Aug 18, 2014
    #11
    Yes, no problems updating through the computer. I have not installed HS on my Mac Pro 5,1 yet, but I did do the firmware update for when I am ready to install it. When I'm ready I will use my USB installer.
     
  12. SteveJobzniak thread starter macrumors 6502

    SteveJobzniak

    Joined:
    Dec 24, 2015
    #12
    Fyi, 10.13.4 introduced yet another firmware update, as seen in one of the threads I linked to:
    https://forums.macrumors.com/thread...3-4-mas-full-installer-mp51-0085-b00.2112641/

    So if you installed long ago, you'll want that one too. Or at least check if you are already on MP51.0085.B00 (I think the previous was 0084)
     
  13. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #13
    It's certainly not required to install that firmware update. If it were, then the updater from 10.13.3 to 10.13.4 would force it. My Mac Pro on my desk is running with the previous firmware version without any problem at all.
     
  14. Mr. 123 macrumors regular

    Joined:
    Sep 20, 2016
    #14
    I updated just a few hours before the security update came out lol... Another update to do...
     
  15. SteveJobzniak thread starter macrumors 6502

    SteveJobzniak

    Joined:
    Dec 24, 2015
    #15
    I assume they fixed some rare bug in the original firmware.
     
  16. Zenithal macrumors 604

    Joined:
    Sep 10, 2009
    #16
    Thanks for the heads up. I tend to ignore major OS updates for this very reason. There's been a small but steady decline in OS updates from Apple in the last decade.
     
  17. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #17
    Other option is extract the firmware update from a full HS install and apply it through recovery after repacking it. This is the method I use for imaging Macs to HS that haven't yet gotten the firmware update and would otherwise fail to boot after the imaging process.
     
  18. BomexM3 macrumors member

    Joined:
    Jan 4, 2014
    #18
    I just used DiskMaker X to make a thumb drive to do a clean install of High Sierra. Are you guys saying it won't work. I'm not trying to get stuck without a computer.
     

Share This Page