WatchCast or WatchPlayer offline podcast help!!

Discussion in 'Apple Watch Apps' started by cpalmaATC, Oct 25, 2017.

  1. cpalmaATC macrumors newbie

    Joined:
    Oct 25, 2017
    #1
    I have figured out how to use both to transfer podcasts from my phone to my Apple Watch Series 3 (CPS + Cellular) running WatchOS 4.0.1. It is slower than I would like, but it works and I now have podcasts on my wrist!

    The problem I am having is with playback. They simply won't play. I have tried uninstalling/reinstalling the entire app, the watch app, deleting and re-transferring podcasts, restarting both the watch and phone. I can hit the play button, but then nothing comes through my bluetooth headphones (yurbuds Liberty wireless) and the time counter on both apps are still at 0:00:00....

    I feel like I'm missing something simple, but it's getting pretty frustrating. Any help I can get would be appreciated!
     
  2. musicpenguy macrumors 68000

    Joined:
    Oct 29, 2006
    #2
    One trick is hit play in the podcast app then go to the Now Playing app and hit play, that’ll do the trick most of the time (something to do with it ensuring the bluetooth headphones are connected and the Now Playing app will help with that).

    I’d recommend WatchPlayer its more full featured (once installed can run without interacting with the phone, can load new feeds directly on watch and download episodes over LTE or WiFi - just turn AirPlane mode on your iphone to make sure downloads are fast, otherwise it’ll try to push episodes to your watch over Bluetooth)
     
  3. Morosowski macrumors newbie

    Morosowski

    Joined:
    Nov 3, 2017
    Location:
    US
    #3
    WatchPlayer works great with most podcasts, however First Take doesn’t work at all.
    I tried downloading several episodes and it downloads but doesn’t play.
    Any idea why?

     
  4. musicpenguy macrumors 68000

    Joined:
    Oct 29, 2006
    #4
    Hmm the latest update mentions you can slide left on an episode to resample the problematic files that do not play on Apple Watch to 64kbs/AAC - this is one of the few features on the iPhone app (something I don’t use anymore).

    So it appears that some podcasts are encoded in a way that aren’t compatible with the watch for native playback and that could be one of them.
     

Share This Page

3 October 25, 2017