WatchOS 2.0.1 certain 3rd party apps still crashing

Discussion in 'Apple Watch' started by 212rikanmofo, Oct 23, 2015.

  1. 212rikanmofo macrumors 65816

    Joined:
    Jan 31, 2003
    #1
    Sigh, what's up with this? I cannot get apps like CNN, iTranslate, Skype and various other apps to open without crashing, even after updating to 2.0.1

    Anyone else also have this problem?
     
  2. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #2
    Have you tried removing and reinstalling the apps?
     
  3. 212rikanmofo thread starter macrumors 65816

    Joined:
    Jan 31, 2003
  4. bumpylumpy macrumors member

    Joined:
    Mar 13, 2015
    #4
    I had the hardest time getting Sleep++ to launch. I tried unpairing and re-pairing, uninstalling and re-installing the app. It was the only one that didn't work, and I also had 3rd party apps that did work so this stumped me completely. I was going to delete it but I read that other people had success with it on this board so I was convinced it was something with my setup.

    On the other thread about 3rd party apps not launching, I saw what seemed like the totally ridiculous suggestion that I delete all of my Music(!) from my iPhone, then re-sync it all back to the phone. What in the world that had to do with my watch, and why *only* the music, made absolutely no sense to me.

    So, after first backing up my iPhone to iTunes on my mac, I went to my iPhone, deleted all of the music, then tried launching Sleep++ on my watch. It would just spin for a few seconds then exit, just like before. I thought, wow, that totally did not work, and now I have to let my iPhone sync back with my iTunes overnight to get my really huge music collection back onto my iPhone (I have the option to compress my music files down to 128 AAC files since most of my on-computer music is uncompressed audio files). That happened all last night.

    So on a lark, I decided to try launching Sleep++ for the first time this morning and it worked! Amazing! I have no idea exactly *when* it started working, but it was definitely NOT right after I first deleted all the music from my iPhone. At some point later, after the music was re-sync'd back things started working again. Neither my iPhone nor Watch were restarted, or unpaired the entire time. Now *that* is bizarre bug.
     
  5. menace3 macrumors 6502

    menace3

    Joined:
    Aug 13, 2008
    Location:
    Seattle, WA
    #5
    Exact same here. Many apps just not working.

    Having issues with Runtastic, Runkeeper, CNN, .

    Apps will not start on my Watch. I get the circle of death and then it finally stops and goes back to my home screen. I have tried the following:

    1. uninstall and reinstall - repeatedly
    2. I even did a watch restore last night and nothing.
    3. Tried on wifi, cellular, and bluetooth
    4. Powered the phone off and on
    5. Powered the watch off and on

    I just dont get it and getting frustrated and disappointed.
     
  6. bumpylumpy macrumors member

    Joined:
    Mar 13, 2015
    #6
    Did you try deleting your Music on your iPhone as suggested by this thread?

    Native apps do not load

    It worked for me. I did all of the stuff you did above, but the Music deletion eventually worked.
     
  7. menace3 macrumors 6502

    menace3

    Joined:
    Aug 13, 2008
    Location:
    Seattle, WA
    #7

    Nope. Just saw this post this AM.

    So will try it tonight when I'm finally home. Thanks.
     

Share This Page