WD USB HDD won't be verified/repaired or formatted with Disk Utilities.

Discussion in 'macOS' started by lovecybercat, Jun 18, 2008.

  1. lovecybercat macrumors newbie

    Joined:
    Jun 18, 2008
    #1
    Hi.
    Few files on my HDD got corrupted and after I tried to repair it using Disk Utilities and it did not work, I recovered all my files to different HDD and tried to erase my WD HDD but I get error ( input/output error) - I am wondering why and how can I fix it?
    Thanks.
     
  2. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #2
    If you cannot even format the hard drive then the best way to fix the problem is to order a new one :rolleyes: At this point, I wouldn't trust it anymore. You might try if it works with a different computer, in case the problem is with the USB ports on your Mac and not with the hard drive.
     
  3. lovecybercat thread starter macrumors newbie

    Joined:
    Jun 18, 2008
    #3
    I tried different computer and it finds it but fails to format it in a middle of process. HDD makes a really weird sound. Oh well- at least I was able to recover all my files. :(
     
  4. chscag macrumors 65816

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #4
    As you've been advised.... The HDD is on its way to the land of dead drives.

    Time for a new one. You wanted a new one anyway. :D

    Regards.
     
  5. lovecybercat thread starter macrumors newbie

    Joined:
    Jun 18, 2008
    #5
    Thanks to everyone you guys are just so optimistic! :)
    All my files are safely recoverd on another HDD ( as of this morning at least LOL) and I just got an e-mail from WD with shipping label for product exchange! ;)
    So yeah, not going to trust that old HDD anymore- bye bye!
     

Share This Page