Weather Channel/Yahoo Widget Not Working

bunnspecial

macrumors 604
Original poster
May 3, 2014
7,202
4,300
Kentucky
I know dashboard widgets are a somewhat controversial topic, but putting that aside I depend heavily on them including the pre-installed Weather Channel/Yahoo widget.

Basically, here's what is happening. I can add the widget to the dashboard(yes, I've tried deleting it and re-adding it) and it will work perfectly for the default of Cupertino, CA.

Screen Shot 2015-09-21 at 10.25.30 AM.png


Of course, I don't live in Cupertino, so this information is of no use for me.

Clicking the small "i" in the lower right hand corner would normally allow me to enter my desired city

Screen Shot 2015-09-21 at 10.28.34 AM.png


Unfortunately, this is as far as I can get. If I attempt-for example-to type in my zip code here's what I see

Screen Shot 2015-09-21 at 10.29.52 AM.png


Typing in the city name gives the same

Screen Shot 2015-09-21 at 10.30.47 AM.png


Even switching to nearby larger city gives the same result

Screen Shot 2015-09-21 at 10.32.01 AM.png


At this point, I can't even revert back to the default of Cupertino

Screen Shot 2015-09-21 at 10.32.55 AM.png


Are any other users of this widget seeing the same sort of thing?
 
  • Like
Reactions: firehiker

bunnspecial

macrumors 604
Original poster
May 3, 2014
7,202
4,300
Kentucky
Interestingly enough, I just tried on my faithful Quicksilver G4 running 10.5.8, and it seems to work perfectly.


Picture 4.png
Picture 5.png
Picture 6.png


All of the screenshots in my opening post were taken on my mid-2012 MBP running 10.9.5.
 

talmy

macrumors 601
Oct 26, 2009
4,715
276
Oregon
Gee, thanks! Mine was working fine (with my location) until I tried changing it to Frankfort, KY. Now it no longer works.:)
 

bunnspecial

macrumors 604
Original poster
May 3, 2014
7,202
4,300
Kentucky
Sorry...

As I said, though, I had the same issue changing it back to Cupertino, CA.

BTW, my work Mac Pro is still working fine on Louisville, KY so I'm not going to play with it.
 

bunnspecial

macrumors 604
Original poster
May 3, 2014
7,202
4,300
Kentucky
Some further experiments:

1. I have a Macbooki(mid-2009) currently running El Capitan Golden Master. The widget is broken in it.

2. I have a beige G3 in my office with a G4 upgrade and running 10.4(Tiger). The widget works perfectly.

So, it appears to now be broken somewhere between 10.5 and 10.9. I don't currently have anything running 10.7, but can check 10.6 on my Mac Pro and will check 10.8 when I get home this evening.
 

talmy

macrumors 601
Oct 26, 2009
4,715
276
Oregon
Sorry...

As I said, though, I had the same issue changing it back to Cupertino, CA.

BTW, my work Mac Pro is still working fine on Louisville, KY so I'm not going to play with it.
Turns out I can restore the preferences file and get it working again. I'm fine as long I don't move.
 

bunnspecial

macrumors 604
Original poster
May 3, 2014
7,202
4,300
Kentucky
Not even Lima, Peru works for me.

I don't currently have anything running 10.10, but as I said I did a "spot check" with 10.6, 10.9(my main OS across my three most used computers) and 10.11. It doesn't work on any of those, but continues to work fine on 10.4 and 10.5.

BTW, I'll add that I haven't tinkered with the location setting on my 13" MBP running 10.9, and the widget is still updating correctly for current temperatures in Frankfort. My current issues came about because I often change the location when I'm traveling, and found that I couldn't get it to reset when I got back home.
 

talmy

macrumors 601
Oct 26, 2009
4,715
276
Oregon
Not even Lima, Peru works for me.

I don't currently have anything running 10.10, but as I said I did a "spot check" with 10.6, 10.9(my main OS across my three most used computers) and 10.11. It doesn't work on any of those, but continues to work fine on 10.4 and 10.5.
Judging from the captures, 10.5 (and probably 10.4) uses Accuweather while 10.6 and later use WeatherChannel. That's probably the difference.
 

fhall1

macrumors 68040
Dec 18, 2007
3,504
738
(Central) NY State of mind
I had a problem with the widget for a day over the weekend where it didn't update and when I tried to change/restore my location to give it a kick in the pants it kept saying "no cities found".....the next day it was back working again. I attributed it to something on Yahoo's end (this was on 10.10.5 BTW)
 

HarryL

macrumors newbie
Jun 10, 2006
4
0
Frankfurt / Germany
It still doesn't work for a lot of german cities and towns. Hamburg and Dresden for example work. Couldn't get Frankfurt/Main or Munich to work. And lots of others don't work either.
 

gonzalorodrigo

macrumors newbie
Nov 26, 2015
4
1
I had the same problem recently with any city on "El capitan". After lots of debugging I observed that it has to do with the headers that the WidgetClient sends when requestion weather data and the chance that the returning data requires more than two TCP/IP packager.

I modified the Widget code and now it seems to work always. You can look at the solution at:
https://github.com/gonzalorodrigo/osxcalendarwidget
 
  • Like
Reactions: nemiere

e93to

macrumors 6502a
Jan 23, 2015
826
184
Toronto
It works intermittently on my 2012 iMac 10.8.5 and mid 2009 MBP 10.6.8. It worked again 2 days ago, now it's showing blank
 

ATC

macrumors 65816
Apr 25, 2008
1,147
356
Canada
My weather widget is not getting weather info for any Canadian city, this started happening a few weeks ago. If I put any US city or any international city (not Canadian) it works fine.

Is Yahoo weather no longer providing Canadian weather info to Apple?
 

gonzalorodrigo

macrumors newbie
Nov 26, 2015
4
1
My weather widget is not getting weather info for any Canadian city, this started happening a few weeks ago. If I put any US city or any international city (not Canadian) it works fine.

Is Yahoo weather no longer providing Canadian weather info to Apple?
My weather widget is not getting weather info for any Canadian city, this started happening a few weeks ago. If I put any US city or any international city (not Canadian) it works fine.

Is Yahoo weather no longer providing Canadian weather info to Apple?
It provides, the information is sent but it breaks in the middle. It seems a server thing, I tried to retrieve with cURL and it breaks after 2 TCP/IP packets. (With the rest of the cities it would work with cURL, even if the widget was failing).
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.