What is this shared "PC server" showing up?

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
I have an Airport network set up with an iMac, MacBook, iBook and two iPhones (at any given time). In the "Shared" section of the Finder sidebar, I can see all the other computers (that are on and connected, of course). On my MacBook, however, I can also see a "PC Server" that doesn't appear on anywhere else. It appears to be identified by a MAC address, but when I check my Airport utility, none of the connected machines show that address.

Here's a screenshot. Any ideas?
 

Attachments


Uoila

macrumors member
Oct 20, 2007
65
0
Sometimes those links are slow to update, for me at least. I can go to school and it will show a list of shares and then when i disconnect and go home i still see them until finder realizes that i've moved and they aren't really there anymore. Do you use this macbook in two distinct locations like work and home?
 

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
Sometimes those links are slow to update, for me at least. I can go to school and it will show a list of shares and then when i disconnect and go home i still see them until finder realizes that i've moved and they aren't really there anymore. Do you use this macbook in two distinct locations like work and home?
So far the "PC Server" only shows up at home.
 

DoFoT9

macrumors P6
Jun 11, 2007
17,532
31
Singapore
this is an 'error' (i guess you would call it that). sometimes i recognises the computer as a PC but it is a mac (even though you cant connect to it). im sure an update will fix it when it comes out.
 

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
this is an 'error' (i guess you would call it that). sometimes i recognises the computer as a PC but it is a mac (even though you cant connect to it). im sure an update will fix it when it comes out.
Why do I only see it on my MacBook, though? Does Leopard see my iMac twice (once as it is and once as the "erroroneous PC Sever")?
 

emeryemery

macrumors newbie
Dec 8, 2008
1
0
This ghost in the Machine is nothing to fear!

While some people have touched on what is causing this issue, I want to make it very clear what is going on. I just figured this out.

When you see something similar to macmac001ec214122a in your shared list, all it means is that the Mac computer you have on your network is also broadcasting the mac address of your Ethernet card.

There is nothing sinister going on here although it should not be doing this. Apple has been ignoring this issue for some reason and why it suddenly started happening is not clear but you are not at a security risk when you see this.

You can confirm what I am saying by going into your network preference.

Choose Ethernet, click the Advanced button and then click on the Ethernet tab. You will see that the Ethernet ID (mac address) for your Ethernet card is where the NetBios name that appears in your shared server list is derived from.
Now click on the WINS tab and you will see that the NetBios Name is your ethernet ID with mac added to the front.

Now, when I check my Sharing settings, I have file sharing set to share and under options I only have "Share files and folders using AFP". FTP and SMB are not checked so my MacBook should not be broadcasting a NetBios name.

What I cannot figure out and what Apple needs to tell us all is how to stop this from happening. How do we turn off the WINS NetBios broadcast. We don't care why it suddenly started happening and we are all comforted by the fact that it's simply a byproduct of sharing our Mac computers on a Mac network.

Please, Apple, it's scaring most people and it's a visual nuisance to us all. Tell us how to stop it!!!!!
 

bluesTank

macrumors regular
Oct 21, 2008
181
0
I am at a medical library in a hospital (ie: tons of computers and networks around) and here is my shared sidebar. Only happens here.
 

Attachments

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
While some people have touched on what is causing this issue, I want to make it very clear what is going on. I just figured this out...
Wow good find. The really odd thing is that my iMac (the one whose Ethernet MAC address is being broadcast) doesn't even have anything plugged into the Ethernet port. Everything on my network is running on wifi.

I have a printer hooked up to my iMac and have it set to be Shared. Could that have anything to do with it?
 

heatmiser

macrumors 68020
Dec 6, 2007
2,430
0
IM IN YUR MACKBOOK

HACKIN YUR FILEZ

: D

Seriously, those are just local networks on your internet.
 

bluesTank

macrumors regular
Oct 21, 2008
181
0
Does anyone know how to remove them from our shared folder list? The list I posted earlier is not going away when I am home. It is annoying to have all those things in my sidebar
 

yOyOYoo

macrumors 6502a
Feb 13, 2005
643
27
CA
Does anyone know how to remove them from our shared folder list? The list I posted earlier is not going away when I am home. It is annoying to have all those things in my sidebar

Seriously this really bugs me too! I'm glad someone posted this so I know that I'm not alone!

For now I just clicked that little triangle, and minimized the list so that it is not showing.
 

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
You're on a network with other computers, as I, and others have said. People are giving you the answer; listen to it.
You said "those are local networks on your internet." That statement doesn't make sense and isn't true. There may be millions of "local networks" on "(my) internet" but I'm only connected to the one that I set up with my modem and wireless router.

What was posted by emeryemery was intelligently-written and factual. What you posted was nonsense.
 

IgnatiusTheKing

macrumors 68040
Original poster
Nov 17, 2007
3,652
0
das Fort
Does anyone know how to remove them from our shared folder list? The list I posted earlier is not going away when I am home. It is annoying to have all those things in my sidebar
Go to Finder > Preferences and choose the Sidebar tab. Then you can deselect the Connected Servers check box and you should be good to go.
 

Attachments