When I click the "Pictures" folder, it opens up the Terminal window. Why?

Discussion in 'iMac' started by Amnesiac1, Aug 29, 2011.

  1. Amnesiac1 macrumors 6502

    Joined:
    Oct 11, 2010
    #1
    I think I may have deleted a few files from my Pictures folder that had to do with iPhoto. Ever since, I find Ic annot open my Pictures folder. When I try to open it from the sidebar or within the finder, it opens up that terminal message. If I right-click and select "Open Enclosing Photo" and then, "Show Package Contents", I can see what's inside and gain access to my iPhoto library and whatnot, but I can't simply click the "Pictures" folder without getting that annoying terminal message. Does this have something to do with what I deleted from iPhoto? My Pictures folder has "iChat Icons", "iPhoto Library" and "Photo Booth Library"... is something crucial missing that will allow the Pictures folder to operate normally (that is, allow it to simply open when I click it isntead of giving me a terminal message)?

    Thanks in advance.
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    What, exactly, is "that Terminal message"?

    Did you empty the Trash after deleting those files? If not, then you can try and put them back - at the very least, you can tell us what the files were.

    You normally shouldn't need to use "Show Package Contents". iPhoto stores your media there, but they aren't named in a very useful way. If you need to get to an original, or a version, of an image, you should use iPhoto.

    If you deleted an item from within a package, you could render it inoperative. (Many different items are actually "packages" in OS-X and are meant to be treated as a single file.)
     
  3. Amnesiac1 thread starter macrumors 6502

    Joined:
    Oct 11, 2010
    #3
    Well, could someone tell me what files an iPhoto folder needs to operate normally?
     
  4. Amnesiac1 thread starter macrumors 6502

    Joined:
    Oct 11, 2010
    #4
    The window is titled "Pictures - bash - 80x24"

    The content of the window: "Last login: Mon Aug 29 02:45:09 on [here its a bunch of letters and numbers]"

    Below that line: "[myname]'s-imac: Pictures [my Apple id]$"
     
  5. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #5
    Your iPhoto library is stored as a package. You're not meant to dig around in there and manually manipulate the files.

    (not to rant or embarrass inexperienced users, but this is why Apple hid the ~/library folder in Lion and why the "show contents" context menu is slightly hidden away; and some people couldn't fathom why Apple would hide these things in Lion. This is why)

    However, I'm confused as to where your problem is - in the iPhoto library document or the folder called "Pictures" itself. I'm not sure what to do for a folder that the OS now thinks is a Unix binary. Weird.
     
  6. Amnesiac1 thread starter macrumors 6502

    Joined:
    Oct 11, 2010
    #6
    Yeah, the folder doesn't operate as a folder... I mean, if I "show contents" I can eventually arrive at my iChat icons, iPhoto library, etc. but the Pictures folder responds to a click by taking me to a Terminal window.

    An Apple rep is suggesting I do a clean re-install. =( Ugh.
     
  7. stordoff macrumors regular

    Joined:
    Aug 24, 2009
    #7
    This might work:

    Use "Show Package Contents" to get access to your iPhoto, Photo Booth etc. Libraries. Copy (_not_ move, just in case it doesn't work) "iPhoto Library" to the Desktop and double click it. If iPhoto launches with your library in tact, you should be able to move stuff out of the Picture folder, delete and re-create it, and then put stuff back.

    If that doesn't work, you might have to do a clean install :(

    I have no idea how this happened though. Did you rename "Pictures" to "Pictures.<somethinghere>" at all?
     
  8. gr8tfly, Aug 29, 2011
    Last edited: Aug 29, 2011

    gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #8
    In my "iPhoto Library" package, I have no Pictures folder, or iPhoto library. I do have "Library.iPhoto". So, I still can't entirely picture (no pun intended) where you are. I am assuming you went into your "Picture" folder - which is a normal Finder folder, then went to the package "iPhoto Library", used "Show Package Contents", and deleted some things from within it.

    What does iPhoto do when you launch it? Are your images still there? If iPhoto is still functioning normally, then the fact you can't launch it by clicking on the corrupt "iPhoto Library" package is somewhat moot. Just don't launch iPhoto that way - at least, until the package is somehow repaired.

    You wouldn't, by any chance, have a backup (Time Machine, perhaps)? Had to ask...

    To answer your question about which files are needed for a working package: I have about 30 different files and folders. The specifics won't help much, unless you still have what you tossed. If that were the case, then we could help restore the package.

    The only other thing I can think of is to recreate "iPhoto Library" package - your iPhoto events/albums etc. Make a copy of the "iPhoto Library" package, then delete the original. Open iPhoto, and reimport your images from the "iPhoto Library/Masters" folder (inside the package). This should recreate a functional "iPhoto Library" package, though all your metadata added (in addition to the original image's data) will be lost.

    I'm assuming you've only been using iPhoto for a relatively short time (mine goes back to where iPhoto stored images differently - 2006, I believe). So, all your images should be in the Masters sub-folder.
     
  9. jamesfk macrumors newbie

    Joined:
    Sep 4, 2011
    Location:
    Cardiff
    #9
    Picture folder become package?

    I had this exact same problem after manually moving my iPhoto library on the command line and messing up the folder hierarchy.

    For me the problem was the Pictures folder had become a package, to unset this try the following:

    xattr -d com.apple.FinderInfo ~/Pictures

    This got everything back to normal for me.

    All Credit to Rodney on the Apple forums for this:
    https://discussions.apple.com/thread/2416657?start=0&tstart=0

    Good luck,
    James
     
  10. ChipGillespie macrumors newbie

    Joined:
    Dec 2, 2011
    #10
    :) This worked for me - I had the same problem but now is all well again with my Picture folder on Lion. Thanks for posting!
     

Share This Page