Where is this IP Address (169.254.137.245) coming from?

phpeters87

macrumors member
Original poster
Nov 9, 2009
91
0
My JBreaked phone has really been acting up lately.

Now, instead of displaying the correct IP addy for my home wireless network (192.168.1.2) I get (169.254.137.245) and can't connect to the internet via my wireless modem.

This is not a neighbors IP addy or anything else, but for some reason, it is "kicking out" the correct IP address and inserting this one in it's place.

Also, the Subnet is showing 255.255.0.0 which is incorrect.
The correct Subnet is 255.255.255.0

So I'll select "Forget this Network" then confirm, then I will reselect "My Network" where it will prompt me for my password.

I enter my password then select "Join" and I'm then connected to "My Network" with the correct IP addy

Everything is great, until...

I turn off/on or reboot the phone, then "My Network" IP address defaults back to 169.254.137.245 so I have to "Forget this Network" and go thru the process above again to be able to use "My Network"

And yes, I did change my root password when I JBreaked my phone last year, so I doubt anyone has hacked into it.

It keeps displaying more and more bizarre behavior everyday.

Everything was fine until about two weeks or so ago, then it started acting up and has gotten progressively worse.
 

phpeters87

macrumors member
Original poster
Nov 9, 2009
91
0
why don't you just use a static ip address?
Same issue occurs, and it doesn't solve the sudden problem of a phantom IP address mysteriously appearing in my WiFI settings for my phone upon rebooting.
 

ClutchThese

macrumors 65816
Jun 25, 2010
1,249
61
Alexandria, VA
it sounds like you haven't received the DHCP feed from the base
station. Go to the Command Prompt and type in "ipconfig" without the
quotes. If it returns a 169.x.x.x address, you're not receiving the feed.

You could try after that typing in "ipconfig /release" (again without
quotes) and then "ipconfig /renew" (no quotes) to kick it into gear. You
may need to restart your system. If it still doesn't receive the feed,
power down the base station for a couple minutes and then connect the power again.

taken from a website: http://www.tomshardware.com/forum/6499-42-tomshardware

not sure if it will fix.
 

phpeters87

macrumors member
Original poster
Nov 9, 2009
91
0
I'll do that, but this is just bizzare.

My other devices (laptop, etc...) are not having any problems with my home wifi, just my phone.

And the Phantom IP addy is located on the other side of the planet.

For some odd reason, it grabs this phantom IP address whenever I reboot the phone.
 

ClutchThese

macrumors 65816
Jun 25, 2010
1,249
61
Alexandria, VA
can you rejailbreak it? restore it and rejailbreak it if possible. I'm it will be fixed that way. are you able to view the device through the router?
 

ssajous

macrumors member
Sep 13, 2007
96
0
It's an iOS401 bug

My JBreaked phone has really been acting up lately.

Now, instead of displaying the correct IP addy for my home wireless network (192.168.1.2) I get (169.254.137.245) and can't connect to the internet via my wireless modem.

This is not a neighbors IP addy or anything else, but for some reason, it is "kicking out" the correct IP address and inserting this one in it's place.

Also, the Subnet is showing 255.255.0.0 which is incorrect.
The correct Subnet is 255.255.255.0

So I'll select "Forget this Network" then confirm, then I will reselect "My Network" where it will prompt me for my password.

I enter my password then select "Join" and I'm then connected to "My Network" with the correct IP addy

Everything is great, until...

I turn off/on or reboot the phone, then "My Network" IP address defaults back to 169.254.137.245 so I have to "Forget this Network" and go thru the process above again to be able to use "My Network"

And yes, I did change my root password when I JBreaked my phone last year, so I doubt anyone has hacked into it.

It keeps displaying more and more bizarre behavior everyday.

Everything was fine until about two weeks or so ago, then it started acting up and has gotten progressively worse.

People are complaining about it on the apple site after upgrading to 401. I have it too after doing a fresh install because when I went from my 3GS to my 4 HD I inherited the blank web clips so it was recommended that I do a new phone setup which I did, now I cannot get on any WIFI I get what you have
 

CJayC

macrumors 6502
Jun 2, 2010
368
0
The 169.xxx IP is a failure IP that indicates your modem/router is acting up. Try the usual troubleshooting steps for the modem, i.e. unplugging it, removing all wires, replacing the wires, etc.
 

phpeters87

macrumors member
Original poster
Nov 9, 2009
91
0
I have other devices running off my wireless router without issue.

I can also go into my router admin page and see that the phantom IP address isn't even in the range of IP addys allowed.

Regardless, I shut down my router, my computer and then restarted them back up.

And, I have a spare "Airlink" router that I connected.

Same Phantom IP addy is appearing when I reboot my phone, so unless my Netgear router is bad and my Airlink router is bad, it's not the router(s)

I'm running version 3.1.2 BTW
 

MikePA

macrumors 68020
Aug 17, 2008
2,039
0
Same Phantom IP addy is appearing when I reboot my phone, so unless my Netgear router is bad and my Airlink router is bad, it's not the router(s)
Perhaps you missed CJayC's post...

This is not a 'phantom' IP address. It is the standard way most operating systems indicate they could not get an IP address from a DHCP server. No one hacked into your network and it's not an IP address from the other side of the planet.

Since redefining the network on your phone temporarily solves the problem, the issue is your phone is not remembering your network for whatever reason. The problem is not with your routers. Unfortunately, the only solution appears to be live with this or restore your phone and re-jb.
 

scirica

macrumors 68020
May 13, 2008
2,068
1
Dallas, TX
You're not alone. This happens to me lately and I have not been able to resolve. I'm not going to re-jb every time, so I'm living with it. I do the "forget and re-add" as my workaround.
 

nebo1ss

macrumors 68030
Jun 2, 2010
2,760
1,287
I have other devices running off my wireless router without issue.

I can also go into my router admin page and see that the phantom IP address isn't even in the range of IP addys allowed.

Regardless, I shut down my router, my computer and then restarted them back up.

And, I have a spare "Airlink" router that I connected.

Same Phantom IP addy is appearing when I reboot my phone, so unless my Netgear router is bad and my Airlink router is bad, it's not the router(s)

I'm running version 3.1.2 BTW
As others have said the 169 address is like a default when your phone does not get a connection to the router with a proper DHCP address. You should reboot your router and it will probably clear the problem. The most likely reason for your problem is that there is a phantom session left by the phone in the router with an assigned DHCP address. Since the router already sees your MAC address connected it will not allow another connection for the same MAC address. When you reboot the router it will clear it out.

One other test worth considering: The 3G is noted for developing WIFI problems in later life, many suspect it is due to overheating of the CHIP. What often happens is that just the sensitivity degrades and you can often connect by moving closer to the router for a stronger signal.
 

MikePA

macrumors 68020
Aug 17, 2008
2,039
0
You should reboot your router and it will probably clear the problem.
He already said he not only shut his router down, but tried an Airport.

phpeters87 said:
So I'll select "Forget this Network" then confirm, then I will reselect "My Network" where it will prompt me for my password. I enter my password then select "Join" and I'm then connected to "My Network" with the correct IP addy. Everything is great, until I turn off/on or reboot the phone, then "My Network" IP address defaults back to 169.254.137.245 so I have to "Forget this Network" and go thru the process above again to be able to use "My Network"
Your phone does not 'default back to 169.254.137.245' after you reboot the phone. When the phone comes back up it tries to connect to the network DHCP server (your router), fails, and the 169 address is plugged into the IP address field.

Since you stated;
1. This happened all of a sudden
2. It works if you tell the phone to forget the network then works when you redefine it.

Some parameter changed on your router or there's a problem with your phone.
 

dgstan

macrumors 6502a
Jun 29, 2010
625
1
You don't mention what type of wireless protocol your router is using. Since you have a 3G iPhone, the iPhone is using 802.11g. I'm wondering if you set your router as "g Only" (as opposed to a/g/n or whatever it defaults to) if the problem might go away.

I have an older Macbook and it was not playing along well with my non-Apple router (of course the "Genius" told me I needed to use an Apple router for it to work correctly). I set the router to only use "g" and it worked fine, although the Macbook had an "n" chip in it. They eventually came out with an OS update that fixed the problem.

The other thing I would try as a test is hard-coding your iPhone's MAC address into the router so it doesn't have to bother with any security handshakes that might be throwing it off.
 

iUser4Lyfe

macrumors 6502
Jun 15, 2009
487
0
Not a phantom IP. 169.whatever.whatever.whatever is an IP address modems/routers give out when something is wrong with it.
 

MikePA

macrumors 68020
Aug 17, 2008
2,039
0
Not a phantom IP. 169.whatever.whatever.whatever is an IP address modems/routers give out when something is wrong with it.
The misinformation in this thread is truly amazing. Addresses in the range 169.254.0.0 to 169.254.255.255 are used automatically by some PCs and Macs when they are configured to use IP, do not have a static IP Address assigned, and are unable to obtain an IP address using DHCP. The router/modem does not assign it.:rolleyes:
 

nebo1ss

macrumors 68030
Jun 2, 2010
2,760
1,287
The misinformation in this thread is truly amazing. Addresses in the range 169.254.0.0 to 169.254.255.255 are used automatically by some PCs and Macs when they are configured to use IP, do not have a static IP Address assigned, and are unable to obtain an IP address using DHCP. The router/modem does not assign it.:rolleyes:
I agree with you entirely with regard to the 169 address and said so in my post. I don't think apple plays well with all routers and if you look at Scrica post where he is doing the forget and readd its the same type of problem. I went through two days of helping a friend resolve this same issue recently. You could see the dummy sessions left up on the router and you could fix it by rebooting or forget and readd but it would still keep coming back and you would have to reboot again. There were three Microsoft devices and two apple devices on the router. Only the apple devices showed the problem. One was a MacBook and the other an iphone. Fortunately, it was one of those Vendor provided Modems/Routers integrated devices got them to change it and problem has gone for good.
 

TMar

macrumors 68000
Jul 20, 2008
1,679
1
Ky
I think this has more to do with the way apple has tried to implement the ability to stay connected to wi-fi and going into a low power consumption mode. My XP machine does this too sometimes when it's brought out of standby but of course it releases and renews automatically.

If you lock your phone then open sbsetting so you can see your ip then turn the screen off. If you wait a little while and click home a lot of times many different ip errors before it connects back to the Wi-Fi.
 

phpeters87

macrumors member
Original poster
Nov 9, 2009
91
0
I added the iPhone MAC address is in my Netgear Admin page settings months ago, and I also did the same with my Airlink router.

The Router cannot issue the phantom IP because it is not within the range of allowed IP addys.

I don't know much about TCP/IP, but I do know the basics of adding wireless devices to a router, and I've tried two different routers so the router is not the issue.

I've done all the usual troubleshooting, but the issue still persists upon rebooting of the phone.

Not a big deal to have to redo my settings on the phone, but I'm just wondering why this is happening as it's happening for a reason.

Also, if I have to restore my phone, won't iTunes auto update me 4.0/4.1, leaving me with an un jail breakable iPhone?

As mentioned, I've been having some other issues with this phone the last few weeks and I'm trying to fix them.

Doing a backup and restore is the last option as my concern is that the phone will be updated to 4.x
 

iUser4Lyfe

macrumors 6502
Jun 15, 2009
487
0
The misinformation in this thread is truly amazing. Addresses in the range 169.254.0.0 to 169.254.255.255 are used automatically by some PCs and Macs when they are configured to use IP, do not have a static IP Address assigned, and are unable to obtain an IP address using DHCP. The router/modem does not assign it.:rolleyes:
Maybe my post was a bit confusing. Lets use a PC as an example. What I meant was if a PC is not being assigned an IP address it will automatically generate a 169 IP address.

Sorry if my post was ambiguous but as I work in the tech industry I do know what I am talking about.
 

BFW122083

macrumors 6502
Sep 17, 2009
373
0
Atl
Ok so don't hate me here, but I used to do tech support for Comcast. You need to unplug your modem and router from the ac outlet. Plug your modem in first and let it fully boot up...2-3 minutes. After that plug the power to your router back in. That's the proper way to power cycle. That should do the trick. Do you have other devices in the house that is wireless? Are they working?
 

nebo1ss

macrumors 68030
Jun 2, 2010
2,760
1,287
I added the iPhone MAC address is in my Netgear Admin page settings months ago, and I also did the same with my Airlink router.

The Router cannot issue the phantom IP because it is not within the range of allowed IP addys.

I don't know much about TCP/IP, but I do know the basics of adding wireless devices to a router, and I've tried two different routers so the router is not the issue.

I've done all the usual troubleshooting, but the issue still persists upon rebooting of the phone.

Not a big deal to have to redo my settings on the phone, but I'm just wondering why this is happening as it's happening for a reason.

Also, if I have to restore my phone, won't iTunes auto update me 4.0/4.1, leaving me with an un jail breakable iPhone?

As mentioned, I've been having some other issues with this phone the last few weeks and I'm trying to fix them.

Doing a backup and restore is the last option as my concern is that the phone will be updated to 4.x
Firmware signature signing by apple was introduced with 3GS you can restore the 3G to any firmware. I think everyone has said that the 169 is not coming from the router. It is a default on any device that fails to get a DHCP address from the router.
 

BFW122083

macrumors 6502
Sep 17, 2009
373
0
Atl
169 comes from the computer/phone when it can't connect to the Internet. It's kind of like a diagnostic for troubleshooting. If you have a 169 things need to be checked.