White iPhone 4 w/ Zagg - Proximity not working

Discussion in 'iPhone' started by Jerastan, May 2, 2011.

  1. Jerastan macrumors newbie

    Joined:
    Jun 26, 2010
    #1
    Hello, All. Just wanted to throw this out there in case someone else was experiencing the same thing. My white iPhone 4 proximity sensor does not work w/ the Zagg shield on the front, but does when the shield is pulled down.

    Best Buy will not refund because they already installed the shield, which seems absolutely retarded to me since it's causing a problem and Zagg swears there is not an issue and just keeps offering to send a replacement. All they kept saying was that the sensor was in the same place so it shouldn't cause any problems.

    Ugh!
     
  2. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
    #2
  3. Jerastan thread starter macrumors newbie

    Joined:
    Jun 26, 2010
    #3
  4. The Californian macrumors 68040

    The Californian

    Joined:
    Jan 17, 2009
    Location:
    Surfers Paradise
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    So is this a widespread problem?
     
  5. Gomez315 macrumors member

    Joined:
    Aug 15, 2010
    #5
    I have the exact same problem with a different screen protector.
     
  6. UCLAkers, May 2, 2011
    Last edited: May 2, 2011

    UCLAkers macrumors member

    Joined:
    Jun 17, 2008
    #6
    oh crap.. is it the powersupport crystal film by any chance? just got the white and will be installing the crystal film tonight. the film is absolutely amazing for the front and back.. and if this truly is a widespread problem I think I'm gonna have to return the phone and stick with my black :mad:.. please say it ain't so!! ugggghhhh
     
  7. dennisjr631 macrumors 6502

    Joined:
    Aug 15, 2009
    #7
    I have ghost armor and my proximity sensor won't work either. I'm just wondering will a regular screen saver do this also. I did such a good job installing this one that I don't want to remove it.
     
  8. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #8
    How about you just cut the ear hole bigger so it allows the prox sensor to see out like they do with the camera?
     
  9. maclaptop macrumors 65816

    maclaptop

    Joined:
    Apr 8, 2011
    Location:
    Western Hemisphere
  10. UCLAkers macrumors member

    Joined:
    Jun 17, 2008
    #10
    awesome! and you've tried it on the white 4 right?

    nah.. I've never been a fan of cutting out custom holes n stuff.. I'd just F the whole thing up trying lol
     
  11. Gomez315 macrumors member

    Joined:
    Aug 15, 2010
    #11
    I'm not sure what it's called. It's the one that they sell at wal-mart that's comes with the yellow cloth and protection for the sides. I really liked this protector on my black iPhone I never had any problems with till I put it on my white iPhone.
     
  12. alectheking macrumors 6502a

    Joined:
    Mar 9, 2010
    #12
    Absolutely! I should have made a thread 2 days ago about this. My zagg shield makes the sensor stop working completely on my white iPhone. I couldn't believe it was the shield, I went through the effort of restoring and even a genius appointment until he diagnosed it was the zagg. Really sucks, I've been using their maximum coverage since the 3G. I ended up peeling it off the top and using a razor to cut out a slit. Resprayed it with the liquid stuff and squeegeed it clean. Looks brand new still and my sensor works way better than my black iPhone 4 did. It goes off a good couple inches away from my head.
     
  13. alectheking macrumors 6502a

    Joined:
    Mar 9, 2010
    #13
    it isn't the phones problem.
     
  14. UCLAkers macrumors member

    Joined:
    Jun 17, 2008
    #14
    well I guess I'm gonna give the PS skin a try.. hopefully the earlier poster is right and it doesn't happen with these.

    anyone out there using the PS crystal film on the white 4 without any proximity sensor issues?
     
  15. tobejs macrumors newbie

    Joined:
    May 5, 2011
    #15
    Zagg & iPhone 4 - OK for black, not for white

    My wife and I just bought 2 iPhone 4s: 1 black and 1 white. Went to Best Buy and had Zagg Invisible Shields installed. Black works fine, but white proximity sensor stopped working.

    Now to try to get my money back...
     
  16. Eduardo1971 macrumors 65816

    Eduardo1971

    Joined:
    Jun 16, 2006
    Location:
    Lost Angeles, Ca. usa
    #16
    I have have the fullbody Zagg Invisi-shield on my white iPhone 4.

    I do not have this problem.
     
  17. hengyu408 macrumors member

    Joined:
    May 18, 2006
    Location:
    san Jose, CA
    #17
    I have a full body ghost armor on my white iphone 4 and the proximity sensor works with no problems.
     
  18. Jerastan thread starter macrumors newbie

    Joined:
    Jun 26, 2010
    #18
    I argued with Zagg for 20 minutes. "We tested them on the white iPhones with no problems." I just gave up.
     
  19. deadlystriker macrumors regular

    deadlystriker

    Joined:
    Jan 15, 2011
    #19
    Power support crystal and antiglare both have no problems on white iphone 4. Personally tested both myself.
     
  20. draperm25 macrumors regular

    draperm25

    Joined:
    Sep 19, 2007
    Location:
    Swansea
    #20
    Mine is the same with another generic front cover, I had to cut the piece out that covers the sensor, no biggey, however these are the same covers I've used for my wife's black iPhone 4 and I've noticed that they dont fit properly, the black iPhone 4 glass seems to be flat around the edges, however my White iPhone 4 seems to have a slight lip around the edge on the front glass panel. Strange?
     
  21. The Californian macrumors 68040

    The Californian

    Joined:
    Jan 17, 2009
    Location:
    Surfers Paradise
    #21
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Has anyone heard anything from Zagg on this issue yet?
     
  22. smug macrumors newbie

    Joined:
    Aug 21, 2010
    #22
    It's all good. I installed ps crystal on two white iphone 4's--no issues with either.

    Clear on white made the install a bit of a pain though.
     
  23. tobejs macrumors newbie

    Joined:
    May 5, 2011
    #23
  24. tobejs macrumors newbie

    Joined:
    May 5, 2011
    #24
    Question: iPhone off for 12-24 hours?

    Best Buy installed iPhone Zagg Invisible Shield, then said we had to be careful handling our iPhones for 12-24 hours. (Black iPhone works fine; white's proximity sensor stopped working.)

    In looking at Zagg site, I found this FAQ:

    Installation video starts with the instruction to leave device off 12-24 hours.

    We both used our phones during this period. Did others who have had no problem follow Zagg instructions? Did others with Best Buy installation get the proper instructions?
     
  25. tobejs macrumors newbie

    Joined:
    May 5, 2011
    #25

Share This Page