Why is MacRumors front page so slow to load?

Discussion in 'Site and Forum Feedback' started by realtwang, Jul 7, 2015.

  1. realtwang macrumors member

    realtwang

    Joined:
    Sep 2, 2010
    #1
    For about the last 6 months, I've experienced a painfully slow page load on the MacRumors site. It's my home page in Safari. This has happened on both Mavericks (10.9.5) and Yosemite (10.10.3). I get about one story and part of the second one, and no sidebars. I'm on a 25mbps cable connection, and usually get about 23mpbs. This is the only site that loads this slow on Safari. What might be happening?

    I've tried totally clearing Safari out, and all the usual stuff. I'm running a 2011 MBP core i7 2.3GHz with 16GB RAM. Most other pages load lightning fast.
     
  2. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #2
    Where are you located geographically?

    It could be ads, it could be something else. How slow we talking. Can you give me how roughly how many seconds for page to first start loading where you can read content, and then when it's completely done?
     
  3. realtwang thread starter macrumors member

    realtwang

    Joined:
    Sep 2, 2010
    #3
    I am in Nashville.
    3-4 seconds to see first content, and 16-18 seconds for the page to fully load. I timed it 3 times, clearing Safari each time. Slowest was 21 seconds.

    And, I tested it on Firefox, 5 seconds for full page load. Seems to only be a Safari issue...
     

    Attached Files:

  4. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001

Share This Page