Why is YouTube so bad on iPad?

Discussion in 'iPad Tips, Help and Troubleshooting' started by Soundburst, Mar 31, 2011.

  1. Soundburst macrumors 6502a

    Joined:
    Oct 4, 2006
    #1
    Fibre optics broadband. 10mb. Wireless. My MBP will load a super high quality YouTube video with ease on the network. . . Yet the iPad runs like a dog and can't load videos without needing two hours to buffer the video you want to watch (that's if it bothers to load it at all). This is m.YouTube.com and the actual app. Why is it iso awful?
     
  2. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
  3. Soundburst thread starter macrumors 6502a

    Joined:
    Oct 4, 2006
    #3
    If I give you a link . . .will you click it on your iPad and tell me if it runs without any intervention? Please :)
     
  4. Mac'nCheese macrumors 68030

    Mac'nCheese

    Joined:
    Feb 9, 2010
    #4
    I will.
     
  5. Soundburst thread starter macrumors 6502a

    Joined:
    Oct 4, 2006
    #5
  6. Mac'nCheese macrumors 68030

    Mac'nCheese

    Joined:
    Feb 9, 2010
    #6
  7. Soundburst thread starter macrumors 6502a

    Joined:
    Oct 4, 2006
    #7
    Thanks a lot for taking the time to do this mate :)
     
  8. Mac'nCheese macrumors 68030

    Mac'nCheese

    Joined:
    Feb 9, 2010
    #8
    Duh, meant 6PM but she finished early and don't worry, I got my first ipad yesterday and any excuse to play with it... anyway. My ipad 2 is hooked up through a plain old airport which is hooked up to a regular old cablevision modem. When I clicked on your link, it opened the youtube app pretty fast but it took maybe ten seconds to load the video itself. Once loaded, it played straight though, no problems.
     
  9. Soundburst thread starter macrumors 6502a

    Joined:
    Oct 4, 2006
    #9
    Why won't mine work :(:(:(

    I can load the video. . It'll load up grand. . .but it will buffer unbelievably slowly and will pause after about 4 seconds of that video while it buffers again. I on an airport express n router, and on speedtest.net I get 9.5mb download..

    It's bewildering :(
     
  10. Hydrocity macrumors 6502a

    Joined:
    May 14, 2010
    #10
    Works for me also. Although the quality was bad, so I'm not sure if I was watching it in sd or if the video is naturally like that
     
  11. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #11
    +1 for the cablevision modem. ( I hope the iPad app gets approved so I can watch tv on my iPad!!! Lol
    I dont know if it's mee but I also have problem with my YouTube app. Search for my thread. Eveytimr I open a YouTube link in safari and I go back to safari it crashes and I have to start over again...
     
  12. adrianeitor92 macrumors newbie

    Joined:
    Mar 24, 2011
    #12
    Now I have a 6Mbps broadband at home and YouTube is very slow specially in my iPhone 4 and iPad 2
    This month I will have optic fiber with 100Mbps
    I hope it will improve
     
  13. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #13
    I get 15mpbs down and there are times (esp in the evening) where some YouTube videos will stutter on all devices in the house, inc. my roommates Win7 laptop.
     
  14. Mac'nCheese macrumors 68030

    Mac'nCheese

    Joined:
    Feb 9, 2010
    #14
    I haven't heard of this. Are you joking or is there going to be a cablevision app that will let me watch cablevision on my pad?
     
  15. diabolic macrumors 68000

    Joined:
    Jun 13, 2007
    Location:
    Austin, Texas
    #15
  16. adiemus macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    North of Boston
    #16
    Change your DNS settings

    Try to change your DNS server settings. I had the same problem, found a post on another site recommending use of different name servers. Here's how:

    Settings --> Wi-Fi
    Tap the blue arrow next to your wireless network
    Tap in the DNS text field and delete anything that's in there already
    Now, enter the new name server IPs

    There are a couple of options:
    Google's public DNS: 8.8.8.8, 8.8.8.4
    Open DNS: 208.67.222.222, 208.67.220.220

    I currently use Google's name servers, but others might work better for you.

    PS - you can do this on your iPhone, home computers, etc which might help "speed up" your Internet connection ( though it really isn't affecting the speed of your connection)

    Enjoy!
     
  17. shareef777 macrumors 68000

    shareef777

    Joined:
    Jul 26, 2005
    Location:
    Chicago, IL
    #17
    Same here.
     
  18. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #18
  19. Blorzoga macrumors 68030

    Blorzoga

    Joined:
    May 21, 2010
    #19
    Runs like clockwork. You must have a lemon.
     
  20. HarryPot macrumors 6502a

    Joined:
    Sep 5, 2009
    #20
    I'm also having terrible download speeds in the YouTube app, tho playing the videos thru safari is fast as in my Mac. So I'm guessing the problem is within YouTube app and not the iPad or the network.
     
  21. Bacong macrumors 68000

    Bacong

    Joined:
    Mar 7, 2009
    Location:
    Westland, Michigan
    #21
    Youtube is garbage to me on almost any device I use it on. I get 30 MB down and line quality is excellent.
     
  22. tazmando macrumors newbie

    Joined:
    May 14, 2011
    #22
    Adiemus, this worked for me although I used my ISP DNS, you gave me the solution I was looking for. Cheers
     
  23. mutchy126 macrumors regular

    Joined:
    May 8, 2011
    Location:
    UK
    #23
    YouTube is Ok with my iPad when on Wi-Fi, But It is rubbish on EDGE or 3G for me!! :confused:
     
  24. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #24
    That's due to the throughput and line quality being substantially worse on a mobile data connection, especially EDGE. It all depends on your provider and where you are, it has nothing to do with iPad or iOS.
     

Share This Page