iPhone XS Wi-Fi Calling is not stable

Discussion in 'iPhone' started by davewolfs, Oct 12, 2018.

  1. davewolfs macrumors regular

    Joined:
    Jul 13, 2007
    #1
    I don’t know what is going on but with my 7 and 6 we’ve had zero issues with T-mobile Wi-Fi calling for over a year.

    The other week we both upgraded to XS phones and now have terrible Wi-Fi calling. I don’t know if it’s the phones, T-mobile or both.

    I have UniFi access points and it shows that the signal is perfect. Doesn’t matter if I’m 3 ft or 10ft from my router I am getting random calls failing. My internet is very stable (fiber). Really haven’t seen this before only after upgrading.

    Any thoughts?
     
  2. Jordan921 macrumors 601

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #2
    I’m using WiFi calling and not having any issues with my Xs Max. I only get 1bar of at&t LTE service at my house so without WiFi calling I’d be screwed.
     
  3. seezar macrumors regular

    Joined:
    Jan 18, 2018
    #3
    Have you upgraded to 12.0.1? There were supposed to be some Wi-Fi fixes.

    I haven't had any issues on my Max with T-Mobile WiFi calling.
     
  4. davewolfs thread starter macrumors regular

    Joined:
    Jul 13, 2007
    #4
    Yes we did this afternoon. Still bad.
     
  5. mritech macrumors regular

    Joined:
    Jul 29, 2015
    #5
    I have low bars with WiFi calling it goes up and down. I think it may be using the bars as the real signal and the WiFi calling to back it up (this is my theory on how this works).

    But all I know is that it works and I can be on the phone for hours. So if you’re not dropping calls then does it really matter?

    Also every time you get a new phone you have to set it up also. I had to call Verizon cause I have some blockage and they had to enable the feature
     
  6. KlingonSpy macrumors newbie

    KlingonSpy

    Joined:
    Dec 26, 2017
    #6
    Pardon the newbie question, but what is wifi calling and how do you set it up on a iPhone X?
     
  7. Jordan921 macrumors 601

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #7
    WiFi calling is usually for people who have bad service wherever they are. So instead of going off your provider for service for calls it uses your WiFi signal. Just go into settings > cellular > WiFi calling and turn it on and set it up.
     
  8. KlingonSpy macrumors newbie

    KlingonSpy

    Joined:
    Dec 26, 2017
    #8
    Thanks for the quick response. I checked the settings you gave me and I don't have one called WiFi Calling. I have one called wifi assist. Is that the one your referring to or is the WiFi calling carrier specific?
     
  9. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #9
    WiFi calling is more carrier related and would be under those settings, if available (might need to be enabled on the carrier side and/or might need a particular plan or feature on account to be available).

    Some recent discussion relating to it all at https://forums.macrumors.com/threads/has-anyone-else-disabled-wifi-calling.2145837/.
     
  10. Jordan921 macrumors 601

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #10
    No there should be a tab called WiFi calling. Not sure if your carrier has it or not.
     

    Attached Files:

  11. maccuser macrumors regular

    Joined:
    Aug 28, 2007
    #11
    I literally started having wifi calling issues this week. The phone wouldn't go to wifi calling even with no signal and on airplane with wifi on. I have the xs max on Verizon. Actually didn't have a problem at the beginning but its been acting up and also dropping calls. Never had any issue
     
  12. davewolfs thread starter macrumors regular

    Joined:
    Jul 13, 2007
    #12
    Well. What a pain this has been.

    I literally updated all software/firmware across my lan. Still had the issue.

    Than realized something off at the router level - called ATT and they did some special reset. So far so good. Hopefully it holds up.
     
  13. Starship67 Suspended

    Starship67

    Joined:
    Oct 28, 2017
    Location:
    LA
    #13
    I don’t need WiFi calling, but perhaps it’s your WiFi that’s the issue.
     
  14. Böhme417 macrumors 6502a

    Joined:
    Mar 11, 2009
    #14
    I've never had great success with wifi calling on any iPhone. I often end up turn the wifi off during the call to clear it up. Either the caller says it's breaking up and they can't hear me, or I have problems with it breaking up and hearing them. I don't understand this, because I have taken wifi calls from my mac and iPad that sound nearly perfect. And I don't think it's a wifi issue. I have reliable enough connections at home and work with the same results.
     
  15. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #15
    My 6S would literally drop wifi calling calls after 15 seconds, like clock work. After trying a dozen things including "restarting the Airport Extreme base station" via the AirPort utility I power cycled the router manually (unplugged and plugged back in) and it fixed it back to the same QoS I had before.

    Once I performed a "restart" on the router I dismissed it as being the problem (why have a restart function if it doesn't completely restart it?) and proceeded to pull my hair out casing ghost.

    While this may not be your problem with wifi calling, your router (I don't know the specifics for yours) is using functions it doesn't normally use to prioritize voice and its using ports it doesn't normally use. Everything else on the network can seem fine even the iPhones wifi however that doesn't mean the network can be ruled out, even if you have good speed.

    From there your carrier has specific servers for wifi calling that need to be functioning at 100%, etc etc...

    Although I do everything I can to avoid it, you can use the "reset network settings" function in Settings > General > Reset > Reset Network settings. I have so many wifi addresses I use and other settings that it makes reseting networking settings a last resort.
     
  16. roncron macrumors 6502

    roncron

    Joined:
    Aug 15, 2011
    #16
    I use WiFi calling a lot, and it’s always worked well for me. Cellular coverage is spotty at home and at work. I used to use a Verizon network extender at home. Now I just use WiFi calling. At home or work, I usually keep I my phone in airplane mode which saves battery since the phone isn’t always hunting for a cellular signal. Calls on WiFi calling are crystal clear and 100% reliable for me, whether incoming calls or calls I make to others.

    WiFi calling is carrier-specific. I’m on Verizon. It might work differently on other carriers, or not at all.

    Good luck.
     

    Attached Files:

Share This Page

15 October 12, 2018