Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

WiFi Encryption Does Not Seem to Work

infosprt

macrumors regular
Original poster
Jun 29, 2007
237
0
Temecula, CA
It seems that the iPhone will not work when using a WiFi system with encryption. The only way I could get it to work was to remove the encryption from my home network.

I am very surprised that this problem was not fixed prior to iPhone availablility. I sure hope Apple acknowledges the problem and issues a fix for it ASAP.

-Al
 

r6girl

Administrator/Editor
Staff member
Sep 6, 2003
1,726
49
Massachusetts
i have WPA encryption enabled on my home network (airport express base station) and my iphone connects and works with it with no problems...
 

killerrobot

macrumors 68020
Jun 7, 2007
2,239
3
127.0.0.1
I was asking if he was running WEP or WPA/2 encryption.
The second part was meaning if Apple doesn't fix this problem (this guy isn't the first that can't connect via WIFI), it's going to make everyone run off of EDGE all the time and slow down internet speeds. Sorry for the confusion.
 

[G5]Hydra

macrumors regular
Jul 2, 2004
151
0
It seems that the iPhone will not work when using a WiFi system with encryption. The only way I could get it to work was to remove the encryption from my home network.

I am very surprised that this problem was not fixed prior to iPhone availablility. I sure hope Apple acknowledges the problem and issues a fix for it ASAP.

-Al

Make sure you select the hex key option if you are using one. The iPhone will let you enter your key and connect and show bars etc but it won't work. When setting up and entering the pw/key make sure you tap the ">" next to the "WEP Password" on that screen. It is kinda subtle and easy to miss. Once you enter and ok it you can't go back and change this however, you need to make the iPhone forget your network and then re-add it doing what I said above. If that doesn't work reset all the network connections.
 

seamuskrat

Contributor
Feb 17, 2003
889
5
New Jersey USA
How are you resetting all network connections on the phone?


[G5]Hydra;3846580 said:
Make sure you select the hex key option if you are using one. The iPhone will let you enter your key and connect and show bars etc but it won't work. When setting up and entering the pw/key make sure you tap the ">" next to the "WEP Password" on that screen. It is kinda subtle and easy to miss. Once you enter and ok it you can't go back and change this however, you need to make the iPhone forget your network and then re-add it doing what I said above. If that doesn't work reset all the network connections.
 

barbourdg

macrumors member
Dec 23, 2002
65
0
dallas
Its the Hex Key Password. Had same problem last night, now it works perfect.

You have to delete the wifi location you found.

Then let your iphone find your local wifi again.

Then when it asks for password, hit the other option key (to the right). Then it states to enter your Hex Key Password. Then you should be ready to Rock n Roll
 

marksman

macrumors 603
Jun 4, 2007
5,764
5
To ultimately get mine to work I had to use a $ before my hex code. It accepts it now. However I still can not get the phone to use my wifi.
 

njon99

macrumors newbie
Jun 30, 2007
2
0
Password type selection matters

I had issues with connecting to my WiFi protected by WEP. In my case my router was configured for 128 bit encryption using an ASCII password. Once I changed my password choice to "Hex or ASCII password" (going by memory here - it might say something a little different), it worked like a charm.
 

arn

macrumors god
Staff member
Apr 9, 2001
15,528
4,063
I had issues with connecting to my WiFi protected by WEP. In my case my router was configured for 128 bit encryption using an ASCII password. Once I changed my password choice to "Hex or ASCII password" (going by memory here - it might say something a little different), it worked like a charm.

Just to emphasize this post. I had the same problem. I was typing in my Hex password (0FBAxxxxx) when it asked for the Wifi Password.

But that won't work. Go back and tell the iphone to "forget" your WIFI network from the settings.

Then it will show up again, click on it, and it will as for the Wifi Password. Click on "Wifi Password" and it will give you the option to enter "Hex or ASCII". Do that, and then enter the Hex code or whatever

arn
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.