wifi is connected... but it ain't?

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,653
2
hey,

i am not connected to wifi, thoughi go to settings/wifi and it shows a check mark next to my network...when i am at the home screen it shows that i am on odge, not wifi. the 'E', not the dot with arcs...


...and browsing is slow...

why so?
how to fix?


r.
 

poppe

macrumors 68020
Apr 29, 2006
2,199
32
Woodland Hills
hey,

i am not connected to wifi, thoughi go to settings/wifi and it shows a check mark next to my network...when i am at the home screen it shows that i am on odge, not wifi. the 'E', not the dot with arcs...


...and browsing is slow...

why so?
how to fix?


r.
I have that same problem... Sucks... WiFi seems to be a hit or miss set up type thing...
 

MattyMac

macrumors 68000
Oct 6, 2005
1,691
7
NJ/NYC
I've been having the same problem and many others on these forums have too.

"Renew Lease"???? I don't see this anywhere in the settings. If it works...please explain where to access this. Thanks!
 

milk242

macrumors 6502a
Jun 28, 2007
690
9
what kind of wireless security are you using on your router (wep, wpa) and is it a passphrase or hex code. If its hexcode then change the security setting in the iphone wifi to hex (default on iphone for wep is passphrase)
 

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,653
2
what kind of wireless security are you using on your router (wep, wpa) and is it a passphrase or hex code. If its hexcode then change the security setting in the iphone wifi to hex (default on iphone for wep is passphrase)
i can't seem to find where to do the security settings on the phone....

but renewing the lease does not work....


still on edge, no wifi...

hm mmmmm.

r.
 

milk242

macrumors 6502a
Jun 28, 2007
690
9
so do you have security settings for your wireless network?

I don't have my iphone with me but i believe the security settings is where you can also see which wireless network your on.
 

jeshepard

macrumors member
Jan 23, 2006
53
0
Had the same issue yesterday. Switched over to the router that my work gave me with the same security settings and it worked. Probably not the ideal solution. My old routers was a D-Link DI-524 while my new one is a Netgear WGR614. Try and find someone else with a router and test it out on theirs.
 

Goldenbear

macrumors regular
Jun 30, 2007
226
3
Los Angeles
I usually see this problem (the EDGE symbol is showing) when the wi-fi signal is weak.

If the wi-fi symbol is showing, but you can't seem to connect to anything, renewing the lease seems to work for me.
 

poppe

macrumors 68020
Apr 29, 2006
2,199
32
Woodland Hills
I'm six inches from the router and the WiFi still doesn't work. Renewing the lease doens't work for me.

WEP didn't work. Changing WEP to WEP Hex ACS II didn't work. Changing it to WPA still didn't work...

Sucks bad as everywhere else I go I can get it to work.

Mac Filtering is not on.

The DNS is put in the same as my router.

But I get nothing.
 

gr8tfly

macrumors 603
Oct 29, 2006
5,298
48
~119W 34N
Try changing your access point's (base station) channel. Especially if you have any other networks showing up on the list (besides your own). Move it at least a few channels away from your current channel.
 

poppe

macrumors 68020
Apr 29, 2006
2,199
32
Woodland Hills
What brand router do you have? is it set to 802.11n only?
The router giving me trouble is a Belkin Wireless G

Try changing your access point's (base station) channel. Especially if you have any other networks showing up on the list (besides your own). Move it at least a few channels away from your current channel.
How exactly do I do that? There are a lot of other networks that come up.

Would this perhaps solve the problem of my iPhone saying "Safari could not connect to the server" (or what ever it says)?
 

gr8tfly

macrumors 603
Oct 29, 2006
5,298
48
~119W 34N
The router giving me trouble is a Belkin Wireless G



How exactly do I do that? There are a lot of other networks that come up.

Would this perhaps solve the problem of my iPhone saying "Safari could not connect to the server" (or what ever it says)?
It's under "Wireless > Channel and SSID" (in the router's web configuration pages).

It might help with the "not connecting to server", if there's another network that's on your channel, it could make it difficult to maintain a good connection. That, in turn, might affect the iPhone getting configuration data from the Belkin's DHCP server.

Usually, the symptom of being on the same channel is getting "bumped off" once in a while.

If you have a strong signal, but still have trouble connecting to the internet (server error), try entering your ISP's DNS IP address manually. You will see it in the Belkin's configuration Status page. On the iPhone, If you touch the right arrow for your network, you will see the configuration info. You can select and edit the IP for DNS. Of course, this is still assuming you are getting at least an IP address assigned [from the Belkin DHCP] for the iPhone ("IP Address" - should be 192.168.2.x).
 

n8236

macrumors 65816
Mar 1, 2006
1,039
8
If you have already tried "WEP" and "WEP hex or ASCII," try going to back to the list of available networks and choose "Other..."

There you can choose from two more pw types, "WPA" and "WPA2."

Update: Use 64bit instead of 128bit security. No more password incorrect messages.
 

Belisarius

macrumors newbie
Oct 25, 2003
20
2
South Carolina
hey,

i am not connected to wifi, thoughi go to settings/wifi and it shows a check mark next to my network...when i am at the home screen it shows that i am on odge, not wifi. the 'E', not the dot with arcs...


...and browsing is slow...

why so?
how to fix?


r.
I had this very thing happen to me yesterday at a restaurant. The iPhone could see the wireless network, but failed to obtain an IP address from the DHCP server. I tried telling it to renew the DHCP lease a few times, to no avail. Never did figure it out.
 

G4R2

macrumors 6502a
Nov 29, 2006
546
2
I had a similar problem with a Netgear Wireless G router that I set up at my in-laws house. The router was set for 802.11g only and I simply could not log on. I was about to give up on it entirely and write it off as an early adopter glitch but then I found I couldn't connect with a device they were hoping to use the router with.

The solution was to set the router for both 802.11 b and g. I have no idea why it worked but since I had success with that device I can only share my experience here in the hope that it will be helpful to others who may have a similar problem.
 

redmeister

macrumors 6502
Jan 26, 2007
272
2
I had a similar problem with a Netgear Wireless G router that I set up at my in-laws house. The router was set for 802.11g only and I simply could not log on. I was about to give up on it entirely and write it off as an early adopter glitch but then I found I couldn't connect with a device they were hoping to use the router with.

The solution was to set the router for both 802.11 b and g. I have no idea why it worked but since I had success with that device I can only share my experience here in the hope that it will be helpful to others who may have a similar problem.
how did you go about doing this on your router? after logging in on routerlogin.net correct? I have the same type of router and can't seem to find the option to turn b and g on anywhere once i've logged in as admin to my router
 

G4R2

macrumors 6502a
Nov 29, 2006
546
2
how did you go about doing this on your router? after logging in on routerlogin.net correct? I have the same type of router and can't seem to find the option to turn b and g on anywhere once i've logged in as admin to my router
I was installing the router for my in-laws. It was an old Netgear 614v4 router. I believe the way to access the web interface is by opening the browser to http://192.168.0.1

The default username is admin and the password was simply 'password.'

If I recall correctly you can set up the wireless mode from the main Wireless Settings page. The option should appear as a drop down menu underneath where you set up the SSID, the Region, and the Wireless Channel.

If you have a different router you can get the PDF version of the manual online at Netgear.com.