wifi problems with lion

Discussion in 'Mac OS X Lion (10.7)' started by Xgamer1224, Jul 20, 2011.

  1. Xgamer1224 macrumors regular

    Joined:
    Jul 11, 2008
    #1
    when i had snow leopard, i was easily able to connect to the wifi in my home. however, with the lion installed, i am having problems. i am able to connect to the network but there is no internet connection. i tried resetting the modem and router and turning the wifi off and on on my macbook pro but still the same result. anyone else having problems similar to mine and have any tips to fix it?
     
  2. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #2
    Rebooting your MB and the router are my first tips. Sounds like you've already done that though. Are you close to your router? Perhaps there's a weak signal issue.
     
  3. Xgamer1224 thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #3
    yes i am right next to it. and yeah i rebooted everything.
     
  4. eternalife macrumors regular

    Joined:
    Jul 21, 2011
    #4
    similar problems

    I have similar wifi problems. When I put my MBP to sleep and wake it up WiFi doesn't work. I have to turn WiFi off and back on to get it to work.
     
  5. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #5
    Snap!

    I upgraded to Lion this morning, and my WiFi hasn't worked right since.

    I can connect to networks no problem, but the internet just doesn't work. Network diagnostics indicates green up to network settings, but red from ISP onward.

    I've rebooted my MBP, and the router (although it's working fine for other computers), and I've tried sharing internet via wifi from an iMac right beside my MBP, so signal isn't an issue.

    If I connect via ethernet everything works fine, but that'll be incredibly inconvenient when I go home from work!
     
  6. Fredly macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    Same WiFi Problem

    I installed Lion this morning on both of my iMacs. Lost the Internet on both. The computers connect to the wireless just fine, but no internet connection. Tried rebooting the computers, restarting the Airport. Nothing works.
     
  7. gazrsvr macrumors newbie

    Joined:
    Jul 21, 2011
    #7
    I had a similar problem trying to get internet sharing working. My iPad was showing connected wirelessly, but would not connect to the internet. My solution was to re-enter/replace the password in the security settings and it then connected. Might be worth a try?
     
  8. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #8
    I tried removing all networks from the preferred network lists, renaming and changing security settings the networks, trying different networks... nothing helps.

    It seems like I can't even reinstall Lion unless I re-download the whole 4GB again?!

    Maybe loads of people are suffering from this problem, but they just can't get online to tell us...
     
  9. djmakk macrumors newbie

    Joined:
    Oct 8, 2009
    #9
    same problem, I get a network connection but I cant get an internet connection. Ive tried all the usual stuff (plist delete, permissions etc.)
     
  10. IzzyJG99 macrumors 6502

    Joined:
    Oct 26, 2007
    #10
    My Wi-Fi was dropping every 5-10 minutes. Console read outs said "overload." I would have to turn my Airport Card off and then back on and it would work again for 5-10 minutes. Same thing.

    I changed my Airport Express to Channel 7 instead of Automatic and it fixed the problem. I also changed it to only broadcast in 802.11G. According to the Apple Store there is a problem with 802.11N in Lion right now. Also might have something to do with IPv6 because when my Wi-Fi was working certain widgets were not and according to Tech Support some widgets use IPv6. Once I fixed the Wi-Fi issue...the widgets worked.

    Evidently there is going to have to be a serious update to Wi-Fi for Lion put out soon.

    I should also mention that there is some speculation that anything that monitors your TCP/IP throughput might cause Wi-Fi to disconnect in Lion. I used "Menumeters" for many years and though they claim to be 10.7 friendly now in version 1.5, I don't fully buy it fully yet.
     
  11. Lava Lamp Freak macrumors 65816

    Joined:
    Jun 1, 2006
    #11
    I have the same problem on my Mac Pro and my MacBook Air. On both machines I didn't have an internet connection after upgrading, even though it showed it was connected to my router, and I had to turn wifi off and back on for it to start working. And now it still occasionally says I'm not connected to the internet after waking from sleep. I have to turn if off and back on again to fix it.

    I never had a single issue with wifi under Snow Leopard.
     
  12. El Jefe, Jul 21, 2011
    Last edited: Jul 21, 2011

    El Jefe macrumors member

    Joined:
    Jun 22, 2010
    Location:
    Dallas, Texas
    #12
    Remove Avast

    I had the same problem. If you have Avast antivirus installed, for some reason it's blocking the Internet connectivity even if you're connecting fine to your WiFi network.

    If you have it, uninstall Avast and see if that does it.

    This is where I found that resolution: https://discussions.apple.com/thread/3189489?start=30&tstart=0

    Update from Avast:

    http://forum.avast.com/index.php?topic=78646.45
     
  13. webjprgm macrumors newbie

    Joined:
    Jul 20, 2011
    #13
    I have a similar problem with wifi in Snow Leopard 10.6.8 on my 2011 iMac. Only that one machine is affected, it connects but after anywhere from 30sec to 10min it stops working and I have to disable and re-enable wifi to get it to work again.

    I have not determined whether this is a hardware issue with my new machine, or whether it is software with the 2011 iMac special version of 10.6.8. I was hoping that upgrading to Lion would solve this (have downloaded Lion but not installed it yet). So maybe the hardware-specific version of 10.6.8 has the same software glitch as Lion?

    I'll keep playing with this, hoping for easy solution ...
     
  14. fivesheep macrumors newbie

    Joined:
    Jul 21, 2011
    #14
    Same thing happens here. my iMac 2011's wifi acts weird since 10.6.8, I have to manually turn off/on the wifi adapter to get it work especially after waking up from sleep. Lion makes it even worst, even rebooting couldn't fix the problem.
     
  15. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #15
    I have an iMac, a 2010 Air, and a 2009 Macbook Pro. I was just getting ready to upgrade to Lion on my Air but this WiFi issue is holding me back. Didn't really want to upgrade the iMac first because it is my workhorse. Don't want to do the MB Pro first because that's my wife's machine and she'll be really bent if she can't get on the internet.

    It sounds like this is a hit or miss WiFi issue, has anyone that was having issues found a solution?
     
  16. zedtech78 macrumors newbie

    Joined:
    Mar 30, 2011
    Location:
    Toronto, Canada
    #16
    Sounds exactly what's been happening to me too. Hopefully a fix will be out soon.
     
  17. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #17
    I was having serious Wifi problems last night, but it might have been my internet. I'm not exactly sure. Will report back later
     
  18. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #18
    When I got home I'd expected big problems trying to connect, I was about to change the 802.11N setting as IzzyJG99 suggested, but before I could find it the internet just started working!

    All I did was look about in the advanced WiFi setting, I changed a few settings looking for the N/G/B settings, but I didn't find it and didn't save any changes.

    I just hope it doesn't randomly stop working again next time I take it away from my home network!
     
  19. zedtech78 macrumors newbie

    Joined:
    Mar 30, 2011
    Location:
    Toronto, Canada
    #19
    I've found a workaround for this that seems to be working on my 2011 MBP.

    1. Systems Preferences -> Network
    2. Under "Wi-Fi", click on the "Advanced" button.
    3. Under the "DNS" tab, add the Google Public DNS - 8.8.8.8
    4. Click OK, then click Apply.
    5. Turn WiFi OFF, then turn it back ON again.

    Hopefully there's a fix for this soon but so far, this works like a charm on my MBP. Way better than manually having to turn wifi off and back on again every time I wake the laptop from sleep.

    Good luck!
     
  20. Jony Mac, Jul 22, 2011
    Last edited: Jul 22, 2011

    Jony Mac macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
  21. Jony Mac macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #21

    Same problem here.

    I noticed with Lion, if I put my MacBook to sleep (close the lid) and re open it, the wireless gets dropped. In SL it would automatically join back to the wifi.

    The only way I can fix this in Lion is to goto the Wireless icon in the task tray and manually select my hot spot.

    I wish there was a fix. I opened a thread for this because I got lost in the lion mess. Sheesh
     
  22. chalkie macrumors newbie

    Joined:
    Jul 21, 2011
    #22
    Avast

    If you've got Avast uninstall it. There are issues with it blocking internet access (wired and wireless) in Lion
     
  23. Hasankra macrumors newbie

    Joined:
    Jul 23, 2011
    #23
    Same problem here, everything worked fine on my macbook air(early 2011) until i upgraded it to os x lion. Since then internet doesnt work. None of the apple apps connect to the internet (safari, itunes, app store or software update helper etc.) but the weird thjng is google chrome and jdownloader seem to work just fine. i reinstalled lion today but the problem persists. i hope apple fixes it soon because it's really annoying not to be able to use internet requiring apps.
     
  24. carl201167 macrumors regular

    Joined:
    May 31, 2005
    Location:
    London, UK
    #24
    Yep, my experience too. My 2011 MBP not only can't pick up wifi, but it appears to crash the wifi network entirely for my house - meaning my wife's older macbook on snow leopard stops being able to use wifi too.

    I spent an hour talking to my ISP this morning and verified the internet connection is fine (I'm writing this connecting via ethernet).

    In the end we hard-reset my router and that worked fine on the macbook, but crashed again for everyone when I fired up the Lion MBP :eek:

    I wonder if it only affects certain routers - I'm going to try a different one this evening.
     
  25. BenEndeem macrumors 6502

    Joined:
    Jul 25, 2008
    Location:
    England
    #25
    Had this with Lion and tried practically everything:

    PRAM resent
    SMC reset
    Removing Wi-Fi and adding it again in System Preferences
    DNS changes
    Cache flush
    Permissions repair

    No Avast installed or anything else pointed to as possible causes.

    Apparently it isn't a known issue, but going by the Apple Support Forum, I'd think otherwise.
     

Share This Page