Wifi stays on during sleep? (lock)

Discussion in 'iPhone' started by wordoflife, Jul 3, 2010.

  1. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #1
    Hi
    I've been having some serious battery life issues with my 3GS running iOS4. At night, I lose 60%-70% percent battery life. I figured that it was that the Wifi would always stay connected. I enabled Airplane mode last night, and I only had 1% drop during the night.

    Does this happen to anyone else? How can I fix it? Is it an iOS 4 bug?

    Thanks in advanced.
     
  2. 0wen macrumors newbie

    Joined:
    Jul 11, 2008
    #2
    It might be an IOS4 issue as I seem to have the same problem with my iPhone 4 as I will be at 100% when I go to sleep and at 70% or less when I wake up.
     
  3. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #3
    The short answer is that yes, this is an iOS 4 bug. I had the same problem with my 3rd generation iPod Touch after updating it to iOS 4. Someone on this board suggested setting up the device as new instead of restoring from a backup, and once I did that, the problem went away, even if I didn't put it into Airplane Mode. Apparently, there was some process left over from 3.1.x that kept running after the upgrade, and that was corrected when I set up the device as new. You will lose your settings and such if you do it this way, but it will solve your battery drain problem.
     
  4. Amnesia87 macrumors 6502

    Joined:
    Jun 19, 2010
    #4
    I have pretty much the exact opposite problem. My phone shuts off wifi when it locks and then when I unlock it I have to go into settings and do renew lease to get connected again.
     
  5. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
    #5
    It's not a bug. It is a feature. With AT&T limited data plans, if there is WiFi available it should utilize it.
     
  6. wordoflife thread starter macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #6
    It's a bit annoying though, that when your not using any form of data, you still lose a lot of battery life from Wifi still staying connected. I disabled notifications and the problems seemed to be solved. Let's hope Apple fixes it soon.
     
  7. FireSokar macrumors regular

    Joined:
    Jun 21, 2010
    #7
    The battery loss is from the nature of wifi and how it works, I like the always on wifi myself, if you have issues just toggle wifi off @ night.
     
  8. Ron21 macrumors 6502a

    Joined:
    Sep 6, 2007
    #8
    It's a new feature in iOS 4, called Persistent WIFI. Not a bug.
     
  9. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #9
    Well yes, that is a feature, but a lot of people (myself included) have seen it drain the hell out of a battery when upgrading to iOS 4 and restoring from a 3.1.x backup. Again, when I decided to start from scratch and set my device up as a new device on iOS 4, the problem was fixed. Apple Support acknowledged that some process left over from 3.1.x was the reason that the battery was being drained, and that after setting it up as new, that process would be gone and the battery would no longer drain so fast, even if Wi-Fi & notifications were left on.
     
  10. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #10
    I had/have an issue with my 3G (don't think it happens with iOS4 anymore) where it would run out of battery in a couple of hours from a full charge and never make it overnight. This issue only came up every few days, and wouldn't surface when Airplane mode was on.

    I always attributed that problem to it always 'talking' to the cell towers (not using data) because I always got the GSM buzz.
     
  11. koopa35 macrumors 6502

    Joined:
    Aug 7, 2008
    Location:
    Los Angeles, CA
    #11
    mines shuts off as well but upon waking it reconnects

    ________________________
    wifi should only stay on , on the ipod touch. on iphone 4 when it sleeps wifi sleeps and 3g is on. when i wake I see it switch from 3g to wifi 100% of the time. i lose about 5% at night while its sleeping.


    http://www.apple.com/ipodtouch/ios4-software-update.html


    http://www.apple.com/iphone/softwareupdate/

    wifi shouldnt stay on while the iphone sleeps. mines dont and nvr did on my 3g/s either
     
  12. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #12
    I believe it's more of a fix, than a bug, like someone stated. On my iPod touch, I had my mail set to fetch every 30 minutes and it was really hit and miss. Many times I would wake up and it would not have fetched my mail the entire night. I eventually installed "Insomnia" from Cydia to solve this problem, but yes, it did show noticeable battery drain. Hopefully, Apple can optimize this better in the next update!
     
  13. Maverick1337 macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #13
    I don't see persistant wifi happening on my iPhone 4. When I'm on wifi and I lock my phone, when I unlock it, it shows 5 bars of 3G for a brief second then flips to full bars wifi. I thought it stayed connected?
     
  14. koopa35 macrumors 6502

    Joined:
    Aug 7, 2008
    Location:
    Los Angeles, CA
    #14
    people are confused i think. as ive said on iphone wifi sleeps when the phone sleeps. wifi always on feature is for the ipod touch only.
     
  15. mbob macrumors member

    Joined:
    Jul 8, 2009
    #15
    I agree something is not right. Some times it seems to never turn off and drains fast. I too initially thought it was notifications but I am not sure now. Today I have left them all on and things seem back to normal so who knows but something is up! iOS4 is the buggiest version yet.....Exchange and battery problems for me along with slowness on my 3gs.
     
  16. wordoflife thread starter macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #16
    Hopefully it will be addressed in the next update. If it really is a feature, there should be at least an option to turn it off. Some people may not want Wifi to connect while in sleep.
     

Share This Page