WiFi to Bluetooth Handoff

Discussion in 'Apple Watch' started by rstark18, Oct 6, 2017.

  1. rstark18, Oct 6, 2017
    Last edited: Oct 7, 2017

    rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #1
    I am having an issue where if I leave my phone at one side of the house and I'm on the other side (wearing my watch) the watch will try to hold on to the Bluetooth signal even though it's too weak to make calls, use Siri, etc instead of switching over to the very strong WiFi signal. Anyone else have this problem or have any suggestions?
     
  2. deadworlds macrumors 6502a

    deadworlds

    Joined:
    Jun 15, 2007
    Location:
    Citrus Heights,CA
    #2
    Is your WiFi signal 2.4Ghz or 5Ghz? I’m asking because if it’s a 5Ghz the watch can’t connect to that, so maybe it’s holding onto the Bluetooth signal because that’s all it has.
     
  3. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #3
    I have both 2.4 & 5 but that is not the issue. If I turn off Bluetooth on my phone the watch connects to the WiFi network. So the problem is that it's holding on to a Bluetooth signal that is not strong enough to support the mentioned features even though the much stronger WiFi signal is available.
     
  4. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #4
    The watch prefers bluetooth as it's much more energy efficient. You didn't actually specify if you're having any detrimental effects by the watch continuing to use BT at the far side of the house?

    The watch will establish a wifi connection when the bluetooth signal starts to become weak and will switch to it when the BT signal is no longer viable.
     
  5. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #5
    As I said in the original post “even though it's too week to make calls, use Siri, etc “. This is detrimental in my eyes. I don’t want to have my phone in my pocket when I’m at home just so I can use my watch. I would think that if the signal isn’t strong enough to use functionally then it should switch over to WiFi.
     
  6. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #6
    Are you sure it actually is switching over to wifi? Are your 5GHz and 2.4GHz networks named the same (same SSID?). Forget the network on your iPhone. Turn off the 5GHz network. Then join your iPhone to it. Then disable bluetooth on the iPhone and see if the watch connects to the wifi network. (if you're comfortable looking at the client list in your WAP/router, that would verify it as well).

    Once the watch is connecting properly to the 2.4GHz segment, you can re-enable the 5GHz one, it won't get confused.

    What kind of WAP do you have?
     
  7. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #7
    Two different SSID’s.

    See post #3. It’s not that it can’t connect to WiFi. It can and will IF I turn off Bluetooth OR if my phone is far enough away to loose the Bluetooth signal.

    I don’t care if it’s using Bluetooth or WiFi. I just want my watch to work when I’m not next to my phone. This is currently not happening at far reaches of the house because as I previously said it still hangs on to the BT signal but it’s not strong enough to use Siri, phone, etc.
     
  8. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #8
    And....that's twice now that you've pointed me backward. (you have to keep in mind that most people here have no clue as to how any of this **** works). Most assume it's doing X when it's actually doing Y.

    Not answering queries only means I'll not bother with troubleshooting anymore. Cheers.
     
  9. co1f macrumors regular

    Joined:
    Oct 14, 2014
    #9
    One suggestion is to turn off BT on your phone. Sounds like you should report that as a bug. I have not experienced that, but my house isn’t that large.
     
  10. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #10
    I am having the same problem as the original poster. I prefer not to carry my phone around the house and my Wi-Fi signal is better for incoming phone calls. Bluetooth seems to take priority even though I am 30 or 40 feet or more away resulting in many failed calls when I go to answer on my watch.

    Is it possible to default to Wi-Fi at a certain address or something to work around these failed Bluetooth connected calls?
     
  11. dave006 Contributor

    dave006

    Joined:
    Jul 3, 2008
    Location:
    Just West of East
    #11
    Short answer: NO.

    Only option is to disable Bluetooth on your iPhone at this point. I don't expect Apple to make add this as a feature request either but you never know what the future holds.

    Dave
     
  12. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #12
    At least for me turning off Bluetooth is not an option as I use it quite a bit for AirPods and other Bluetooth devices. At this point I don’t take calls on my watch mainly because of the low reliability of the connection.
     
  13. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #13
    Same here.
    --- Post Merged, Dec 17, 2017 ---
    For something as important as a phone call, one would think signal strength would be a priority over power efficiency. Or perhaps make that a selectable option. If you feel my suggestion is valid, it would be very helpful if everyone could provide Apple feedback.

    In the meantime, coming at it another way as a workaround, would it be possible to create some kind of foil or Faraday cage to reduce Bluetooth signal strength? Something that would reduce the Bluetooth connection strength to my watch down to maybe 10 feet while the phone and I are in my home office. This could allow usable Bluetooth in my home office while switching to Wi-Fi as I move to the rest of the house and outside without carrying my phone all day.

    Any ideas on how this could be best accomplished?
     
  14. hrefman, Dec 17, 2017
    Last edited: Dec 17, 2017

    hrefman macrumors newbie

    hrefman

    Joined:
    Jan 1, 2011
    Location:
    United Kingdom
    #14
    I experience exactly the same issue in my home as the OP. It’s very disappointing frustrating, especially when I have an incoming call and no one can hear me as the signal is poor. I’ve gone through setting my home WiFi to 2.5ghz and seperate SSIDs for 5ghz too.

    The AW will Occasionally handoff to WiFi or go to LTE but more often than not it keeps wanting to hang on to BT. I’m also using AirPods when doing household chores so it’s frustrating to have the signal break up my music or calls.

    For me I’m a remote worker and spend a lot of time working at home, so it’s only when I’m out running, or travelling where the AW excels in it’s use case.

    Just a shame about the handoff issues, which I can’t see being addressed unless engineers can change the AW Bluetooth minimum strength to allow for a less sensitive handoff. Similar to the way WiFi access points can be adjusted.
     
  15. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #15
    Is anyone aware of a Bluetooth repeater that could possibly assist with poor Bluetooth telephone connections to the Apple watch?
     
  16. dave006 Contributor

    dave006

    Joined:
    Jul 3, 2008
    Location:
    Just West of East
    #16
    While I don't know of a Bluetooth repeater there are some Bluetooth hubs that are starting to appear (think support for Amazon Echo & Google). Here is a link to the Cassia Bluetooth hub on Amazon. The published information does not indicate that it directly supports the Apple Watch, it is a place to start looking.

    Link: https://www.amazon.com/Cassia-Netwo...13548686&sr=8-1&keywords=bluetooth+hub+cassia

    Dave
     
  17. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #17
    Dave006, I did run across this device before I posted. My hunch is that it is not compatible or the company would advertise it as such and there would be some confirmation or questions on using the device with the Apple watch at this point?
     
  18. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #18
    I am still experiencing the same problem as the OP. The current affinity the watch has for Bluetooth makes it useless for answering a call while roaming around the house.

    Why does the watch lock onto a Bluetooth signal that is too weak? This results in a failed call every time I try to answer even though a Wi-Fi signal is strongly present?

    Does AW3 also exhibit this unreliable behavior?
     
  19. Midway123 macrumors newbie

    Joined:
    Sep 23, 2017
    #19
    I am afraid so, same (unfortunate) behaviour on AW3 here
     
  20. WilliamG macrumors G3

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #20
    I suspect it’s because BT is Low Energy, and WiFi isn’t. Apple is ensuring battery life on the Watch over actual usefulness of Watch. So it goes...
     
  21. iRicktoo macrumors newbie

    Joined:
    Dec 16, 2017
    Location:
    SD CA
    #21
    I am surprised we are not seeing more complaints and requests for addressing this deficiency. I would think answering calls would be one of the top priorities and capabilities for the watch!

    Are you listening Apple?
    Are you using your own product?
     
  22. lankox macrumors regular

    Joined:
    Jul 5, 2007
    #22
    I too am dismayed that the Apple Watch will not let go of the Bluetooth signal when it is woefully weak. I have resorted to carrying my iPhone with me around the house which is infuriating.
     

Share This Page