Will Airport Extreme setup CD only work with Windows 7 Service Pack 1?

Discussion in 'Mac Accessories' started by applefan289, Jun 21, 2012.

  1. applefan289 macrumors 68000

    Joined:
    Aug 20, 2010
    Location:
    USA
    #1
    If I am setting up an Airport Extreme on a PC with Windows 7, will it only work on Service Pack 1? It says on Apple's website that the requirement is "Windows 7 Service Pack 1".

    I'm not sure if that means *only* service pack one, or *at least* service pack one.
     
  2. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #2
    It means minimum of SP1. Not sure why, as the Express doesn't require SP1. Either way, your Win 7 machine should have SP1 anyways so you should be fine.
     
  3. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #3
    SP1 is the latest release anyway, so that wouldn't be a problem. Also, in the future you could download the latest version from Apple.
     
  4. applefan289 thread starter macrumors 68000

    Joined:
    Aug 20, 2010
    Location:
    USA
    #4
    Thanks. The reason I'm asking is because I will be installing it on someone else's computer, and don't know what version of Windows 7 Home Premium they're running.

    I'm crossing my fingers that they have at least Service Pack 1. But if they don't, it looks like Apple offers the latest version for download, and it says the technical necessities are "Windows 7" with no mention of service pack.
     

Share This Page