Windows 8 EFI Install Update

Discussion in 'Windows, Linux & Others on the Mac' started by redcolumbia, Mar 16, 2013.

  1. redcolumbia macrumors newbie

    Joined:
    Dec 5, 2010
    #1
    Hello,

    So I've installed windows 8 through EFI, no bootcamp (emulated bios setup).

    There has been an extensive thread on this 35 pages long, but half of it is focused on windows 7 and I want to focus specifically on issues with the EFI implementation.

    Current setup: Macbook Air mid 2012, Windows 8 EFI.

    Problems right now:
    1) No Audio. I've tried everything -- downloaded newest intel drivers and tried to force the HD Audio Controller driver to update using the intel DisplayAudio folder driver as mentioned here by gophermobile
    http://forums.macrumors.com/showthread.php?t=1427082&page=2
    Does not work. Windows rejects the driver saying:
    "The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems." (Yes the driver is for 64 bit, straight from Intel's website).

    Note that I had to use the Have Disk option in device manager, because simply doing "update driver" leads windows to reject the update saying its already gotten the newest drivers.

    2) Intel Graphics HD4000 drivers not working. Using basic windows graphics driver which means that graphics is severely impeded. Anyone got a working solution for this? There has been mentions of setting PCI registers and all this nonsense but not sure if that is working.

    I'm pretty sure these are the 2 MAIN problems.

    Let's solve these now, especially with the new Bootcamp 5 drivers out.
     
  2. amenoera macrumors newbie

    Joined:
    Jul 11, 2009
    #2
    the same here , MacBook pro 2011 , windows 8 x64 efi , no sound , slow boot .


    but when installing using normal mode(via bootcamp) everything working fine .

    the problem is I have ssd in dvd slot . so I need ahci enabled which is not enabled in bios mode , only enabled in efi mode .

    note when in efi mode it completely boot in 3 -4 seconds ****in faaaaaaast .

    any help ?
     
  3. PowerPCMacMan macrumors 6502a

    PowerPCMacMan

    Joined:
    Jul 17, 2012
    Location:
    PowerPC land
    #3
    Hi,

    I had a situation like this with Windows 7 on my Mac Pro. I downloaded from RealTek's website generic high def audio drivers and that solved that problem.

    For the Graphics card drivers, try going to Intel's site and download the latest Windows 7/8 drivers for your video. Remember, when you are in Bootcamp its as if you are on a REAL PC, so go ahead and install the OEM drivers for which ever version of Windows you have.

    Thats what I did with my Nvidia cards.
     
  4. Mackan macrumors 65816

    Joined:
    Sep 16, 2007
    #4
    Uhm, you have totally different hardware than him. He is also talking about EFI install. He also have tried to download and install latest drivers. It just doesn't work. There is currently no solution to get the Intel graphics and audio to work in EFI mode for this model.

    The problem is likely with the Intel drivers, but could also be because of Apple's EFI implementation. Under the hood, it's probably just a small thing that needs to be fixed to get things compatible, but I don't think we can rely on Intel or Apple to willingly help.

    I face a similar situation with my MacBook Pro 13'' 2010 model, the integrated 320M cannot be recognized in EFI mode. Nvidia has managed to produce a driver that makes the GT650M working on newer retina MacBook Pro's though.
     
  5. magicsleeper macrumors newbie

    Joined:
    Dec 24, 2008
    Location:
    Belgium, Gent
    #5
    no problems whatsoever

    I can confirm that Windows 8 Pro X64 installed with EFI on iMac 2012 27" with latest bootcamp drivers, everything works!!
     
  6. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #6
    I don't know if someone already test it but it might be a solution to explore :

    - Start efi shell from refind.
    - type "drivers" then you will have all the drivers loaded by the mac firmware at startup and the version of this drivers

    So at this point it seems that no one try to update this drivers from a newer mac

    It seems that there is a command in efi shell which permit to unload driver and load drivers (it doesn't touch to the firmware and you have to unload/load drivers at each startup).

    The question is how to dump this drivers for ATI / NVIDIA / INTEL / CIRUSLOGIC ...

    I think the EFI drivers has an effect on how it auto-configure the device at startup, and so, how Windows could identify it
     
  7. Shelltoe, Mar 21, 2013
    Last edited: Mar 21, 2013

    Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #7
    Well using Linux you have no driver problems and you are even able to switch graphics from within the OS so i doubt messing with EFI basedrivers will help.
    I've got an 15'' rMBP and I'm able to switch graphics using EFI shell by setting some PCI registars. So guess i digged a bit into it.
    I know the Linux community had to fix their Intel drivers cause it wasn't able to handle the bits per pixel. Might be our problem aswell.
     
  8. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #8
    You have a newer mac !

    I think setting of PCI registars is a consequence and not the cause (which could be the EFI basedriver)
     
  9. Shelltoe, Mar 21, 2013
    Last edited: Mar 21, 2013

    Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #9
    No. As I said the Linux community didn't had to change anything about the basedrivers to make EFI Mode work. Even with Intel HD and Graphics Switching.

    I'm in touch with a developer of Linux's GMUX driver who helped me to switch graphics.
    Everything is set for Intel HD to work (and it does using basic display drivers).
    All registars for Intel HD are fine.

    The only new for rMBP's compared to the previous gen is a updated GMUX device which now uses a message box interface (0x7C2). But thats only relevant for ppl with 15'' rMBP who want to use their Intel HD in Windows.
     
  10. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #10
    And so it's an adaptive answer to a problem. Only Linux (and OSX) could give this type of personalized answer. But maybe we could also solve it by another way !

    Good for you ! What about Nvidia / Ati / CirusLogic ... and the previous Mac with Intel devices ?

    It could be interesting to know the Intel Efi Basedriver version of your rmbp and compare to "old" Intel MacBook or iMac ! ... and, if diferent, try to use your efi Intel basedriver !

    I'm pretty sure there is some improvement with the updated efi basedrivers more than only support new devices
     
  11. Shelltoe, Mar 21, 2013
    Last edited: Mar 21, 2013

    Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #11
    Well you don't get the point I guess. All drivers shown in EFI Shell are used to start up your system but are irrelevant for any OS booted afterwards. Most devices don't even have a driver showing up in EFI Shell.

    You can connect an external GPU no matter what brand via Thunderbolt and it will work while not having any drivers installed.

    BTW. the audio problem seems to be Intel (chipset) related aswell even though it's shown as CirusLogic.

    Anyways... I don't wanna crush your enthusiasm.
     
  12. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #12
    Ok. So in order to answer this thread Windows 8 works pretty well in EFI on the iMac late 2009 (Core i5, ATI Mobilty Radeon 4850) ... except that the ATI Card said it could not start even with the pci registars (mm 0003003E 8 -pci).
     
  13. Shelltoe, Mar 21, 2013
    Last edited: Mar 21, 2013

    Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #13
    Well as the thread isn't specifically iMac related we should say EFI works great except for Intel / ATI graphics- and audiosolutions. Since Apple dropped ATI the driver support is really poor while Intel has similar problems even on some PC-based systems.

    Regarding your iMac: I assume 000300 is your ATI card. Whats the default state of registar 3E (which is necessery to enable VGA out)? The bus indicates it's not connected to an PCI Bridge but as a rootdevice right?
     
  14. jlpek17, Mar 21, 2013
    Last edited: Mar 21, 2013

    jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #14
    For me the audiosolution (Cirrus Logic CS4206A -AB81) works very well except that it makes time to initialize (1-2min) after I'm on the desktop but I think even in Bios mode it does that.

    I don't know if it's related but "sleep mode" and "brightness control" don't work also. The "Advanced Tab" for "Screen Resolution" show only 256mo for my Graphic Card have 512mo.

    I don't really understand this ; it takes times and a lot of contributions to find my registars in following the difficult thread (I think you know very well) http://forums.macrumors.com/showthread.php?t=696523&page=34

    I found my registar in dumping the files here in attachments.

    You seems to know the solution. Don't You ?
     

    Attached Files:

  15. mm201 macrumors regular

    Joined:
    Feb 17, 2013
    #15
    Any progress with the 15" rMBP's audio and iGPU?
     
  16. Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #16
    Took a quick look as I'm still at work. I can already tell that "mm 0003003E 8 -pci" can't work as you are triggering a probably not present registar of your wlan(?!?) device. Additionaly your VGA device doesn't use "3E" to enable VGA output.

    I'll might have a closer look at it after work. What error does your device manager show regarding your ATI CARD (error 12? error 43?)
     
  17. jlpek17, Mar 21, 2013
    Last edited: Mar 21, 2013

    jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #17
    I have the error 10 : The device could not start with and without the use of mm 0003003E 8 -pci

    I'm pretty sure that with previous build of Win 8 (Beta or RC) the problem was the device has not enough memory.

    Does this could explain "Sleep mode" "Brightness control" and "256mo instead of 512mo" problems on my system ?
     
  18. Shelltoe, Mar 21, 2013
    Last edited: Mar 21, 2013

    Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #18
    I guess your system is currently using the basic display driver thats why you miss those features and wrong numbers show up.

    no progress in the past month or so ... dunno about your current state though.
    most of my knowledge can be read up in my eGPU thread.

    Guess the only interesting part for you would be switching graphics before booting windows.
     
  19. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #19
    Yes it does use this basic display drivers !

    ----------

    I knew that I already read you on another forum but don't know where ; you did an amazing job on this other forum ! I complained because you are not on Macrumors but actually you was !
     
  20. Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #20
    Did some quick tests on a MacPro with a ATI Radeon HD 5770. Received the same problems. I know Apple used their own EFI ROM's for ATI and old Nvidia GPU's (GT 560 and above work with regular PC EFI ROM's) which might be the problem here as Windows can't handle them. This might affect all mac system with ATI GPU's and could be unfixable unless you want to mess up your OS X.

    I'll make some more tests during the weekend.
     
  21. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #21
    Thank you very much. You are very helpfull !

    What are you thinking here ?
     
  22. Shelltoe macrumors member

    Joined:
    Dec 11, 2012
    #22
    BootCamp adds a virtual BIOS layer that recognizes Apples firmware and tells Windows how to handle it. By installing EFI Mode, Windows just finds a firmware it can't handle.

    In the past it was pretty common to buy a regular PC GPU and flash it with Apples EFI ROM so you could use it in Mac OS. This was way cheaper than buying a "official" Mac GPU ... but this isn't needed anymore as modern Nvidia GPUs support both PC and MAC out of the box.

    You could try to flash your GPU with a PC ROM to make it work in Windows but you won't be able to use OS X anymore as your ATI Card requires Apples "special" firmware. It's a no go.
     
  23. amenoera macrumors newbie

    Joined:
    Jul 11, 2009
    #23
    hello everybody ,

    here is my story , first I have MacBook pro 2011 (i7,2.7ghz,8gRam,256 vertex 4 ssd in main slot + 500hdd hitachi in dvd place ) . need to mention that main slot is sata 3 6gb/s capable .

    1ST scenario : * install mountain lion 10.8.3
    * create a second partition with 80gb
    * make usb flash bootable with windows 8 .
    * convert the disk to gpt without losing data using(gptfdisk) >>>( so windows 8 can b e installed "it must be GPT")
    * power up & hold alt and select efi boot
    * install windows 8 in efi mode
    * install bootcamp 5 including drivers
    * everything work including ahci + vga + sleep + trackpad + bootcamp control panel . excep (sound . .. showing in device manager as "High Definition Audio Controller" >>> "PCI\VEN_8086&DEV_1C20&SUBSYS_72708086&REV_05"
    * boot windows in around 8 - 15 second
    *screenshot is attached

    * for 2nr scenario I removed the 500hdd and put back my dvd .

    2ND scenario : * install mountain lion 10.8.3
    *running boot camp and prepare a second partition for windows 8 .
    * insert windows 8 and proceed with normal installation .
    * after finishing install windows 8 setup bootcamp
    * everything working like it show be (yes everything) but no AHCI .
    * windows boot instantly (about 1 or 2 seconds) .
    * trying to patch mbr to activate ahci and yes its activated but sleep not working .

    Finally , I tried every possible method / driver / trick without any help , and read that this is an Efi issue .
    all I need is ( AHCI enabled + Sleep working + Sound ) is there is any solution for such this problem even in future ?

    Thanks & Best Regards .
     
  24. amenoera macrumors newbie

    Joined:
    Jul 11, 2009
  25. jlpek17 macrumors regular

    Joined:
    Oct 10, 2011
    #25
    So, have you seen any advancement ?
     

Share This Page