windows remote desktop client for mac???

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
I'm trying to setup windows remote desktop client for mac, but I can't seem to connect to my windows computer.. Any ideas?

Remote Connections is turned on, on the windows side. I type the IP and admin user name as there is no password on the account. I tried adding a password and still fails to connect.
 

MacForMeOneDay

macrumors member
Jun 16, 2007
69
0
I'm trying to setup windows remote desktop client for mac, but I can't seem to connect to my windows computer.. Any ideas?

Remote Connections is turned on, on the windows side. I type the IP and admin user name as there is no password on the account. I tried adding a password and still fails to connect.
And you made sure that in Windows Firewall, its setup to allow exceptions for RDC?
 

mlemonds

macrumors 65816
Apr 9, 2008
1,010
119
Lexington, KY
also if you are trying to do this from across the internet (read: outside your router) then your router needs to forward port 3389 to your Win machine.
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
I'm entering the name of the account (firstname lastname) with password I created.

I checked the firewall and remote desktop and remote assistance are both checked.

I'm in the office now connected to the same internet/router and trying to connect. I get the following response after it tries.

The Mac cannot connect to the Windows-based computer.
This problem can occur if:
- The Windows-based computer is not set up to accept remote connections.
- The Windows-based computer is not turned on.
- The mac, or the Windows-based computer is not experiencing network problems.
Try connecting to the Windows-based computer again, or contact your administrator.

I use our public IP address (did a second lookup at checkmyip.com) first and last name for user (with a space in the middle) (example: Steve Jobs) with first two letters of first and last capital. I then add the password and hit connect.


edit: even tried turning the firewall off.
 

swiftaw

macrumors 603
Jan 31, 2005
6,309
20
Omaha, NE, USA
I'm entering the name of the account (firstname lastname) with password I created.

I checked the firewall and remote desktop and remote assistance are both checked.

I'm in the office now connected to the same internet/router and trying to connect. I get the following response after it tries.

The Mac cannot connect to the Windows-based computer.
This problem can occur if:
- The Windows-based computer is not set up to accept remote connections.
- The Windows-based computer is not turned on.
- The mac, or the Windows-based computer is not experiencing network problems.
Try connecting to the Windows-based computer again, or contact your administrator.

I use our public IP address (did a second lookup at checkmyip.com) first and last name for user (with a space in the middle) (example: Steve Jobs) with first two letters of first and last capital. I then add the password and hit connect.


edit: even tried turning the firewall off.
Have you told your router to forward that port required for RDC (3389 i think) to your windows machine?
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
I have a total of 3 computers running right now.. 2 PC's and 1 mac. The two pc's both have the same username but different passwords.

Not sure if this helps...
 

swiftaw

macrumors 603
Jan 31, 2005
6,309
20
Omaha, NE, USA
I have a total of 3 computers running right now.. 2 PC's and 1 mac. The two pc's both have the same username but different passwords.

Not sure if this helps...
If you are tying to connect to PC from your Mac on the same network you need to use the internally assigned IP address of the PC not the external IP address.

If you are trying to access your PC from somewhere else of the internet then you need to use the external IP address and then port forward the appropriate ports from your router to the PC.
 

plinden

macrumors 68040
Apr 8, 2004
3,969
3
I use our public IP address (did a second lookup at checkmyip.com) first and last name for user (with a space in the middle) (example: Steve Jobs) with first two letters of first and last capital. I then add the password and hit connect.
If you're on the same network, you should use the local IP address (the 198.x.x.x or 10.x.x.x or 172.x.x.x etc address)

Since you're using the public address, you're going out to the internet and back in so you're having the same problems you would have from home.

If you've made sure you can connect locally, then you'll know the problem lies between the PC and the external network. It's likely your office IT is denying access.

Do you have VPN? In other words, when you're at home, can you connect to your office network? If you can VPN into the local network from home, then it's more likely you'll be able to connect.

Edit: Damn, spent too much time typing.
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
Have you told your router to forward that port required for RDC (3389 i think) to your windows machine?
How would I go about this on a linksys router? I'm in the router control panel, in port forwarding but I see the following..

application - ext.port - TCP UDP - int.port - IP address - enabled
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
there must be an easier way ;) any software?

I tried using the local ip 192.168.1.1 same error.
 

MacForMeOneDay

macrumors member
Jun 16, 2007
69
0
How would I go about this on a linksys router? I'm in the router control panel, in port forwarding but I see the following..

application - ext.port - TCP UDP - int.port - IP address - enabled
Remember you only need that if the computers are NOT on the same network. It sounded like you were on the same network based on your previous note about being at work.

Application would be RDC (anything is fine)
External = 3389
Internal = 3389
Protocol = Both
To Ip Address = the IP address of the Windows box you want to connect to.
You want to be careful doing this. If you set this up, then your RDC is essentially connected directly to the internet.

Also, something you said made me think. Are you sure that the Windows account name is the "FirstName LastName"? When you are on the XP box, it will say the Account Name at the top when you hit the "Start" button.
 

plinden

macrumors 68040
Apr 8, 2004
3,969
3
(There may be an easier way to find the IP address of a PC but I can't remember)
On your windows PC open a DOS window (Run - cmd). Type ipconfig /all

Use the IP address that shows you.
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
Remember you only need that if the computers are NOT on the same network. It sounded like you were on the same network based on your previous note about being at work.

Application would be RDC (anything is fine)
External = 3389
Internal = 3389
Protocol = Both
To Ip Address = the IP address of the Windows box you want to connect to.
You want to be careful doing this. If you set this up, then your RDC is essentially connected directly to the internet.

Also, something you said made me think. Are you sure that the Windows account name is the "FirstName LastName"? When you are on the XP box, it will say the Account Name at the top when you hit the "Start" button.

Yes it says my bosses first and last name for the username.

as for being in-network, I'm setting this up in-network but I wanna use it at home tonight.
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
alright, I created two port forwards, one for TCP and one for UDP both for ext 3389 and int 3389 and the IP address I got from ipconfig was 192.168.1.101

typed in our internet IP, admin user and pass and hit connect.. same error :/
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
oh, i got it ;) interesting... forgot to check enabled in linksys config.

Now this should work from home correct?
 

plinden

macrumors 68040
Apr 8, 2004
3,969
3
On your Mac, open Terminal and type:
Code:
telnet 192.168.1.101 3389
This will tell you if the TCP port 3389 on your PC is open. You should see something like:
Code:
my-mac:~ truz$ telnet 192.168.1.101 3389
Trying 192.168.1.101...
Connected to <some host name>
Escape character is '^]'.
oh, i got it ;) interesting... forgot to check enabled in linksys config.

Now this should work from home correct?
Edit:So it's working on your internal network now?

If so, replace your local IP address with the external IP address. If that works it should work from home.
 

fpar

macrumors regular
Feb 11, 2008
109
0
i have similar setup already, your problem is that the windows account has no password. Windows remote desktop only works if there is a password, so create a password and if you want you can enable auto login on the windows machine. if you have any more questions on this feel free to PM me for a rapid response.
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
I just downloaded ultra vnc for a windows box and used the built in screen sharing in leopard. It works very well.
How did you go about setting this up? rather simple to the way above I went?
 

truz

macrumors 6502a
Original poster
Jan 1, 2006
621
1
Florida
I know this is out of topic, but.. what would you guys recommend for remote desktop from mac to mac? I have a desktop in florida I'd like to access from colorado (where I'm living now currently).

I have used the ichat screen share, but you have to request permission so if no one is on the other end to accept your not connecting.

Also, I have the Apple Remote Desktop (10 clients) but I never got the software working correctly.
 

MacForMeOneDay

macrumors member
Jun 16, 2007
69
0
I know this is out of topic, but.. what would you guys recommend for remote desktop from mac to mac? I have a desktop in florida I'd like to access from colorado (where I'm living now currently).

I have used the ichat screen share, but you have to request permission so if no one is on the other end to accept your not connecting.

Also, I have the Apple Remote Desktop (10 clients) but I never got the software working correctly.
I don't think your situation with RDC is going to be any different if you use vnc. I suggest since you said you have 2 PCs that you ensure that you can connect PC to PC using RDC, my guess is that you can't do that at the moment either.

Depending on exactly what you want to do with the Florida to Colorado thing you have a few options.
1) Actually control the remote Mac (view the screen, interact with the OS GUI):
Enable ssh(Remote Login) on the Colorado Machine.
Ensure you have a Static IP on the Colorado Machine (inside/behind router)
Ensure you do the port forward to port 22 like you did for 3389 before (this allows the external IP to route port 22 to your Colorado Mac)
Open a Terminal
ssh into the Colorado machine doing port forwarding (You'll need a way to know your Public IP address, look up DynDNS.org. Most Linksys Routers support this. So you'd use a <uniquename>.dyndns.org or similar address)
> ssh -L 5901:localhost:5900 ColoradoMacIP

Then simply open the screen sharing app and point it to localhost:5901

Another option is HamachiX, I've been using this to connect my Mac and my Mom's Mac to help her out. However, I've had to continuously "Install System Components" inside Hamachi in order to get the underlying processes running right???? Haven't looked into this too much, as to the root cause.

2) Just get to files/directories on the Colorado Mac
Just do the same stuff for setting up ssh on the Colorado Mac, but then just use Filezilla and sftp(ftp over ssh) into the Colorado Mac.

I'd be glad to help you with this, just send me a PM.