Windows Sharing with Firewall on

Discussion in 'macOS' started by RZetlin, Aug 17, 2007.

  1. RZetlin macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #1
    With the Mac OS X firewall turned on, I am unable to access files with Windows Sharing.

    How do have Windows Sharing work with the firewall turned on?
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    Hmm, I have my firewall on and windows sharing works.

    Silly question, you have turned windows sharing on in the firewall settings, right?
     
  3. RZetlin thread starter macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #3
    This is what I have done:

    Sharing panel:

    - Services
    Windows Sharing - On

    - Firewall - on

    In the firewall panel there's no entry to allow the Windows Sharing.
     
  4. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #4
    Did you select which accounts you wanted to share? And did you try connecting using the address it tells you, for example, mine says

    "you can access your computer at \\192.168.1.200\<username>"
     
  5. RZetlin thread starter macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #5

    Yes, I have.

    The problem is Windows Sharing is not showing in the Firewall panel.

    How do I manually add Windows Sharing to the Firewall?
     
  6. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #6
    Hmm, it's not listed in the firewall panel at all?

    That's worrying

    Edit: You could try deleting com.apple.sharing.firewall.plist
     
  7. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #7
    That is strange. On my Mac (10.4), it is the second item in the Firewall settings, directly after "Personal File Sharing". However, you can't turn it on or off there, you have to turn it on in "Services". This should automatically change the Firewall, because turning Windows Sharing on and then not letting it through the Firewall is pointless.

    Maybe you have to be the admin user?
     
  8. RZetlin thread starter macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #8
    I have admin rights

    I am missing several entries in the firewall allow list.

    Is there a way to load up the default allow list again?
     
  9. RZetlin thread starter macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #9
    I add a few new rules to the firewall settings.

    But I cannot change the settings.

    I get the message "You cannot change the firewall settings for this service"

    How do I edit the firewall settings?
     
  10. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #10
    did you delete the plist file like i suggested?
     
  11. RZetlin thread starter macrumors regular

    RZetlin

    Joined:
    Jul 9, 2007
    #11
    Good News: Moving the plist file to a different directory did restore the default firewall settings back. Thank you.

    From what I can tell another program, (Adobe?) had overwritten the firewall settings.
     

Share This Page