Resolved Xcode hangs on launch

Discussion in 'Mac Programming' started by maverick28, May 19, 2017.

  1. maverick28 macrumors member

    Joined:
    Mar 14, 2014
    #1
    Some time ago I downloaded and ran successfully Xcode 4.3.3 and Xcode 4.4 simultaneously. Then, troubleshooting I deleted them, wiping out all files referencing to both Xcode versions through Terminal. I then re-downloaded 4.3.3 and was able to launch and run it, however 4.4 which I re-downloaded afterwards refused to do the same resulting in an endless hang which to abort I could only resort to Force Quit. Having launched again I was greeted with a notification message suggesting me to either to restore previous windows or do not restore. Regardless of the option selected the hang renewed immediately until the next ForceQuit etc. I can't understand what went wrong this time? I haven't started any projects that could become corrupted or so as a common explanation suggested on numerous forums. I remember that since Apple's certificate expired and being on Lion I needed older versions of Xcode I changed the date to the one closer to the original release date. The first time trick worked with both version (although I can't remember how exactly I changed them) and so it did with 4.3.3 this time but not with 4.4.

    Also, if it might seem useful, when uninstalling I removed these binary files referencing to Xcode:

    /usr/bin/xcodebuild

    /usr/bin/xcode-select

    /usr/share/man/man1/xcode-select.1

    /usr/share/man/man1/xcodebuild.1

    /usr/share/xcode-select



    I removed these items because I thought it was bundled with Xcode and therefore would be re-installed again. Was I wrong? Was these built-in OS X?



    Acting on intuition I looked inside Xcode.app packages of both versions but could only find /usr/bin/xcodebuild.



    So what should I do?
     
  2. cqexbesd macrumors regular

    Joined:
    Jun 4, 2009
    #2
    No doubt the fastest solution would be reinstalling, either from backups or with original installers, of either or both Xcode and/or OSX. If you actually want to know what's going on though maybe try truss on Xcode, or sampling it, to see what its waiting for.
     
  3. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #3
    I solved. It turned out my instinct didn't do a bad turn as I later learned that the binaries in /usr/bin and /usr/share were responsible for launching several versions of Xcode. I downloaded Lion combo update from Apple's downloads section, installed these components using Pacifist and the problem was gone.
     

Share This Page