Yamaha CLP645 Bluetooth MIDI problem

Discussion in 'Digital Audio' started by panflegl, Jan 3, 2018.

  1. panflegl macrumors newbie

    panflegl

    Joined:
    Jan 3, 2018
    #1
    Hello, everyone!

    I just bought a new Yamaha CLP645, and I tried to connect this keyboard via Bluetooth to my MacBook (MacBook Pro - Retina, 13-inch, Early 2015 with High Sierra 10.13.2). I partially succeeded, as these two devices paired and the sounds played in my notebook are transmitted to the piano and are played via the piano speakers - so far so good. Unfortunately, I was not able to set up the opposite direction from piano to the notebook as it seems as the notebook doesn't see the piano as available MIDI source/input via Bluetooth - in the Mac MIDI setup the CLP is listed but only as an output, not as an input. I tried to same on my iPhone with the same result. The device is connected, but when I (e.g., in Flowkey) try to search for the Bluetooth LE MIDI Devices, the result is "No devices found."

    I'm new in the area of MIDI, keyboards, etc. so I'm lost. Could you help me? What driver should I install, or what procedure to follow? Is this even possible?)

    Thank you very much for your answers
     
  2. panflegl thread starter macrumors newbie

    panflegl

    Joined:
    Jan 3, 2018
    #2
    I solved the issue, so if anyone has the same problems, this is what I found. This version of a piano has Bluetooth Audio only, which means that you cannot use Bluetooth for MIDI. Though, you can use it for audio transfer from PC/Mobile/etc. to the piano. This was confirmed by Yamaha technician.

    Therefore, I ended up with the following setup - I connected the Mac with USB cable (A-B version, also known as printer version) and set this for MIDI input to the PC. As I wanted the sound to be produced by the piano, I continue using Bluetooth connection for the sound transfer from the PC to the piano. This setup works like a charm:)
     
  3. Fizou macrumors newbie

    Joined:
    Jan 13, 2019
    #3
    Hi

    I tried this set up but I get an echo: I first get the note/sound from the piano itself then again a few beats later for the blue tooth connection. Not sure what I do wrong. I plan to use the CLP 645 to learn piano using an app called Piano Marvel. So when I practice I first get the sound coming from the app, voice and background accompaniment, then as I play the notes on the score on my Mac screen, I get them directly from the keyboard, and again a short bit later from the Mac via Bluetooth. Any idea how to fix it?
     
  4. theluggage macrumors 68040

    Joined:
    Jul 29, 2011
    #4
    generators and keyboards.

    First thing to try is to find the "Local on/off" function on the CLP 645 itself and switch it to "off". That stops the notes you press on the piano keyboard being immediately played by the piano sound generator - and makes it act like a separate MIDI keyboard and sound module, which is usually what you want when you're hooking up to sequencer software.

    Looking at the CLP 645 manual online its called "Local control on/off" on the system menu (that's the system settings on the keyboard itself, not the computer).

    I also see an option called "Audio Loopback" there... that should probably be off as well unless you want to accidentally re-enact the opening of Back To The Future... :)

    There may also be settings in "Piano Marvel" that determine whether it sends the MIDI data back to the piano (so the piano parts sound on the piano) or generates its own sounds on the Mac.

    I don't know if Yamaha has implemented some form of lag-free Bluetooth audio - it doesn't sound like it from your experience (maybe not supported by your Mac) - but regular Bluetooth audio is useless in any situation where you're playing sounds manually and want to hear the result because (as per your description) there's a lag of a second or so.

    According to the manual, the piano supports USB Audio In/Out, so it ought ti be showing up on your Mac as an audio source - which should be lag-free - if your software allows it, you could select the piano as an Audio input and just turn off/ignore Bluetooth.
     
  5. Fizou macrumors newbie

    Joined:
    Jan 13, 2019
    #5
    Thanks. I have it working with a USB cable plugged in the mac, but this defeat the use of the Blue Tooth on the piano. I going to get the BT midi cable from Yamaha .(MD-BT101) and see if this works.
    Thanks Fizou.
     
  6. emmanuelscerri macrumors newbie

    Joined:
    Aug 10, 2019
    #6
    Thanks for taking the time to share. In so doing you saved me a lot of trouble. Have a good day.
     

    Attached Files:

Share This Page

5 January 3, 2018