Yosemite on MBP Major WiFi issues?

Discussion in 'OS X Yosemite (10.10)' started by EFaden, Oct 16, 2014.

  1. EFaden macrumors newbie

    Nov 14, 2008
    Just upgraded my MBP to yosemite and ever since my wifi will not stay connected. It works for about 30 seconds and then stops. Wired works fine. Anyone seen anything like this or have suggestions?
  2. flux73 macrumors 65816

    May 29, 2009
    I don't have an answer, but I'm wondering what are the specs and model year of your MBP?
  3. WithBBQSauce macrumors newbie

    Oct 16, 2014
    I am having the same issue on my rMBP (late 2013), except that the problems are confined to 5.0ghz wifi. 2.4ghz works fine. But on 5ghz I have the same issue as the OP (can't stay connected for more than 30 seconds).
  4. Ai-apple macrumors regular

    Nov 1, 2013
    5GHz band is still having issue with the official release 10.10. There is no issue with 10.9.5.
  5. ABC5S Suspended


    Sep 10, 2013
    Yosemite installed about two hours ago, using 5.0 Ghz WiFi setting, AirPort Extreme (Newest), and thus far no issues of dropping down to 2.4. Not enough time, but so far so good.

    New Mid 2014 MacBook Pro Retina 8 GB 128 GB SSD
  6. dwfaust macrumors 601


    Jul 3, 2011
    I had the issue during the developer preview process with both 5ghz and 2.4ghz, but the issue cleared up in DP6 for me. I’m running a 2012 rMBP.
  7. Eplowe macrumors newbie

    Oct 17, 2014
    I am having the same problem on a late 2013 mbp. I also experience the issue on the 2.4ghz range.

    Did a fresh install of Mavericks from Yosemite (wiped the hard drive) and I had normal connectivity like I did before upgrading. I then upgraded from the clean Mavericks install to Yosemite and had the same problem on both ranges (5 and 2.4). I'll get connectivity then it drops after a 30 seconds to a minute and then comes back in another minute or so then drops again.

    I am puzzled.

    At the point I need to fall back to Mavericks.
  8. Spinvis, Oct 17, 2014
    Last edited: Oct 17, 2014

    Spinvis macrumors newbie

    Oct 17, 2014
    I'm not losing connection, but it is extremely slow (after upgrading to Yosemite) on my MBP Retina (using Safari, 2,4Ghz Wifi) and sometimes Safari says it can't find the server... Had no problems with Mavericks.

    Also not having any issues when connected via Ethernet.
  9. EFaden thread starter macrumors newbie

    Nov 14, 2008
    I'm using an A1398. I'm on 2.4 ghz connected to a netgear r7000. I had no p problems until the upgrade. Now it connects for about 30 seconds then I just get a ton of packet loss. It says it is still connected.. It just cannot do anything.
  10. dovis0071 macrumors newbie

    Oct 17, 2014
    Same issue with MBA 2014

    Upgraded to Yosemite (not fresh install) ant noticed that wifi is fu*king with me. Visually wifi signal bars are full, but safari not load webpages, mac store as well. Only solution i found is to turn wifi off and turn it back on.
  11. dandl macrumors newbie


    Oct 28, 2013
    Naples, Italy
    I apparently solved this issue removing all the preferred networks and then establishing a new connection.

    rMPB middle 2012
  12. MassiveAttack macrumors 6502a

    Mar 28, 2010
    New York
    I'm having the same issues. Wifi was working fine last night after I upgraded but this morning I can't get wifi to connect no matter what I do. Bummer.
  13. deviant macrumors 65816

    Oct 27, 2007
  14. Ekim Neems macrumors member

    Aug 23, 2007
    Same issue for me as well. I have two SSIDs - one for 2.4 and one for 5.0ghz and the 2.4 one works fine, the 5.0 is super slow. Really disappointing.
  15. hfletcher macrumors 6502


    Oct 10, 2008
    Used to connect at MCS index of 15+, around 100Mbps of actual bandwidth.
    Now in same location struggling to reach MCS index of 5, TX rate stuck at 52Mbps....

    Laptop is in same place, other devices working fine. On 2.4ghz btw.
  16. MassiveAttack macrumors 6502a

    Mar 28, 2010
    New York
    This is exactly what worked for me. Thanks!

    There's definitely a wifi bug that needs to be addressed ASAP. My late 2011 MBP was absolutely worthless with no internet connectivity.
  17. ltorrelles macrumors newbie


    Nov 16, 2012
    Barcelona, Spain
    Having the same issue. Retina 15inch mid 2012. Will try what @dandl posted when I get home.

    Here's a video on the issue.

  18. PackFan macrumors 6502


    Apr 22, 2009
    Twin Cities, MN
    I've been having the same troubles since the installation and throughout the Developer Previews.

    I just tried the deleting of the preferred networks - will see if it helps.
  19. EFaden thread starter macrumors newbie

    Nov 14, 2008
    Deleted the preferred networks didn't work for me.
  20. geoff5093 macrumors 68020


    Sep 16, 2014
    Dover, NH
    I'm hard wired in and connected to WiFi, I found that after upgrading it doesn't want to stay on 5GHz and will back down to 2.4GHz rather quickly.
  21. mentaluproar macrumors 68000


    May 25, 2010
    Ohio, USA
    I have the same problem in my rMBP. Wifi is useless and the console is flooded with error messages.
  22. Edax macrumors newbie

    May 22, 2010
    Wifi seems to work fine at home (various Airports) but same problem at work with a TP-Link wireless router; 2012 (15") rMBP.
  23. JoeBlazeX macrumors newbie

    Jun 22, 2010
    I've reported this issue to Apple on the first day of GM1 for my 2012 rMBP and sent them 3 separate WiFi logs. I only received one response which was to send them more logs after the first log I attached. I can't believe they released Yosemite with this serious bug, I have to either suffer with slower internet on the 2.4 GHZ band or use a thunderbolt ethernet adapter and hang out with router.
  24. bartolo5 macrumors member

    May 11, 2008
    Add me too. Can't connect to 5ghz at all, but 2.4ghz seems to work fine. 5ghz was working perfectly smooth on Maverics. I have an Asus AC66U here.
  25. hinjeniero macrumors newbie


    Jan 31, 2014
    Same problem here, both in 5GHz and 2.4GHz but no problems when using the same frequencies and 802.x authentication system with certificates.

Share This Page