you cannot use this version of the application Xcode with this version of Mac OS x

Discussion in 'Mac Apps and Mac App Store' started by enzo.shi, Apr 14, 2011.

  1. enzo.shi macrumors newbie

    Joined:
    Apr 14, 2011
    #1
    hello,my all friends in MacRumors,I am fresh about mac,but the project needs to be deployed in MAC.
    Now the question as below,
    you cannot use this version of the application Xcode with this version of Mac OS x.
    my mac Osx version 10.5.8 and Xcode is 2.4 .inXcode 2.4 Release Notes says that "Xcode 2.4 will run on Mac OS X 10.4 (Tiger) on a Macintosh with either a PowerPC or an Intel processor. It will not install or run on earlier versions of Mac OS X. Xcode supports development for Mac OS X 10.1, Mac OS X 10.2 (Jaguar), Mac OS X 10.3 (Panther), or Mac OS X 10.4 (Tiger) (both PowerPC and Intel) using the Mac OS X SDK support."

    another question ,my project needs ios simulator, xCode 4 contains ios simulator , how can i find ios simulator in xCode 2.4 thanks all
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    Xcode 2.4 is too old for Leopard, which is what you have... Leopard requires Xcode 3.x for development.
     
  4. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #4
    If your project needs to be deployed "in MAC" (I assume you mean on a Macintosh) then you don't need the iOS simulator. If your project needs to be deployed on an iOS device then upgrade to 10.6.7, register as an iPhone developer for $99, then download the latest XCode version. You get everything you need at developer.apple.com.
     
  5. enzo.shi thread starter macrumors newbie

    Joined:
    Apr 14, 2011
    #5
    thanks, yes,it was deployed on a Macintosh, but how can i find ios simulator,
    according to instruction of the project,i need the Xcode to open the ios simulator, "you can not use this version of the application Xcode with this version of Mac" puzzled me ,how can fix it ?

    instruction: 1.go to the spotlight and search for "iso simulator"
    2.you should be able to see apps there ->Xcode ->ios simulator
    pre condition: install xcode IDE in the Mac machine
     

Share This Page