2006/2007 Mac Pro (1,1/2,1) and OS X El Capitan

Discussion in 'OS X El Capitan (10.11)' started by Mr. Zarniwoop, Jun 8, 2015.

  1. scholefn macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Sydney, Australia
    #4201
    Ok. Finally got it all working again. The last step was I had to update the NVIDIA driver for my GT 710 - from 346.03.15f10 to ...15f15. Thanks to this as a great resource!

    So to summarise (so I can come back here if I do it again), after I mistakenly applied the 2018-003 security update and got into a reboot loop I had to;
    - Put my old graphics card back in
    - Boot into Lion
    - Download the 2017-005 update and use Pacifist to extract the kernel file
    - Overwrite the kernel with this file on my El Capitan disk
    - Reboot to El Capitan
    - Update the NVIDIA web drivers
    - Enable the NVIDIA driver in El Cap
    - Shut down
    - Put the GT 710 video card back in
    - Start up
     
  2. macmanmello macrumors newbie

    macmanmello

    Joined:
    Aug 28, 2016
    #4202
    ok im trying to get sound out of my graphics card... the graphics card is a

    NVIDIA GeForce 8400GS 512 MB (i know its an older graphics card.)


    i have el capitan 10.11.4 installed on to my mac pro 1,1 using this guide.... here are my specs


    Model Name: Mac Pro

    Model Identifier: MacPro1,1

    Processor Name: Dual-Core Intel Xeon

    Processor Speed: 2.66 GHz

    Number of Processors: 2

    Total Number of Cores: 4

    L2 Cache (per Processor): 4 MB

    Memory: 12 GB

    so my issue is under the sound settings, i do not have any thing related to my graphics card in there. just built in audio ect ect. i just put this card in to my mac pro to be able to hook it up to a tv... it powered up with no boot screen but initialized as soon as it came to the desktop... however under displays settings im able to change my resolution to 1080p... so my mac is hooked up to my tv essentially and im not getting any sound out of the television. but the graphics work fine. can some one point me in the right direction of where to get the correct audio drivers for my graphics card.. nvidia has nothing on there site about mac audio drivers.... i know it allows sound to go thru it..i have tested on windows based computer and it works fine with the right drivers.. im sure theres a work around to this issue and would be super grateful if someone can help me out!!! THANKS IN ADVANCE
     
  3. khanam macrumors newbie

    khanam

    Joined:
    Nov 13, 2016
    Location:
    Miami, FL
    #4203
    So I have the 2018-003 update waiting and know it will make the system unbootable. Is there a simple way to flash a patched kernel after the update and if yes, how do we patch the kernel and flash it? Can someone please point me to the posts that detail it? Thanks all for keeping my 1,1 going so far.
     
  4. secondhandnews macrumors newbie

    Joined:
    Jun 12, 2018
    #4204
    Apols for this post if its already been covered- I've used the search feature and can't find an answer.

    Anyway....I'm using Pikify, and have things set up as per the instructions- legit, downloaded from Apple Store version of El Capitan installer app in my /Applications folder, and running Pikify 14.

    I'm running a single HD, partitioned into 2 equally-sized partitions, Lion on the first, second one is blank and is my target for the El Capitan installation.

    Pikify runs fine and seems to do its thing- I'm choosing my second (blank) partition as the destination. 5 mins or so and its done.

    However, every time it reboots- the El Cap installer halts, with a warning that 'El Capitan is already installed on this computer'. I've started from scratch several times, full wipe of the disk and repartitioning, and reinstalling Lion from fresh. Same thing always happens.

    I must be doing something wrong, but what?

    thanks in advance-
     
  5. Ant3000 macrumors 6502

    Joined:
    Jul 20, 2015
    Location:
    UK
    #4205
    Don't update or you will brick your system. This will no doubt have the same updates as the earlier versions that also caused trouble. Look back a few pages in this thread to see more details.
     
  6. EpilepticGerbil macrumors newbie

    EpilepticGerbil

    Joined:
    May 12, 2018
    Location:
    Victoria BC, Canada
    #4206
    Am I the only one out there wondering if there's a way to remove the problem causing code out of the update patch while leaving the rest in to update our beloved MacPro's? Or am I just dreaming and I need to wake up?
     
  7. JPS_3000 macrumors newbie

    JPS_3000

    Joined:
    Jun 17, 2018
    #4207
    IM sorry to maybe ask stupid questions, but as Far as suggested in Post #4160 was to download the SP-2017-005 then extract the kernel file and replaceing the existing File on the el capitan drive.

    but i am having an error occuring while extracting those SP_File as followed: The File „file://localhost/var/folders/ZT/ZTcWGFPQFaaCG6wRAli7ZE+++TI/-Tmp-/com.charlessoft.pacifist.temp/2008/A88CD0CB-9282-4A79-ACEA-FC2B2FAFC2F0%20Contents/B0B89433-1BAF-4DD4-B435-95BD34510DEC%20Contents/2AA0F572-420B-4E03-B474-1FE7738B96A2%20Contents/./System/Library/Kernels/kernel“ cannot find the file.

    I have tried serveral things a redownloading pacifist and the .iso /.dmg File. unfortunately it wont help. i cant extract the kernel file .. whats wired is, that the process runs for lets say 30 % of the extracting but after 30% extraction the error-message appears.

    has anybody an idea why that message appears? what did i do wrong?

    the file-rights are -rwxr-xr-x maybe it has something to do with this file-rights, anybody??
     
  8. Hindrik1997, Jun 17, 2018
    Last edited: Jun 17, 2018

    Hindrik1997 macrumors newbie

    Joined:
    Jun 7, 2018
    #4208
    I am trying to install El Cap on my XServe '06, but it keeps kernel panicking on boot. Even a pre installed disk from my 1,1 mcp keeps panicking and rebooting on my xserve. Any ideas?

    UPDATE: Removing AppleIntel8254XEthernet.kext fixes it, however El Cap doesn't see my internet interfaces now...
     
  9. swishpan macrumors newbie

    swishpan

    Joined:
    Jun 17, 2018
    Location:
    Michigan
    #4209
    Hello!

    I've been a viewer of this forum for quite a while, but have never participated until now. I have two Mac Pro 2,1 machines. I did the security updates. To make a long story short, I resurrected the machines with a ton of trial and error. I now have a hard drive and time machine backup. I learned from this!

    Anyway, one of the Mac Pro machines will not reboot. It actually was this way, before the '2018-001' update. It gets stuck, and you can hear it trying, within the tower. I've looked at the Boot Rom version, and it seems to be the common version that is appropriate for that machine. Is the Boot Rom the issue? And is there an easy way to apply a patch? I've done a bunch of looking, and usually I can find the right words to Google properly. I haven't found the right solution yet.

    My Machine is a Mac Pro Quad Core x 2 (so 8 core)...and I think it's a 2007 model.

    Thanks for your help.
     
  10. Hindrik1997 macrumors newbie

    Joined:
    Jun 7, 2018
    #4210
    The 2018 series of updates break El Capitan on the 1,1 and 2,1. Do not install them. You should rollback to 2017-004.
     
  11. rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #4211
    Try clearing the Parameter RAM (PRAM)....



    After doing this you will need to choose which disk to boot from. On reboot, when you hear the chime, hold down the ALT key, then choose the disk that has the Pikified installer on it.

    If it was the PRAM, you might need to clear, and then re-run pikify...
     
  12. mmontec macrumors newbie

    Joined:
    Jun 18, 2018
    #4212
    Hi all,

    First of thanks to everyone for the loads of information and all the hard work to make this happen. I followed the instructions and got El Cap to successfully start up and run from a second HD in my Mac Pro (Model A1186). Unfortunately it is consistently crashing after a few minutes of use.

    I don't know where or how to start debugging the issue to come up with a solution on how to fix this. Does anyone have any advise or suggestions on how to problem solve and/or resolve this issue?

    Thanks!
     
  13. Ant3000 macrumors 6502

    Joined:
    Jul 20, 2015
    Location:
    UK
    #4213
    What RAM do you have and in what configuration?
     
  14. mmontec macrumors newbie

    Joined:
    Jun 18, 2018
    #4214
    @Ant3000 Thank you for getting back to me. I'm including some screen shots below regarding the RAM config. The computer had also had a 1gb and a 512mb chip but I removed them after I read that 1GB and lower chips don't play nice. Let me know if you have any recommendations or ideas on what the problem is.

    [​IMG]
    [​IMG]


    -Michael
     
  15. Rettspann macrumors newbie

    Rettspann

    Joined:
    Jun 21, 2018
    #4215
    I followed the instructions in the video and the Pikifying process seemed to be ok. I saw the final "reboot" message and accepted. But after hearing the Apple "chime" nothing happened! I have a Windows Radeon HD5770 so no initial display but I waited for ages...
    Can anyone offer any advice please?
     
  16. Ant3000, Jun 21, 2018
    Last edited: Jun 21, 2018

    Ant3000 macrumors 6502

    Joined:
    Jul 20, 2015
    Location:
    UK
    #4216
    Have you tried resetting the PRAM?
    Are you sure the HD used is OK?
    It could just be lack of RAM - I can't recall what the min needed to run El Cap is but if you have more it is worth adding it. It needed 12gb to install (or at least it did last time I installed it) so assume you either have more RAM or a second Mac you installed it with? More RAM is worth adding anyway and is relatively cheap. Depending how you are going to use this 4gb isn't really enough for many apps - I have 32gb of the stuff with big heat sinks and El Cap runs well.
    As you noted, don't use the 512 or 1gb sticks as they have been known to cause issues.
    --- Post Merged, Jun 21, 2018 ---
    It may be waiting for you to select the boot drive - but you can't see it as the graphics card doesn't show a boot screen.
    Do you have more than one HD installed? If so, pull the others so it only has one to choose from and it may then select this by default on start-up. You can then select start-up disk in the System Prefs for future use. All this is assuming the install went OK.
     
  17. mmontec macrumors newbie

    Joined:
    Jun 18, 2018
    #4217
    @Ant3000
    I have tried resetting the PRAM. Not sure about the HD but it was brand new. You are right that I installed El Cap on the HD from another computer. I've taken your advice and purchased 8x4GB chips on eBay to beef up the RAM significantly. Hopefully that fixes the problem. I will let you know!

    Again, thank you very much for taking your time to help me with this, I really appreciate it.
     
  18. Ant3000 macrumors 6502

    Joined:
    Jul 20, 2015
    Location:
    UK
    #4218
    No problem - I have had lots of help on here so good to try to pass it on. RTHPJM has done a huge amount to help on this and if you look up his posts there is a lot more information.
    Good luck.
     
  19. mmontec macrumors newbie

    Joined:
    Jun 18, 2018
    #4219
    @Ant3000 Through the miracle of eBay and the US Postal service I already got the RAM this morning, installed it, and things seem to be working great! No crashes and I think I'm in business. Thank you very very much for your help and to everyone on this thread and board for all the amazing work to bring my perfectly good Mac Pro back to serviceable!

    [​IMG]
     
  20. grigorye macrumors newbie

    Joined:
    Jun 26, 2018
    Location:
    Almere, Netherlands
    #4220
    Just in case, to be safe and not accidentally trigger the update to 2018-003, you can disable it via

    > sudo softwareupdate --ignore 'Security Update 2018-003'

    After that you won't see 2018-003 listed in the software updates.
     
  21. haveuseenmybaseball, Jun 26, 2018
    Last edited: Jun 26, 2018

    haveuseenmybaseball macrumors newbie

    Joined:
    Jun 26, 2018
    #4221
    Hello everyone in Macrumor land, I have a similar question to some of the ones answered but I haven't been able to find my specific solution. Any help would be awesome and highly appreciated!

    I have somewhat updated my mac pro 1.1 2006, originally 2.66 to the quad 3.0, now with 32 gb ram, ssd , el capitan, and yeah yeah... now for the graphics card. I bought supposedly an apple 5770 to replace the x1900. Old card works with el capitan and 42 inch display, but not the 5770. 5770 powers up, won't show video. I got another apple display, 30in?, to try, still nothing on 5770. Tried them together, same. Bought dual link dvi adapter on amazon, still no. Ideas? Thanks for reading !
     
  22. Hindrik1997 macrumors newbie

    Joined:
    Jun 7, 2018
    #4222
    Just reinstalled El Cap on my 2,1 but it randomly kernel panics. Any ideas?
     
  23. SoulCreation macrumors newbie

    Joined:
    Jun 27, 2018
    #4223
    I am grateful to find that their are people who still lover their MacPro 1,1.
    For the last 6 years my MacPro sat in a box with me not knowing how to bring it back. I missed it terribly.
    I did not want the new ones as it lack the luster and what I know is capable from the original design.
    I did hackintosh to keep running my favorite programs, but its not the same and the performance lacking unless i kept upgrading things. I missed my dual core the most. Then I came across a video that said I can make it run El Capitan. Hope in my eyes to get my machine back. I am still lusting for a MacPro 5,1 -- and hope one day to get one..... but right now my focus is to resurrect my MacPro 1,1.

    I have read this entire post from beginning to end.
    I followed the instruction on post #1390 The Pikify app

    Using my mac mini which when I got it had El Capitan and I have now discovered it has High Sierra. Not sure when that happened.

    On the Mini: I re-downloaded El Capitan
    External Drive: prepped drive for MacPro 1,1
    My plan was to get it running on the external drive, dismount it and place it in the MacPro 1,1
    On the Mini: I followed the steps of Pikify -- it completed; each time to reboot -- it failed.
    The files are their as I can view them.
    I have discovered that Sierra is preventing it due to the changes made.
    I have tired to boot into my clone of MacMini with ElCapitan and to other clone drives from previous to have them show up as external but not bootable. When I attempt to boot them using Option Key -- only the MacMini original drive shows.

    I tried changing the start up disk and same still happens.

    I figured that the drive I created should still reboot in Mac Pro 1,1
    but each time I use the Option Key -- the only two drives that show is Lion & Recovery but no El Capitan.

    I did make a flash drive, El Capitan but I know that the Mac Pro 1,1 cant see it and its being ignored now by MacMini.

    I am frustrated and do not know what more to try.
    I feel as thou I am missing something simple......

    Any help is greatly appreciated.
     
  24. rthpjm, Jun 28, 2018
    Last edited: Jun 28, 2018

    rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #4224
    Hello SoulCreation,

    Welcome.

    I have not tried Pikify with that combination. However, you should be okay to “build” the modified installer from your Mac Mini onto the external drive.
    El Capitan, Sierra, and High Sierra all implement SIP (system integrity protection). This means that your Mac Mini cannot set the “next boot” volume programmatically because it is running High Sierra with SIP enabled. Correctly signed helper applications might be able to do this, but the Pikify app is not signed for various reasons.

    Please understand that the whole Pike-modified system is designed to boot the Mac Pro. It is probable that the modifications are not compatible with your Mac Mini. Therefore it may not boot the Mac Mini.

    My recommendation is to re-fit the drive into your MacPro.
    At boot, when you hear the chime, hold down the Alt key.
    You should be presented with the boot selector screen.
    You should see your hard disk.
    Select this to boot.

    Cross your fingers, hold your breath...
    Hopefully it will boot into the installer...



    Alternatively, you can keep the HDD attached to your MacMini, run the “Install OS X El Capitan” app directly on the Mac Mini (no need for Pikify, or any other modifications at this stage). I think it will launch (it might not launch or it might not allow you to continue because your Mac Mini is at a higher release of the OS, but if it does, then...) then simply choose to install on the external HDD.
    You must then replace the two boot.efi files on the external drive manually.
    Optionally, replace the boot.efi file on the Recovery HD partition of the external HDD too (you will need to search for instructions of how to mount the Recovery HD partition).
    Once you have done that, re-fit the external HDD to your MacPro.
     
  25. rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #4225
    Try moving the cable to the other connector on the gfx card...
    --- Post Merged, Jun 28, 2018 ---
    That usually happens with low RAM configuration. What RAM do you have?
     

Share This Page