2006/2007 Mac Pro (1,1/2,1) and OS X El Capitan

Discussion in 'OS X El Capitan (10.11)' started by Mr. Zarniwoop, Jun 8, 2015.

  1. dcloud45 macrumors member

    dcloud45

    Joined:
    Oct 5, 2015
    #1351
    thanks OGnerd can you tell me the command us
    what command is that?
     
  2. slopeza macrumors newbie

    Joined:
    Nov 25, 2015
    #1352
    I have installed El Capitan in a supported mac and change boot.efi in /coreservices/ and /i386 . I mount de hard disk in Mac Pro but the system not work.
     
  3. Oculos macrumors newbie

    Joined:
    Nov 13, 2011
    #1353
    Has anyone upgraded a previous Yosemite install to El Capitan? I remember I installed Yosemite that way, upgrading from the previous install by replacing the boot file on the installer. Is it doable now?
     
  4. OGNerd, Nov 26, 2015
    Last edited: Nov 26, 2015

    OGNerd macrumors regular

    OGNerd

    Joined:
    Jun 1, 2015
    #1354
    Type man bless in Terminal to get a rundown on how to use the bless command.

    Type csrutil in the Terminal app of the Recovery OS to get a rundown on how to disable, enable, and check the status of SIP.
     
  5. OGNerd, Nov 26, 2015
    Last edited: Nov 26, 2015

    OGNerd macrumors regular

    OGNerd

    Joined:
    Jun 1, 2015
    #1355
  6. andsat macrumors newbie

    andsat

    Joined:
    Oct 9, 2015
  7. Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #1357
  8. slopeza macrumors newbie

    Joined:
    Nov 25, 2015
    #1358
  9. hwojtek macrumors 65816

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    Poznan, Poland
    #1359
    You need to disable SIP (csrutil disable in Recovery terminal) in order to use bless in El Capitan:
    https://developer.apple.com/library...ion/ConfiguringSystemIntegrityProtection.html
     
  10. andsat macrumors newbie

    andsat

    Joined:
    Oct 9, 2015
    #1360
    Anyone else not able to boot into Recovery?

    I've tried holding command+R while booting as well as choosing it from the boot options menu. Just boots the main partition.
     
  11. dickmnixon macrumors newbie

    dickmnixon

    Joined:
    Nov 2, 2015
    #1361
    I too am having an issue booting to the Recovery Partition as well. It worked for me a bunch of times in the past 3 weeks since I put El Cap on my 1.1

    The only thing I change on my system was to add the Inateck USB 3 card people had recommended in this and some other threads. The only thing I really found the card to mess with was my ability to login to iTunes or the Mac App Store. I ran a few terminal commands to delete my user info and then it let me sign in. I pulled the card and tried again but that did not seem to be the reason it wasn't going to recovery mode.

    I used http://musings.silvertooth.us/2014/07/recovery-partition-creator-3-8/ to create a new recovery partition on a different drive and after that I was able to boot to it with Command+R *
    I have Lion on the drive as well and only drop it in one of the internal bays if I really need to boot to something else or boot to the recovery partition to replace the boot file.

    *Your milage may vary :)
     
  12. andsat macrumors newbie

    andsat

    Joined:
    Oct 9, 2015
    #1362
    so I was just able to fix it--

    in Terminal-

    $> diskutil list

    note there should be /dev/disk0 with partition 3 being Recovery HD

    $> diskutil mount /dev/disk0s3

    you'll now have Recovery HD. browse to com.apple.recovery.boot and you should see boot.efi

    unlock the file

    $> sudo chflags nouchg /Volumes/Recovery\ HD/com.apple.recovery.boot/boot.efi

    replace it with the one you use from https://github.com/Piker-Alpha/macosxbootloader

    (I just copy + paste in Finder)

    then lock the file and unmount

    $> sudo chflags uchg /Volumes/Recovery\ HD/com.apple.recovery.boot/boot.efi
    $> diskutil unmount /dev/disk0s3

    this allowed me to finally boot into Recovery so I could disable SIP w/ the following

    $> csrutil disable

    :)
     
  13. dickmnixon macrumors newbie

    dickmnixon

    Joined:
    Nov 2, 2015
    #1363
    Your fix worked like a champ for me, Thanks.
     
  14. Roland L macrumors newbie

    Joined:
    Jan 8, 2014
    #1364
    Apologies if this is a question which has been addressed earlier (though a thorough search here and Google is not yielding any answers) - is there a way to disable the hardware/ID check which prevents the App Store from allowing downloading of El Capitan please? I don't have access to another Mac.

    I'm using a Mac Pro 1,1 running Yosemite. I am aware of the 'Mavericks Download Enabler' - but that's very old now.

    Alternatively how can the ftk3252456602304584541.pkg (which Apple do allow to be downloaded) be opened? XAR is failing me, as is Pacifist.
     
  15. slopeza macrumors newbie

    Joined:
    Nov 25, 2015
    #1366
    I disable SIP and reboot the computer but....

    SERGIO-GMAC:~ sergio$ sudo bless --folder /volumes/SSD --file /volumes/SSD/boot --setBoot
    Password:
    Error while getting file ID of /volumes/SSD/boot. Ignoring...
     
  16. will_half macrumors newbie

    will_half

    Joined:
    Nov 30, 2015
    #1367
    Got me up and running again with the pikify3.1v2. Thanks very much :)
     

    Attached Files:

  17. Spleeny, Dec 1, 2015
    Last edited: Dec 1, 2015

    Spleeny macrumors newbie

    Joined:
    Nov 30, 2015
    #1368
    same problem than slopeza 2 post above
    I followed this tuto to install 10.11 but my MP1.1 Reboot on old partition when I choose the new for install, when I try the screen turn black with white apple (elcapitan boot screen) for 5 sec then turn grey with dark grey apple and boot old 10.8 instead 10.11 installation menu.
    Bless command doesn't work
    When I try I get
    Code:
    Error while getting file ID of /Volumes/OS X Base System/boot. Ignoring...
    Could not find IODeviceTree:/options
    Any help ?
     
  18. Galostro macrumors newbie

    Joined:
    Oct 22, 2013
    #1369
    You should hide ur serial :)
     
  19. evagelos macrumors newbie

    evagelos

    Joined:
    Sep 18, 2014
    Location:
    Patras, Greece
    #1370
    pikify3.1v2 ???
     
  20. Morpheo macrumors 65816

    Morpheo

    Joined:
    Feb 26, 2014
    Location:
    Paris/Montreal
    #1371
    Maybe a new streaming service from Pike every time he updates his boot.efi? ;)
     
  21. JOSECBA, Dec 2, 2015
    Last edited: Dec 2, 2015

    JOSECBA macrumors member

    JOSECBA

    Joined:
    Sep 1, 2015
    #1372
    Anyone knows if this GRAPHIC CARD: Ati Radeon R7 240 2GB ddr3, works ok on MAC PRO 1.1 ? I have the GeForce 210 right now.
    Thanks. Screen Shot 2015-12-01 at 7.08.18 PM.png
    52h.jpg
     
  22. RaimisFr macrumors newbie

    Joined:
    Dec 2, 2015
    #1373
    Salut! Ne te presse pas d'installer El Capitan sur MacPro 2.1, je viens de le faire et l'ordinateur plante toutes les 2 minutes. Je cherche une solution.
     
  23. RaimisFr macrumors newbie

    Joined:
    Dec 2, 2015
    #1374
    Hi, I have installed El Capitan on MacPro 2.1 on two different drives SSD and HD. Booting normally but computer reboot after 2-5 minutes. Same thing on SSD or HD. Any idea? Do it's my copy of El Capitan installer is "freaky" ?
     
  24. donjames macrumors member

    Joined:
    Feb 20, 2015
    Location:
    Henderson, Texas
    #1375

Share This Page