2009 Mac Mini won't sleep

Discussion in 'Mac mini' started by claaariii, May 5, 2016.

Tags:
  1. claaariii macrumors newbie

    Joined:
    Feb 12, 2010
    #1
    Hi!

    I've read through lots of forums with this problem but can't seem to find a solution.

    My Late 2009 Mac Mini, running OSX Version 10.11.4, apparently randomly stopped sleeping...it took me a while to notice it but probably started happening about 3 weeks ago.

    Whether I command+option+escape, press the power button, select "sleep" from the power menu, or let 15 minutes go by, the display will turn off (and often, upon "waking" pops up an "out of range" error which is also driving me crazy...), but the Mini's light stays on and the drive keeps buzzing.

    There are no apps "preventing sleep" in activity monitor, I've set the firewall to block all incoming connections, the only thing hooked up to the Mini is the display and keyboard, with a Mighty Mouse hooked up to the keyboard (I've tried unplugging both the mouse and keyboard and still won't sleep), I've done SMC and NVRAM resets.

    This is what pmset -g shows in terminal, which is the most advanced thing I've ever done in terminal :)

    Active Profiles:
    AC Power-1*
    Currently in use:
    hibernatemode 0
    womp 0
    networkoversleep 0
    sleep 15
    Sleep On Power Button 1
    ttyskeepawake 1
    hibernatefile /var/vm/sleepimage
    autorestart 0
    disksleep 10
    displaysleep 15


    I've read that "ttyskeepawake 1" is the default value, and a bunch of people with that value whose computers still sleep. Not sure what it means though.

    Please help! Thanks :)
     
  2. MultiFinder17 macrumors 68000

    MultiFinder17

    Joined:
    Jan 8, 2008
    Location:
    Tampa, Florida
    #2
    Is there anything in the print queue? My Mac Pro refused to sleep a while back, and it turned out to be something about having an active job in the print queue. Weirdest thing.
     
  3. claaariii thread starter macrumors newbie

    Joined:
    Feb 12, 2010
    #3
    Thank you!!!!!! That was it! :D

    Sure enough, there was one PDF in my print queue (but I had to go searching for printer preferences, wasn't on my dock or anything), and a printer was showing up as "in use". I checked the file and it was a PDF that I downloaded exactly 3 weeks ago (my calculations as to when the error started we're accurate!). I now recall hitting "print" on the file, thinking it would give me the option to "save as PDF" but it didn't, so I found the right way to download it. I deleted the file from the queue, and the printer now shows up as "offline" and the mini sleeps!!

    I just actually went ahead and deleted the printer altogether, since it was the previous owner's and I don't even currently have one, to avoid the same thing happening in the future.

    Now I feel like going back to all the forums I read and adding this as an option...definitely the simplest of all!

    Glad my Mini will get some much-needed sleep tonight :) I forgot to just turn it off a few times before going to sleep myself these past few weeks, it's silent enough but the buzzing was sometimes annoying. My 2 year old thought it was raining one night, lol.

    Thanks again!!!
     
  4. MultiFinder17 macrumors 68000

    MultiFinder17

    Joined:
    Jan 8, 2008
    Location:
    Tampa, Florida
    #4
    Excellent, glad that helped! That issue buggered me for the longest time before I could figure it out; it's a weird, random issue that took me a week to think of!
     

Share This Page