2016 MBP Critical software update fail

Discussion in 'MacBook Pro' started by GatewayMike, Nov 14, 2016.

  1. GatewayMike macrumors newbie


    Jun 18, 2010
    IMG_0028.JPG So, I just finished migrating to a 2016 15 MBP. After a restart, here's the wonderful result. This pic was taken on the 4th try...
  2. gooser macrumors 6502a

    Jul 4, 2013
  3. GatewayMike thread starter macrumors newbie


    Jun 18, 2010
    I feel so lucky to have waited 3 weeks and spent $4200. on a POS.
  4. CoastalOR macrumors 68020


    Jan 19, 2015
    Oregon, USA
    How did you migrate? Did you move data/software from a older Mac/OS?

    If old data/software was migrated then it could be a conflict with the new MBP or OS. If your error is from the initial startup of the new MBP, then contact Applecare.
  5. Los Angeles macrumors member

    Sep 25, 2012
  6. YsoSerious macrumors 6502


    Oct 8, 2008
    That's why I always start fresh on new Mac's. It's a pain in the @ss reinstalling apps but I feel it's the best solution for me that has worked over these many years. Why I don't use time capsule and just back up data (photos, docs and work).
  7. karbim macrumors regular

    Oct 11, 2016
    London, UK
    What version of Mac OS did you upgrade from? Sierra 10.12.1?
  8. dumastudetto macrumors 68030

    Aug 28, 2013
    Yes definitely id try wiping it clean and doing the updates. It's a pita restoring everything manually but it does get you a much cleaner system.
  9. CreativeC macrumors member

    Oct 23, 2016
    What good is having time machine if you can't use it to restore your files?
  10. dumastudetto macrumors 68030

    Aug 28, 2013
    I wouldn't know, I don't use time machine and never have. But I imagine you can manually pull what you need and copy documents and other assets to your new machine.
  11. Los Angeles macrumors member

    Sep 25, 2012
    Hey Gateway Mike,

    I had the same issue as I mentioned above. I dont believe this is from your backup process. This error message was intermittent with my computer. I only got past the set up once then it came back. Im pretty sure your computer came with this issue. I have now returned mine and Im on the phone with Apple and they are giving me a tiny discount 200 dollars but they are going to put my build at the front of the line and ship it out ASAP.

    None of my business but I would recommend you return that machine and get a new one.
  12. Paulito240 macrumors newbie

    Dec 30, 2009
    Gateway Mike,

    Just had this same issue. My 2016 MacBook Pro 15" didn't even ask me if I wanted to update, it just happened on Restart. Called Apple Support talked with them for two hours. They were stumped with the term "critical" software update and they said Apple would never use a word like that for an update. They found a service bulletin that stated to click "Try Again" until it works. That's all that it said, one step...no reasons why. Well that never worked, obviously. They left me with two options: Boot into recovery mode and reinstall Sierra or Boot into recovery mode, erase my hard drive, and do a clean install of Sierra.

    Tried the reinstall of Sierra and the same error message kept popping back up. So I backed up my drive in Safe Mode, rebooted into recovery mode and did a clean install of Sierra and that worked. Fingers crossed that this won't happen again. I've turned off automatic updates and turned off FileVault
  13. tomviolence macrumors member

    Jan 16, 2012
    I got this ‘critical’ message too, tried again, no difference, but… I just plugged in the power cord, which solved it. Figured it had to do with that. Can anyone confirm this? Otherwise there obviously is another issue at hand.
  14. thesaint024 macrumors 65816


    Nov 14, 2016
    suspension waiting room
    +1. Fresh install is like moving. You are forced to decide if you really need all the useless crap you've accumulated over the years that may just clutter your new house. If you don't, you could end up with some Clarisworks extensions on your 2016 Mac. It's only a couple of weeks of occasional pain of forgetting to reinstall something. If after a while, you'll see you don't really need the apps anymore. Files are a different story. Keep ALL of them.
  15. LxHunter, Feb 14, 2017
    Last edited: Feb 14, 2017

    LxHunter macrumors 6502

    Nov 14, 2010
    Had this error also
    Bought new MacBook 13 TB and first updated to 12.3
    Did a Time Machine transfer and when restarted this error occurred.
    Tried a restore of the OS but still error.
    Apple replace the MacBook
    I tried a Time Machine transfer from another HD with an earlier backup.
    Same problem.
    Apple replaced again
    Now typing this on the 3rd MacBook I configured from scratch.
    Wasn't going to try a third time with the Time Machine transfer.
    As they say "Jamais Deux Sans Trois"

    So I guess there a 2 Refurb's soon to be bavailable
  16. ZMacintosh macrumors 65816


    Nov 13, 2008
    Have not experienced this yet on a 13 or 15 MBP 2016. Though I do use iCloud Drive (Desktop + Documents) + iCloud Photo library + Time Machine...all my files are where I left them, install the apps from the App Store, adobe & other 3rd party installers are in the documents folder, and it points to my pre-existing backups from the last year or two.

    I'd recommend a Clean install + manual migration. and utilize any of the syncing services for an easier set-up.
  17. Sanpete, Feb 14, 2017
    Last edited: Feb 14, 2017

    Sanpete macrumors 68020

    Nov 17, 2016
  18. MH01 Suspended


    Feb 11, 2008
  19. Brookzy macrumors 601


    May 30, 2010
    PSA: While I can't help those who keep seeing this message repeatedly, it may interest you that this 'critical update' is the Touch Bar's OS. When you do a clean install of Sierra, it does a clean install of the watchOS-esque software on the Touch Bar's chip too. That's why it's critical, and why you can't skip it.

    Yep, as per above. :)
  20. benghee macrumors newbie

    Jun 25, 2010
    Yes, i found you! I unplug my power cable then restart the mac and see this "critical" message and tried several attempts, including my free of charge warranty chat support ask me go back to mac store to have it check with the senior tech, and i also almost come very close to reformatting my mac....after discover the battery icon is still in charging status even i plugged out the cable, so i have to do the SMC reset, https://support.apple.com/en-us/HT201295 and then try one more time go back to my login screen...voila! it return to desktop, all my files there with tears in my eyes.

    It seems like the touchbar causing this "critical" message somehow as the Apple support stated in our conversation:

    "I understand, with the touch bar it is a new technology with each update we are improving it. This installs the firmware on the mac and from what I have seen on this error is usually why it get’s this error. Since the firmware was not downloaded or connected correctly which would get this error. You’re welcome, if you have any other issues or concerns just contact us again!"

    I hope someone will find helpful of what i experienced here.
  21. dontwalk macrumors newbie

    Aug 7, 2017
    It is possible to boot in safe mode.
    I'm looking for how to disable this "update"... If some one know, please help. Thanks.
  22. Frankfurt macrumors 6502


    Dec 4, 2016
    I did not have this issue. I migrated manually from a 2008 Macbook with El Capitan installed. I did not want to import any potential issues via Time Machine and thus manually copied over iTunes, photos and documents and reinstalled apps (e.g. Office for Mac 2016).

    Now this makes me wonder how the High Sierra update will work out. I will definitely sit that one out for a few weeks until the dust settles on issues people encounter.
  23. blackcypher macrumors newbie

    May 3, 2017
    I just ran into this issue. Here's the entire experience and resolution.

    I noticed that when you boot into normal mode, you're faced with a WiFi connection screen asking you to connect to install the critical update. No matter what you do, it never seems to succeed, leaving you with the error message where the Mac can't start until this critical update is installed.

    I tried NVRAM and SMC resets, Online Recovery, First Aid on the SSD, Time Machine Backups, Deleting partitions and reloading the OS, Mac Diagnostic tool upon boot, nothing worked. Booting into Safe Boot works, that's how I temporarily dragged off my files onto an external drive.

    At no point did the touch bar ever light up, which meant that it failed or something was preventing it from working.

    I scheduled a visit to the nearest Apple Store Genius Bar and had them run something called MRI (Mac Resource Inspector), a software tool only Apple-techs have access to which connects my laptop to their in-house server which scans my machine remotely.

    During the mid point of the scan, I noticed my touch bar lit up, then about 5 minutes later the scan showed no problems. The tech restarted my machine but performed the NVRAM reset (CMD + Option + P + R) before proceeding to boot normally.

    This time it went all the way through and allowed me to login normally. This leads me to think that the MRI software either loaded something my laptop needed or reset the condition that kept forcing me to apply an un-installable update.

    Finding an article online, I read that there might be some sort of conflict between the Mac OS (High Sierra) and the OS for the touch bar controlled by the T1 CPU. I'm guessing that if both don't recognize each other, it may result in this problem.
  24. redleg6 macrumors newbie

    Jan 9, 2018
    South Central PA
    So, is it safe to construe from the conversations above that this issue effects 2016 MBP with touch bar and running 10.12.x and is only a problem when you upgrade to High Sierra?
  25. blackcypher macrumors newbie

    May 3, 2017
    I'm not sure if it's an issue with High Sierra. TBH both the tech and I were still unsure as to the cause.

Share This Page