3.1.2 suddenly crashes after blacksn0w install

Discussion in 'Jailbreaks and iOS Hacks' started by ShaftX, Feb 5, 2010.

  1. ShaftX macrumors newbie

    Joined:
    Feb 5, 2010
    #1
    A very strange thing occurred yesterday. After months of enjoying FW 3.1.2 with the blacksn0w unlock (I'm using an iPhone bought in the UK, in Holland), my iPhone suddenly became very slow after losing the signal, which froze after that. Thought I reboot, but it came then stuck on the Apple logo, rebooting every few minutes.

    I thought a restore would do the trick. Ironically, the 3.1.3 update was released that day, so official Apple restore wouldn't work. Restored my iPhone with PwnageTool and unlocked it with blacksn0w. Problem stays! Once blacksn0w is installed, it turns slowly and when I open the settings pane it crashes after sometime, leaving me again in the Apple-logo-loop.

    The strange thing is everything works perfectly fine, when I restore and do not install blacksn0w. Installing it again causes it to go back in the loop, tried it several times.

    How could this happen out of the blue while enjoying blacksn0w since it was released? I was just using Safari while the signal dropped and crashed after that.

    Any thoughts?
     
  2. crashie macrumors newbie

    Joined:
    Feb 7, 2010
    #2
    I have roughly the same - the phone became really slow when I was tethering using MyWi.

    Rebooted, and when I try to jailbreak using blackrain or redsnow, it takes unusually long to boot up (spinner thingy stays on the screen for a while), then looks like it crashes, apple logo, and its back into restore state.

    Cannot restore to 3.1.2 because 3.1.3 is out, and its advisable to upgrade obviously.

    If you have found the solution, please let me know.
     
  3. T.Sthlm macrumors newbie

    Joined:
    Feb 7, 2010
    #3
    Pretty much the exact thing has happened for me. I've been using the phone with blacksn0w for about a month, and it's worked quite good, apart from sometimes loosing 3G coverage, and then gotten it back after a few seconds. But all of a sudden, it got slow and then froze. After reboot, it got stuck on Apple logo, and after waiting a while, a semi-transparent loader wheel appeared on top of the Apple.

    I find it extremely odd is that a complete restore doesn't help, as soon as blacksn0w is installed, the same problem appears right away. What in the phone could possibly be different now from when the first time blacksn0w was installed?

    I've Googled and found a number of people who are complaining they're getting stuck on the Apple logo after installing blacksn0w, but no explanations or proposed solutions, unfortunately.

    I'm wondering if we're screwed.. I'll keep looking and report back if I find out more, please do the same.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
    I clarified there is a tutorial how to open Itunes for custom or older firmware ispw.
     
  5. crashie macrumors newbie

    Joined:
    Feb 7, 2010
    #5
    Well, the tutorial amounts to holding the 'Option' key while clicking restore, which allows you to select a firmware file. However then it will go talk to Apple to make sure it doesn't mind me installing that firmware. And because its not the latest any longer, Apple does mind.

    I've tried blackrain on windows, and the behavior is slightly different - the phone goes into a reboot loop:

    - make it rain -> long frodo + spinner image -> phone restarts (apple logo) -> blackrain picks it up and applies the hack again -> repeats over and over
     
  6. ShaftX thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #6
    When did this problem started to occur to you guys? Strange case..

    Be advised that I already restored the iPhone using a custom ISPW created with PwnageTool. This worked, untill I reinstalled blacksn0w. Then the same problem occurs again.
     
  7. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #7
    How long did you wait for the phone to restart? I have occasionally (I think twice in the time I've had my phone) had to wait 10-15 minutes for my phone to start up after encountering a problem like that. I believe both times it occurred after installing or uninstalling a package that made changes to system files. My assumption has been that the phone is doing some sort of memory check or something; maybe if I had verbose boot I could see what it was doing. If I let it spin long enough, it boots in the end and subsequent restarts will have normal boot times. Until I let it finish its spinning, though, no amount of hard-resetting will get my phone booted.
     
  8. crashie macrumors newbie

    Joined:
    Feb 7, 2010
    #8
    I'd say it takes around five minutes. Spinner gets to 3/4 fast, but then it stales, gaining a few edges during the subsequent waiting. But then it restarts, everything goes around, and boot after applying blackrain is exactly the same.
     
  9. ShaftX thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #9
    I think I left it on for a few hours, it just keeps rebooting itself after a few minutes, over and over again..
     
  10. T.Sthlm macrumors newbie

    Joined:
    Feb 7, 2010
    #10
    The first time my Phone crashed like this was after using it for a couple of weeks. The weird part is that the first time time, the problem disappeared after I did a restore and applied Blacksn0w again.

    The second crash was three days ago, about two-three weeks after the first crash. This time around, the phone becomes unstable instantly when applying blacksn0w, signal stuck at "Searching...", crashes after a few minutes, and is stuck at the Apple logo after reboot, exactly like described above. I've tried like ten times, resetting network settings, applied blacksn0w manually (through the file system), through cydia, through blackra1n.. same problems either way.

    I can't understand why the problem persists after a restore this time. My theory, which is ONLY A GUESS, is that Blacksn0w somehow alters the baseband over time, in a way that is not reset by doing a restore.

    Since I don't have my hash for 3.1.2 stored in Cydia, I can't do a restore to the official 3.1.2 firmware, I can only restore to custom firmware made in PwnageTool. MAYBE an official restore to 3.1.2 would also overwrite and reset the baseband. Thoughts or other theories, anyone?
     
  11. ShaftX thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #11
    I finally got the iPhone working again! Thanks for above post, reminding me that in had indeed stored my SHSH with Saurik's servers. These are the steps I have followed to restore my iPhone:

    1. Edit the hosts file of my mac to route the Apple servers to Saurik's servers.
    2. Put the iPhone in DFU mode. (NOT recovery)
    3. Restore to 3.1 (Don't know why exactly, was so tired of 3.1.2 that I thought I should try 3.1)
    4. Jailbreak with blackra1n, unlock with blacksn0w

    That was all. I could understand that people don't have the SHSH stored with Saurik / Cydia, the only thing I can think of to try is put the iPhone in DFU mode, and try to restore to 3.1 or 3.1.2 with a custom made PwnageTool package.
     
  12. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #12
    Won't work without SHSH stored for 3GS
     
  13. T.Sthlm macrumors newbie

    Joined:
    Feb 7, 2010
    #13
    Congrats! Since I'm an idiot and didn't store my SHSH for 3.1 or 3.1.2, I'm still out of luck though :'(

    I'll try a custom 3.1 and see if that helps.
     
  14. T.Sthlm macrumors newbie

    Joined:
    Feb 7, 2010
    #14
    Ok, from all the research and trial-and-error I've been through, here is my full description of the problem, theory of the cause and proposed solutions. I'm hoping others that have this same issue find use for this information. I would also love to have this confirmed or debunked by someone in the hacking scene who know more.

    This info is relevant for: iPhone 3Gs at firmware 3.1.2, 5.11.07, Jailbraked and running Blacksn0w.

    Symptoms: Blacksn0w works to begin with. After using it for a while (a few weeks to a month), your phone crashes, and on reboot it freezes at the apple logo. After a while a semi-transparent loader (spinning wheel) appears over the apple logo. Then after some more time, the phone reboots. A restore in iTunes takes care of the problem, but also removes the Blacksn0w unlock. When re-applying Blacksn0w, the problem comes back instantly.

    Cause: Blacksn0w is the cause of this behavior. It somehow alters the baseband in a permanent way over time. This could be due to a bug in Blacksn0w, or a defense mechanism apple has built into the baseband.

    Solution: A restore to a custom firmware (made in Pwnage tool) will NOT solve the problem, because it does not overwrite the baseband. However a official restore will do the trick, as reported by ShaftX above. This I believe is because the official update will re-write the baseband. Can someone who knows confirm or deny this? If you don't have your SHSH hashes for 3.1 and/or 3.1.2 stored by Cydia, Saurik or on file, this solution will NOT work, since Apple only allows official restore to 3.1.3. As of today (february 11), a 3Gs officially updated to 3.1.3 can't be jailbroken or unlocked. This means for now, without the SHSH hashes, I believe you'll have to wait for 3.1.3 jailbreak/unlock.
     
  15. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #15
    Neither blacksn0w nor any other software can alter the baseband. Blacksn0w is injected into commcenter and changes the way commcenter interacts with the baseband. Since blacksn0w does not overwrite or patch commcenter or the baseband, its effects cannot persist after it is uninstalled. Any problem you continue to have after removal of blacksn0w must be caused by something else.

    But the fact is that you don't know that it would persist if you uninstalled blacksn0w, because the only way you could get your phone out of a boot loop was to restore it and thereby remove blacksn0w. All you can say for sure is that with blacksn0w installed your phone crashes. Your wild speculation about blackra1n permanently altering the baseband is the purest fantasy.

    As for your problem, I have to say that it doesn't surprise me. Blacksn0w uses a very difficult injection method to deliver a payload which is known to exacerbate a bug in commcenter that affects Wi-Fi. I don't doubt that you are having this problem, I just think it is irresponsible to throw around half-baked theories for which you have no basis in evidence.
     
  16. T.Sthlm macrumors newbie

    Joined:
    Feb 7, 2010
    #16
    There here are a number of reports of the exact problem that I'm experiencing, but no one has been able to explain the cause or propose a solution. I respect that you think it's irresponsible to put my theories in a discussion, but I did it to see if this theory could be proved or disproved. Thanks for doing that.

    So what do you propose to do? All this still leaves the problem unsolved. After crashing, a restore gets the phone working perfectly (aprart from being locked), but as soon as blacksn0w is installed again, it instantly crashes.

    First time blacksn0w was installed, it DID NOT crash until after several weeks. So, here's the million dollar question: what in the phone could possibly be different now compared to the last time?
     
  17. wokster macrumors newbie

    Joined:
    Feb 20, 2010
    #17
    Installed pwnage, blackrain and even tried the sshh method with the host flie and everything goes fine until I install Blacksn0w and then it just goes back to the pineapple and keeps re-booting!

    Any advice would be greatly appreciated.
     
  18. mattais macrumors member

    Joined:
    Apr 29, 2008
    Location:
    Bristol, UK
    #18
    I am having these problems as well. The hardest thing about it is eliminating possible causes of the crashes. My phone was running 3.0 and blacksn0w for about 3 months, using carriers from the UK and Norway. About a week ago it froze, and wouldn't boot past the Apple logo - getting stuck in a rebooting loop with the transparent loading wheel appearing half way through.

    I upgraded my firmware to 3.1.2 using the 3.1.4 pwnage tool, but the phone wouldn't boot past the Apple logo after the restore with the custom firmware. I then restored using the regular 3.1.2 firmware, JB with blackra1n and unlocked with blacksn0w. The phone worked for a day, froze, then got stuck on reboot again. I was also suffering from the occasional signal drop out associated with blacksn0w when the phone was working.

    I repeated the process, but used Cydia to install blacksn0w instead. I also set up my phone as a new device in iTunes, not restoring my old settings. It worked fine over Friday and the weekend, but crashed this morning again.

    I am tethering, but have used several different IPCC files. The phone has crashed both during while using tethering, and without as well. This is a VERY frustrating problem - so I sympathise with all suffering from it. I hope we can find a solution soon - I don't even have the internet at my flat right now so I have to walk to town every time i need to restore my iphone/install blacksn0w!!
     
  19. ethershock macrumors newbie

    Joined:
    Feb 22, 2010
    #19
    problem with MC model - a word of caution

    Hey all, word of advice:

    I had the same problem most everyone here has been experiencing, i.e. used blacksn0w to get tethering working but then wifi fails and bricks the phone in endless boot cycle, ultimately requiring a restore. I'm going without the tether for time being.

    If you're compelled to try the blacksn0w unlock to get tethering going, you might want to check your phone model first (Settings->General->About->Model) and see if it starts with "MC". I read in another website that models beginning with MC will fail with the blacksn0w unlock. Sure enough, my model was MC135LL.

    Btw, I have o/s 3.1.2 and 05.11.07 modem fw on my 3GS.
     
  20. ethershock macrumors newbie

    Joined:
    Feb 22, 2010
    #20
    Follow-up -- success!

    Hope this will help some of you...

    I just tried a different approach to enabling tethering using sinful iphone approach instead of blacksn0w. very easy and so far my testing proves everything is working fine. wifi ok. vvm ok. tethering ok.
     
  21. bmacir macrumors 6502

    Joined:
    Apr 2, 2009
    #21
    I am having the same symptoms described in this thread. Could you please explain how you managed to haz success?

    Edit #1: i am on a 3g iphone NOT 3gs

    Edit #2: this is how I managed to have a working iPhone again: apparently restoring with custom ipsw didn't do the trick so I reinstalled the 3.1.2 non custom ipsw and ran blackra1n.
     
  22. ethershock macrumors newbie

    Joined:
    Feb 22, 2010
    #22
    well... i have a 3GS but ...

    i humbly suggest you watch this fella's youtube video "how to" at http://www.youtube.com/watch?v=bhCCxwW7ifE

    if this url gets edited out, go to youtube and search for user named "liljiggajlm" and his movie titled "How to Enable internet tethering for iPhone 3G & 3G S on firmware 3.1.2"

    btw, i had to do the exact same restore steps as you. painful but at least you know how to get your phone back.
     
  23. thinkpad77 macrumors newbie

    Joined:
    Mar 2, 2010
    #23
    any alternative for blacks0w?

    looks like many users are experiencing issues w/ blacksn0w. I am also one of them although my issue is little different. my iphone was stuck at apple logo after I turned it OFF completely and turned it ON back after following steps in iclarified on how ti jb/ul 3.1.2 3G w/ bb 05.11.07

    someone suggested to use redsn0w for jb but again use blacksn0w for ul because the former can only jb. is there any other alternative to ul an iphone other using blacksn0w? I am more interested in getting my iphone ul than jb. thanks !
     
  24. mattais macrumors member

    Joined:
    Apr 29, 2008
    Location:
    Bristol, UK
    #24
    I seem to be getting a more stable install by putting the phone in DFU mode before restoring, using the official 3.1.2 firmware, blackra1n and then snow to unlock.

    Still getting the dropped calls but no freeze/restart issues... yet.
     
  25. crazyfool2100 macrumors newbie

    Joined:
    Mar 8, 2010
    #25
    Same problem

    Hi

    I am having the exact same issue. I enjoyed an unlocked 3gs 3.1.2 (blacksn0w) for about 2 months and then I started having WIFI issues. I reset my network settings as many sites suggested, but doing that put my phone into a boot loop stuck at the apple logo (thx guys). I was forced to restore the phone with a custom 3.1.2 pwnagetool firmware and I ran blacksn0w again. It worked this time but about a week later, the phone crashed again and when I restarted it, it was in a boot loop.

    After the 2nd restore, blacksn0w no longer unlocks my phone but rather just makes it extremely slow and unstable for a min or so and then completely freezes. Restarting just puts it in a boot loop. I have tried installing blacksn0w via cydia and manually without results. I've restored and reblacksn0w'd multiple times and it crashes every time.

    It's odd to me that the unlock worked for a while, then worked again after 1 restore, and now just completely doesn't work. I don't understand what changed with the phone when I never upgraded to another firmware or made any other os modifications. I don't have my 3.1.2 shsh on file, so doing an original restore is out of the question now :(

    Has anyone had any luck solving this problem?
     

Share This Page