5K iMac problems since macOS Sierra

Discussion in 'macOS Sierra (10.12)' started by jonahke, Nov 30, 2016.

  1. jonahke, Nov 30, 2016
    Last edited: Nov 30, 2016

    jonahke macrumors newbie

    jonahke

    Joined:
    Nov 30, 2016
    Location:
    Lier
    #1
    Since the day I installed macOS Sierra on my 5K iMac I got several problems
    -When I want to shut down my iMac it get stuck on a black screen with the spinning beach ball.
    -When an app freezes and I force quit it, it won't restart (same with my Finder)
    -The beach ball appears with the easiest tasks (f.e. uploaden an image from my finder to Facebook)

    The only thing to 'solve' those problems is to restart my Mac with the power button.

    With Mac OS X El Capitan I never had any problems, so what can I do?
    I tried starting my Mac in safe mode, I did an hardware test (nothing wrong), reset NVRAM,...


    This are the results of the EtreCheck:


    Code:
    EtreCheck version: 3.1.3 (337)
    Report generated 2016-11-30 14:34:26
    Download EtreCheck from https://etrecheck.com
    Runtime 1:45
    Performance: Excellent
    
    Click the [Support] links for help with non-Apple products.
    Click the [Details] links for more information about that line.
    Click the [Remove] links to remove adware.
    
    Problem: Other problem
    
    Hardware Information: ⓘ
       iMac (Retina 5K, 27-inch, Late 2015)
       [Technical Specifications] – [User Guide] – [Warranty & Service]
       iMac – model: iMac17,1
       1 3,2 GHz Intel Core i5 (i5-6500) CPU: 4-core
       8 GB RAM Upgradeable – [Instructions]
           BANK 0/DIMM0
               4 GB DDR3 1867 MHz ok
           BANK 0/DIMM1
               Empty
           BANK 1/DIMM0
               4 GB DDR3 1867 MHz ok
           BANK 1/DIMM1
               Empty
       Bluetooth: Good – Handoff/Airdrop2 supported
       Wireless:  en1: 802.11 a/b/g/n/ac
    
    Video Information: ⓘ
       AMD Radeon R9 M390 – VRAM: 2048 MB
           iMac 5120 x 2880
    
    System Software: ⓘ
       macOS Sierra  10.12.2 (16C48b) – Time since boot: less than an hour
    
    Disk Information: ⓘ
       APPLE SSD SM0256G disk0 : (251 GB) (Solid State – TRIM: Yes)
       [Show SMART report]
           EFI (disk0s1) <not mounted> : 210 MB
           Recovery HD (disk0s3) <not mounted>  [Recovery]: 650 MB
           Macintosh HD (disk1) /  [Startup]: 249.79 GB (73.59 GB free)
               Core Storage: disk0s2 250.14 GB Online
    
    USB Information: ⓘ
       Broadcom Corp. Bluetooth USB Host Controller
       Apple Inc. FaceTime HD Camera (Built-in)
       Seagate  Desktop         
    
    Thunderbolt Information: ⓘ
       Apple Inc. thunderbolt_bus
    
    Gatekeeper: ⓘ
       Mac App Store and identified developers
    
    Adware: ⓘ
       ~/Library/LaunchAgents/com.bittorrent.uTorrent.plist
       One adware file found. [Remove]
    
    System Launch Agents: ⓘ
       [not loaded]    7 Apple tasks
       [loaded]    176 Apple tasks
       [running]    97 Apple tasks
    
    System Launch Daemons: ⓘ
       [not loaded]    41 Apple tasks
       [loaded]    172 Apple tasks
       [running]    101 Apple tasks
    
    Launch Agents: ⓘ
       [running]    com.adobe.AdobeCreativeCloud.plist (2016-10-28) [Support]
       [running]    com.brother.LOGINserver.plist (2016-05-29) [Support]
       [loaded]    com.oracle.java.Java-Updater.plist (2016-05-20) [Support]
    
    Launch Daemons: ⓘ
       [running]    com.adobe.adobeupdatedaemon.plist (2016-10-28) [Support]
       [running]    com.adobe.agsservice.plist (2016-10-23) [Support]
       [loaded]    com.adobe.fpsaud.plist (2016-10-26) [Support]
       [loaded]    com.malwarebytes.HelperTool.plist (2016-11-28) [Support]
       [loaded]    com.microsoft.autoupdate.helpertool.plist (2016-08-03) [Support]
       [loaded]    com.microsoft.office.licensingV2.helper.plist (2015-10-08) [Support]
       [loaded]    com.oracle.java.Helper-Tool.plist (2016-04-01) [Support]
    
    User Launch Agents: ⓘ
       [not loaded]    com.adobe.AAM.Updater-1.0.plist (2016-11-03) [Support]
       [loaded]    com.bittorrent.uTorrent.plist (2016-11-11) Adware!  [Remove]
           /usr/bin/open
       [loaded]    com.google.keystone.agent.plist (2016-08-24) [Support]
       [running]    com.spotify.webhelper.plist (2016-11-29) [Support]
    
    User Login Items: ⓘ
       iTunesHelper    Programma   (2016-11-03)
           (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)
       Safari    Programma   (2016-11-25)
           (/Applications/Safari.app)
       iTunes    Programma   (2016-11-03)
           (/Applications/iTunes.app)
       Mail    Programma   (2016-11-25)
           (/Applications/Mail.app)
    
    Internet Plug-ins: ⓘ
       Silverlight: 5.1.50428.0 – SDK 10.6 (2016-09-10) [Support]
       FlashPlayer-10.6: 23.0.0.207 – SDK 10.9 (2016-11-08) [Support]
       Flash Player: 23.0.0.207 – SDK 10.9 (2016-11-08) [Support]
       QuickTime Plugin: 7.7.3 (2016-11-25)
       JavaAppletPlugin: Java 8 Update 91 build 14 (2016-05-20) Check version
       AdobeAAMDetect: 3.0.0.0 – SDK 10.9 (2016-10-28) [Support]
    
    Safari Extensions: ⓘ
       Open in Internet Explorer – Parallels – http://www.parallels.com (2016-05-29)
    
    3rd Party Preference Panes: ⓘ
       Flash Player (2016-10-26) [Support]
       Java (2016-05-20) [Support]
    
    Time Machine: ⓘ
       Time Machine not configured!
    
    Top Processes by CPU: ⓘ
           22%       com.apple.WebKit.WebContent(5)
           21%       kernel_task
           20%       com.apple.WebKit.Networking(2)
            7%       WindowServer
            6%       Safari
    
    Top Processes by Memory: ⓘ
       1.07 GB       kernel_task
       1.02 GB       com.apple.WebKit.WebContent(5)
       795 MB        iTunes
       360 MB        mdworker(24)
       188 MB        mds_stores
    
    Virtual Memory Information: ⓘ
       2.30 GB       Available RAM
       731 MB        Free RAM
       5.70 GB       Used RAM
       1.59 GB       Cached files
       82 MB         Swap Used
    
    Diagnostics Information: ⓘ
       Nov 30, 2016, 02:21:29 PM    Self test – passed
       Nov 29, 2016, 10:12:57 PM    /Library/Logs/DiagnosticReports/Finder_2016-11-29-221257_[redacted].hang
           /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
       Nov 28, 2016, 03:39:47 PM    ~/Library/Logs/DiagnosticReports/CEPHtmlEngine_2016-11-28-153947_[redacted].crash
           com.adobe.cep.CEPHtmlEngine – /Applications/Adobe Illustrator CC 2017/Adobe Illustrator.app/Contents/MacOS/CEPHtmlEngine/CEPHtmlEngine.app/Contents/MacOS/CEPHtmlEngine
       Nov 28, 2016, 02:37:20 PM    /Library/Logs/DiagnosticReports/Finder_2016-11-28-143720_[redacted].hang
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Looks like you have some adware running there. Go to the folder ~/Library/LaunchAgents/ and dlete that uTorrent launch item. Note this is the Library folder in your personal users folder and not the System Library folder.

    Code:
    Adware: ⓘ
    ~/Library/LaunchAgents/com.bittorrent.uTorrent.plist
    One adware file found. [Remove]
    Otherwise, I'm not seeing anything that would make Finder crash like this. Can you clarify, does the problem still occur when you boot to safe mode?
     
  3. jonahke thread starter macrumors newbie

    jonahke

    Joined:
    Nov 30, 2016
    Location:
    Lier
    #3
    Yes even when I boot in safe mode it happens. I also tried to make a new user account, but even then my Finder and other apps freeze.

    And it all started when I updated my iMac to macOS Sierra. (It is already a lot better than in the beginning, but still..)
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    I think you may have some underlying hardware issue here that just coincidentally manifested with the Sierra install. A safe mode boot runs a completely stripped down system and stops all launch items and startup items, so that cannot be the cause.

    I'd take it in under warranty.
     
  5. stooovie macrumors 6502a

    Joined:
    Nov 21, 2010
    #5
    I had the same problems even with ElCap. Same 5k iMac. Freezing, hanging like 2-5 times a day. Believe it or not, third beta of 10.12.2 solved all of that. Zero problems in 12 days uptime and HEAVY usage (concurrent Adobe suite and VM with Windows 10). I kind of want to stay on the beta this iMac has NEVER been this stable :)

    So no, it doesn't have to be a hardware issue.
     
  6. jonahke thread starter macrumors newbie

    jonahke

    Joined:
    Nov 30, 2016
    Location:
    Lier
    #6
    Sorry apparently I always did the 'safe mode' wrong (stopped holding shift after the Apple-logo appeared) so I did it again, but it is actually hard to tell if the problem appears in safe mode because my Mac is almost unusably slow in this mode. (but this is normal, right?) So I can't do the normal work I do to compare.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Ah... okay. That's better. Yes, it is normal to be slower in safe mode because that shuts off graphics acceleration. So if safe mode fixes the Finder crashes, then it means either a launch or startup item of some kind is causing this. There is no magic way to figure out which one it is. You just have to go through all the items in either System Preferences > Users & Groups > Login items... or any of the following folders and start removing and testing.

    Code:
    ~/Library/LaunchAgents (~ is your users folder)
    /Library/LaunchAgents
    /Library/LaunchDaemons
    /Library/StartupItems
    /System/Library/Extensions/
    What I do is print out the Etrecheck report and use that as a worksheet. Then make a folder on the Desktop and start dragging those items out of the listed folders and into the Desktop folder then restart in regular mode and see if that worked. I usually remove half at a time until I find the offender. Then once you find the culprit you can start adding things back and testing.
     
  8. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #8
    Perhaps create a new user - and play around with that. See if apps behave over time.

    Also, as mentioned above - you should look through your software - Java etc.

    How often is the Parallels extension in use in Safari? Disable for a moment.
     

Share This Page