Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

westislander

macrumors member
Original poster
Aug 17, 2011
68
29
Montreal, Quebec Canada
Hey Guys,

I'm planning to buy the new AirPods 2 very soon. There's a few new features that will be part of this refresh like Hey Siri instead of tapping one of the AirPods to wake Siri up. My concern is whether this and other features will work on 10.13.x.

Apple no longer supports my MacBook Air with new OS updates so I'm stuck on High Sierra until I buy a new Mac.
 

chrfr

macrumors G4
Jul 11, 2009
10,184
3,897
Hey Guys,

I'm planning to buy the new AirPods 2 very soon. There's a few new features that will be part of this refresh like Hey Siri instead of tapping one of the AirPods to wake Siri up. My concern is whether this and other features will work on 10.13.x.

Apple no longer supports my MacBook Air with new OS updates so I'm stuck on High Sierra until I buy a new Mac.
Apple lists that 10.14.4 will be required. Nobody knows at this point if that means you'll get some functionality with older versions of macOS.
 
Comment

zorinlynx

macrumors 603
May 31, 2007
6,279
9,631
Florida, USA
It'll be interesting to find out, over all, if newer iOS versions are required to use them at all, or just to use newer features like "Hey Siri".

It would suck if people using older iPhones like the iPhone 5C wouldn't be able to use these since they are stuck on an older iOS.
 
Comment

westislander

macrumors member
Original poster
Aug 17, 2011
68
29
Montreal, Quebec Canada
In my case, I have the 8 Plus so I won't have any software compatibility issues for the foreseeable future. My only concern is with my Mid 2011 MacBook Air running the latest version of High Sierra.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.