Anyone else a tad confused by the new JB/Unlock?

Discussion in 'Jailbreaks and iOS Hacks' started by E3BK, Nov 28, 2010.

  1. E3BK, Nov 28, 2010
    Last edited: Nov 28, 2010

    E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #1
    ** Update #2 **
    thelatinist has a handy little guide in post #24 on this thread that can help you figure out which steps to take. Please do read my 1st update below as well as the Dev Team post.


    ** UPDATE **

    So after more info has been released and a little more digging/research by me, here's what I've found. Mind you, I'm only researching things that would apply to my 3GS so I apologize if I can not answer your question. Also, if you find that any of my info is wrong (totally possible) please let me know so I can update this.

    Most importantly, you should definitely do research of your own. ie...don't blame me if something happens to your phone. I'm not responsible for that :) Make sure you READ THE WARNING ON THE DEV-TEAM BLOG.

    - The current jailbreak is for iPhone 3G & 3GS on NEWER BOOTROM ONLY (5.14 OR newer) OR IF YOU ARE WILLING UPDATE YOUR BOOTROM TO THE IPAD VERSION. Again...please read the Dev Team warnings before you do this. It's very very important.
    - This is a tethered jailbreak.
    - This will jailbreak and allow you to unlock on FW 4.1 only.
    - iPhone 4 jailbreak is not yet released
    - For those with 3GS on bootrom 5.13 or older, wait for the new "unofficial" PwnageTool so you can preserve your baseband and not have to mess with the iPad stuff.

    From the Dev-Team instructions:
    I hope this is helpful. Again, I just want to help as this is confusing. If you find any of my info is wrong, please let me know.

    ---------------------------------------------------------------------------------------------------------------
    The Dev Team has posted that they have new JB/Unlock tools ready. YAY!! And THANK YOU DEV TEAM! Much thanks, and we are not worthy. We all certainly appreciate all the hard work you put into this and never take a penny for your efforts.

    And now...I'm pretty tech savvy but this is definitely a bit confusing. I've read 3 times and still unsure. Posting here since the dev-team comments section is a bit messy.

    I have a Mac, 3GS, 4.0.1 on BB 5.13.04. It's already JB/Unlocked but I want to upgrade to 4.2.1 so....in order to JB & Unlock I must:

    1) DL the iPad OS - this is what the JB tool will use to create a custom IPSW and rewrite the baseband
    2) update to stock 4.2.1 via iTunes
    3) ** here's where I'm confused **
    Site says: iPhone3GS users with old bootroms who want to go to 4.2.1 should not use this PwnageTool! Update to stock 4.2.1 first, then use the upcoming redsn0w to update your baseband.

    I'm on a mac w/ BR 5.13 - do I use the PwnageTool or wait for Redsn0w?

    3) Unlock w/ Ultrasn0w (currently being updated in Cydia)

    OR do I just use Pwnage to create a custom 4.2.1 IPSW since I have the 5.13 bootrom which is already unlockable w/ Ultasn0w?

    Sorry for the n00b-like post but it is a bit confusing. I just want to make sure I do it right. :/ If someone could confirm the steps for me, I'd greatly appreciate.
     
  2. jjm83 macrumors newbie

    Joined:
    Apr 20, 2010
    #2
    im no noob either and this is confusing the hell out of me.... Im scared to try anything until I know for sure what I'm doing
     
  3. ZenErik macrumors 6502

    Joined:
    Dec 22, 2007
    Location:
    Massachusetts
    #3
    I work in electronics repair, and we do unlocks too. Had today off, but I imagine I will have to learn how to do this real quick tomorrow. :p
     
  4. E3BK thread starter macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #4
    LOL. Ok...at least it isn't just me who is confused. I'm fine on 4.01 but would love to update to 4.2.1. But there are just too many questions right now and I don't want to lose my untethered JB.
     
  5. killmoms, Nov 28, 2010
    Last edited: Nov 28, 2010

    killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #5
    Yeah, I’m only a little confused because I don’t know why I’d need the new redsn0w, since the current one that just came out already jailbreaks old-bootrom 3GSes just fine. I’m guessing it doesn’t have a baseband update functionality? Maybe?

    I still have 05.14.02 on my old-bootrom 3GS on iOS 4.1, but I’d like to upgrade it to 4.2.1 before I sell it. It’s out of warranty already so I guess it doesn’t REALLY matter if I put the iPad baseband on it (and I’m selling it saying “I’m not responsible for any troubles you have beyond when you receive it.”). I’d just like to be sure so that I don’t get some annoyed eBayer on my case.
     
  6. mappyman macrumors regular

    Joined:
    Jul 26, 2008
    Location:
    UK
    #6
    I have baseband 4.26.08 and just want to update to firmware 4.2.1 on my old boot rom 3GS.

    Reading the dev team site does it mean I can no longer keep my 4.26.08 baseband and have to update the baseband? :eek: :confused: :eek:
     
  7. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #7
    Yeah, because apparently there’s a baseband check in 4.2.1? I think I read that? Then again, I’d be surprised if that were the case since you’d think a baseband check would balk at a “newer” 06.whatever baseband from the iPad too.
     
  8. ZenErik macrumors 6502

    Joined:
    Dec 22, 2007
    Location:
    Massachusetts
    #8
    Have you tried to make a custom firmware for 4.2.1 using Snow Breeze? Might work... Might not.
     
  9. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #9
    There is no new jb. It is still tethered for the same devices. The iPad bb is a higher # but is compatiable with the current unlock. So all it does is update your bb to that bb. That's what I got out of it and I think that is what happens.
     
  10. NYR99 macrumors 6502a

    Joined:
    Dec 30, 2007
    #10
    I have a 3Gs with 4.0 and 05.14.02. I just want to be able to finally unlock. This is so confusing!
     
  11. E3BK thread starter macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #11
    OK, MuscleNerd just posted this on Twitter:
    If you have an old-bootrom 3GS with unlockable BB and just want to go to 4.2.1, we'll release an "unofficial" PT bundle

    I'm assuming old bootrom is 5.13 or older. So use the instructions on the Dev Team blog if you are on bootrom 5.14 or newer. If 5.13 or older....wait.

    I think...lol.
     
  12. emac82 macrumors 6502

    Joined:
    Feb 17, 2007
    Location:
    NB, Canada
    #12
    I have a iPhone 3G, 4.1, 05.14.02

    What do I do to jailbreak and then unlock? It is locked to Rogers, but I need it to work on the Bell network...

    HELP ! :)

    I've been waiting weeks to do this and had some help then but now that the time is here I don't want to screw it up..
     
  13. jjm83 macrumors newbie

    Joined:
    Apr 20, 2010
    #13
    I just dont get how to make PT ask you to update the baseband. When I open it up, it just looks like normal PT... do I have to change the name of the ipad firmware file to say iphone instead? Im running Mac OSX 10.6.4
     
  14. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #14
    ya way over my head also! but I think the main point is there is no Untethered JB yet at least for windows users so you need to wait. it is supposed to be out today also. the way I read it is pawnage tool is untethered but not positive :confused:
     
  15. PaulDoFish, Nov 28, 2010
    Last edited: Nov 28, 2010

    PaulDoFish macrumors regular

    Joined:
    Jun 23, 2010
    #15
    I have a 3G on 4.1 with unlocked BB 5.13.04.

    I wanna go to 4.2 keeping my unlock, but I am also confused on whether or not I am safe to do so...

    So if i'm getting this right, the new ultrasn0w still does not unlock BB 5.14/5.15, but it unlocks 6.15. So if I updated to stock 4.2, I would be screwed unless I use pwnagetool to install the 6.15 BB.

    The question is, can I use PT on my 3G to preserve my baseband and update to 4.2? I hear 4.2 has a BB check built in..
     
  16. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #16
    No, it doesn’t matter whether you’re on Windows or Mac, the newer devices (3GS with new bootrom, iPad, and iPhone 4) all have tethered jailbreaks only. Older devices like the iPhone 3GS with the old bootrom and iPhone 3G still have untethered jailbreaks.
     
  17. Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #17
    The baseband check only applies to the iPhone 4.
     
  18. E3BK thread starter macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #18
    No, just wait for the next "unofficial" PwnageTool for those w/ old bootrom.
     
  19. E3BK thread starter macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #19
    No....you need BOTH the iPhone 4.1 FW and the iPad FW. Choose the iPhone FW 1st then it asks you if you are sure you want to update your bootrom, then choose the iPad FW.
     
  20. Zermelo macrumors regular

    Joined:
    Nov 18, 2010
    #20
    For those who are on any unlockable baseband 05.13 or lower BUT want to upgrade to 4.2, the instructions on the Dev-Teams blog are pretty clear:

    Don't do anything yet! They will release for you later. You will probably be sorry if you do. It would be foolish NOT to wait. The instructions are only for those who are on 05.14 or higher with a 3g or 3gs model.
     
  21. michael31986 macrumors 68030

    Joined:
    Jul 11, 2008
  22. Bettz1 macrumors regular

    Joined:
    Jul 4, 2010
    Location:
    Leicester,UK
    #22
    I've been waiting for a unlock for ages since my little sisters updated her 3Gs to 4.1 and 05.14.02 baseband.Its a American iphone we need the unlock once we've jailbroke it i know we loose the warranty but will anybody be able to re sell the phones in say 6 months? will we be stuck on the ipads firmware?
     
  23. jay12 macrumors member

    Joined:
    Nov 5, 2010
    #23
    yeah somehow i had a perfectly working 3gs and got 5.14.02 on it and now it doesn't work.:( Need to get it working bad.
     
  24. thelatinist, Nov 28, 2010
    Last edited: Nov 29, 2010

    thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #24
    Yeah, this is confusing as all hell. I highly recommend anyone who doesn't know exactly what he's doing not do anything until this mess gets sorted. Meanwhile, here's my simple take:

    3G users...

    ...who do not need unlock: Upgrade to official 4.2.1 and jailbreak with Redsn0w.

    ...who need an unlock and...

    ...are on BB 5.13 or earlier: Create a custom 4.2.1 firmware using PwnageTool WITHOUT 6.15 baseband.

    ...are on BB 5.14 or later: Create a custom 4.2.1 firmware using PwnageTool WITH 6.15 baseband from the iPad firmware.​

    Old bootrom 3GS users...


    ...who do not need an unlock: Wait for the update to Redsn0w, then upgrade to official 4.2.1 and jailbreak with Redsn0w.

    ...who need an unlock and...

    ...are on BB 5.13 or earlier: use the unofficial old-bootrom PwnageTool bundle to create a 4.2.1 firmware without baseband upgrade. Because this is a "minimal" bundle designed just to allow upgrade without baseband upgrade, after you restore you will still have to jailbreak your phone using Redsn0w.

    ...are on BB 5.14 or later: Create a custom 4.1 firmware using PwnageTool WITH 6.15 baseband from the iPad firmware. Or wait for Redsn0w and use it to upgrade while upgrading your baseband to 6.15.​

    New Bootrom 3GS users:

    ...who do not need an unlock: Wait for the update to Redsn0w, then upgrade to official 4.2.1 and jailbreak with Redsn0w.

    ...who need an unlock and...

    ...are on BB 5.13 or earlier: do not upgrade at this time.

    ...are on BB 5.14 or later: Wait for the update to Redsn0w, then use it to upgrade to 4.2.1 while upgrading your baseband to 6.15.​

    iPhone 4 users: do not upgrade at this time.

    Note: if anyone has any corrections, particularly regarding the iPhone 4, please let me know and I will correct the above.
     
  25. emac82 macrumors 6502

    Joined:
    Feb 17, 2007
    Location:
    NB, Canada
    #25
    I need an unlock, I just did the first part but with 4.1, do I need 4.2?? I am fine with 4.1....Now how would I proceed to unlock?
     

Share This Page