Anyone else having problems trying to activate iMessage on iOS 7 [Merged]

Discussion in 'iOS 7' started by acctman, Jun 10, 2013.

  1. acctman macrumors 6502a

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #1
    Am i the only one that is having a problem getting iMessage to work? Under settings and messages iMessage just says Waiting for activation...

    so i'm not able to receive imessages for other ios/imsg users just regular sms only.
     
  2. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    #2
    took about 10 minutes, then it finally activated. give it time.
     
  3. acctman thread starter macrumors 6502a

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #3
    its been about 3hrs, but if it'll eventually activate then i can wait. no rush... i'll mess around with xcode in the mean time.
     
  4. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #4
    im having the same problem as you.. is Facetime the same for you too?
     
  5. Patriot24 macrumors 68030

    Patriot24

    Joined:
    Dec 29, 2010
    Location:
    California
  6. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #6
    perhaps its only a problem for verizon iphone 5 users?
     
  7. Patriot24 macrumors 68030

    Patriot24

    Joined:
    Dec 29, 2010
    Location:
    California
    #7
    I am on Verizon, so that isn't the problem.
     
  8. acctman thread starter macrumors 6502a

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #8
    you're on verizon too? i'll give it 24hrs before i start search for solutions
     
  9. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #9
    iMessage activated and worked fine for me right away.
     
  10. KelteN macrumors newbie

    Joined:
    Jan 30, 2009
  11. seanfour20 macrumors newbie

    Joined:
    Jul 1, 2010
    #11
    I'm in the same boat. iMessages are showing up on my Mac just fine, but it won't activate on my phone. Also when I select the "Use your Apple ID for FaceTime" option and enter my password, I get an error telling me it couldn't sign in, and to check network settings. Being on wifi or cellular doesn't make a difference. All other Apple ID services are working just fine. :confused:
     
  12. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #12
    Same problem.
    It also does that in the new "Facetime" app... Or rather, it just tries to load and sits there.

    Anyone else have their Settings app crash when you toggle the on/off button a couple of times on the iMessage button?
     
  13. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #13
    I read somewhere that it could be the fact that Apple's servers are running slow, so yeah, we should give it some time and try again later.
     
  14. N23 macrumors regular

    Joined:
    Aug 3, 2009
    #14
    Hopefully that's the case. My iMessage on my ip5 activates just fine but it's not receiving/sending any imessages.

    My iPad and MBP are still synced just fine.
     
  15. brandonb2124 macrumors newbie

    Joined:
    Jul 24, 2010
    #15
    Same problem here. Can send text messages, but not receiving anything.
     
  16. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #16
    Yep. iP4 here. Can't get iMessage to activate, and if I keep clicking the toggle button it just eventually crashes.
     
  17. Daniel.steel macrumors member

    Joined:
    Jun 4, 2005
    Location:
    York UK
    #17
    Add new DNS entries

    Add 8.8.8.8,8.8.4.4.

    As a DNS entry on your Wi-Fi and it will activate.
     
  18. lw9090 macrumors regular

    Joined:
    Jul 31, 2008
    #18
    Been over 12 hours for me and still not activated.
     
  19. brettv04 macrumors newbie

    Joined:
    Jun 11, 2013
    #19
    Same for me. iMessage won't activate. Sliding the on/off switch does crash the settings app sometimes. iPhone 4S on Verizon
     
  20. brandonb2124 macrumors newbie

    Joined:
    Jul 24, 2010
  21. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #21
    It has to be your devices. iMessage works great for me and countless others.
     
  22. Sirious macrumors 65816

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #22
    I had the same problem. It asked me to top up my account, so I did that. I also restarted my phone afterwards and it took about 3 minutes and it activated.
     
  23. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #23
    OKAY! so after 12 hours of trying to get my iMessage to work.. i decided to restore.. Here's my steps:

    Restored my iPhone (with the beta)..
    Got the "Cannot activate message without a UDID".
    Put in DFU mode..
    Restored back to iOS 6.1.4 (I didn't have a jailbreak so didn't matter much)
    Then UPDATED (not restore) back to iOS7 beta 1.

    I think a key point is that when you restore back to 6.1.4, DO NOT RESTORE FROM A BACKUP. Set up as a new iPhone, and as soon as you can, update back to iOS 7.

    My iMessage and Facetime are both activated now :D
     
  24. mac00l macrumors 6502

    Joined:
    May 3, 2011
    #24
    That!!

    Installed iOS 7 from a Factory restore, and everything is working fine.
     
  25. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #25
    the only downside is that all my apps have to install again.... haha, hopefully all their history are saved over icloud..
     

Share This Page