Apple Maps Doesn't Load

Discussion in 'Apple Watch' started by PhantomCypher, May 22, 2015.

  1. PhantomCypher macrumors member

    Joined:
    May 21, 2015
    #1
    Apple Maps refuses to load the maps when I open the app. It shows small tiles, big tiles - no matter what I do I can't get it to load. I re-paired the watch, rebooted it, everything.

    Running latest iOS on my 6+ paired with my new SS 42mm Milanese. Data for all other Watch apps work fine.


    I have a support case with Apple Support open so we'll see what they say in the next 24 hours...

    Anyone else having this problem?
     
  2. iamasmith macrumors regular

    iamasmith

    Joined:
    Apr 10, 2015
    Location:
    Cheshire, UK
    #2
    Had that exact same problem on 1.0 when I first got the watch.. then it worked and it worked ever since, quite bizarre really :p
     
  3. PhantomCypher thread starter macrumors member

    Joined:
    May 21, 2015
    #3
    Did you update to 1.01 or it started working on 1.0?
     
  4. iamasmith macrumors regular

    iamasmith

    Joined:
    Apr 10, 2015
    Location:
    Cheshire, UK
    #4
    It started working about day 3 on 1.0 for some reason (about 3 weeks ago IIRC) and showed no problems since.

    I thought I'd have to wait for them to iron out the bugs.
     
  5. Subdiv macrumors 6502

    Joined:
    Jan 17, 2014
    Location:
    Colorado
    #5
    My watch on 1.0 worked at first, then did as you are describing one day, then started working again the next day. Go figure...
     
  6. skaclown macrumors member

    Joined:
    Feb 2, 2008
    #6
    Mine did the same thing on day 1, after loading the maps app on iPhone and rebooting the watch it started working...
     
  7. PhantomCypher thread starter macrumors member

    Joined:
    May 21, 2015
    #7
    So perhaps it is updating the application or syncing with the phone overnight?

    You would think Maps would work out of the box considering how major a part of the experience it is.
     
  8. BSben macrumors 6502a

    Joined:
    May 16, 2012
    Location:
    UK
    #8
    Aren't you the one expecting an 18K Edition Watch?
     
  9. PhantomCypher thread starter macrumors member

    Joined:
    May 21, 2015
    #9
    SS is the casual everyday watch to bang around and 18K is the real jewelry. It's like when you use your Green Amex out and about but your Black for the shopping sprees.
     
  10. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #10
    Can you pair two Apple Watches to one iPhone?
     
  11. CobraPA macrumors 6502a

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #11
    No, have to unpair and then pair the second one.
     
  12. VPrime macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
    #12
    I just got my watch, and mine is doing the same thing :(.
    I updated to 1.0.1 and it still isn't working.
     
  13. PhantomCypher thread starter macrumors member

    Joined:
    May 21, 2015
    #13
    We should all report to this Apple as an ongoing bug so they can really look into it. Tier 2 support said they've never gotten a complaint about this yet...
     
  14. lifeguard macrumors 6502

    lifeguard

    Joined:
    Nov 25, 2010
    #14
    Spent 4 hours on with Apple support (off and on trouble shooting) Turns out they know about it and there is going to be an additional update within the next few days. 1.0.1 did not fix it for everyone and "supposedly" there is fix on its way
     
  15. mik63 macrumors newbie

    Joined:
    May 22, 2015
    #15
    Maps in Watch

    Same problem here.
    Not loading the map on the 1.0 and on the 1.0.1 update.
    if I try to ask for directions it works but without showing the map itself.
     
  16. loon3y macrumors 65816

    loon3y

    Joined:
    Oct 21, 2011
    #16
    It still isn't loading I let a friend use it and pair it with his and now I paired it with mine it still doesn't load anymore



    I nearly did everything
     
  17. thewhitetower macrumors member

    thewhitetower

    Joined:
    Jun 25, 2011
    #17
    Same issue here...grid only shows with blue dot!

    Wife's 38mm SS works perfectly...both watches on iOS 1.0.1
     
  18. KitzelFox macrumors newbie

    Joined:
    Jun 22, 2012
    #18
    Same here... I had to get a replacement watch today due to dead pixels on the screen, and the replacement seems fine but the maps simply will not load! I have tried everything I can possibly think of, from setting it up new, to resetting both the iPhone and Watch... nothing seems to work. It worked fine on my old watch, so I don't know if it's the watch or a software bug. But considering everything else works so far, I am going to assume software bug.
     
  19. Cobalt Thunder macrumors newbie

    Joined:
    May 19, 2015
    #19
    Same here!
    Isn't loading maps data. The same on 1.0 and still the same on 1.0.1.
    Tried hard resetting for both and still nothing.
     
  20. PhantomCypher thread starter macrumors member

    Joined:
    May 21, 2015
    #20
    I really wanted to use this as my daily navigation tool but it looks like everyone else is having the same problem.
     
  21. KitzelFox, May 22, 2015
    Last edited: May 22, 2015

    KitzelFox macrumors newbie

    Joined:
    Jun 22, 2012
    #21
    I wonder if it could possibly be that the map data from Apple's servers is down or not currently pushing out the information at this time? It is odd that so many people are experiencing the issue all of a sudden, and maybe even a lot of other people too who just aren't currently using the maps app in order to find out.

    I was able to put in an address and have it give me directions, so the directions/GPS are working fine... There simply isn't any map to show me where I'm going. Just a grid.
     
  22. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #22
    Mine has been working fine both before and after the update.
     
  23. DDustiNN macrumors 65816

    DDustiNN

    Joined:
    Jan 27, 2011
    #23
    Same issue here. I just got mine today and it will absolutely not show any map data whatsoever. GPS location works fine (for Weather, etc), but just no map data.
     
  24. Deekity macrumors newbie

    Joined:
    May 12, 2015
    #24
    Same here. Got it today. Maps won't load. Awaiting fix
     
  25. OBirder macrumors member

    Joined:
    May 13, 2015
    #25
    As you might remember: Same watch, as well delivery today, no map. Update to 1.01 and hard resets didn't help. No map data.
     

Share This Page