Apple Releases 5.0.2 Update for 2nd and 3rd Generation Apple TV

MacRumors

macrumors bot
Original poster
Apr 12, 2001
47,630
9,402



Apple has released Apple TV Software Update 5.0.2 for 2nd and 3rd generation Apple TV models. The release has build number 9B830. Apple has yet to update the Apple TV Software Update webpage with details about the update.

The Apple TV can be updated directly on the unit by going to the Settings menu, then General, then selecting Update Software.

The last Apple TV update was released less than a month ago.

Update: Apple has updated its support document to indicate that the 5.0.2 update addresses a single issue related to parental controls.
Parental Controls: Addresses an issue which caused content restrictions to be incorrectly applied for the iTunes Store in Australia.
Article Link: Apple Releases 5.0.2 Update for 2nd and 3rd Generation Apple TV
 

RoboCop001

macrumors 65816
Oct 4, 2005
1,400
198
Toronto, Canada
The number 2 is like a backwards, misshapen S.

And Siri begins with the letter S..................

Wait.....


I can do this.... That means.... That means this update brings Siri!! :D:D
 
Comment

Bevz

macrumors 6502a
Oct 23, 2007
816
137
UK
Have updated but can't see any difference at all... Only minor version bump so I guess no new features...
 
Comment

SandboxGeneral

Moderator emeritus
Sep 8, 2010
25,882
8,983
Detroit
I hope this fixes the badge notifications on podcasts that always read new podcasts and never go away after having watched them. :mad:
 
Comment

jhende7

macrumors regular
May 19, 2010
145
23
I really hope this fixes the language bug with Netflix. Half the good movies only play in French....

Edit: boom fixed it! That's at least one change in the update!
 
Last edited:
Comment

blacktape242

macrumors 68000
Dec 17, 2010
1,669
2,227
Sacramento, CA
Please check your cables and wireless network. It's unlikely a problem with Apple TV since so many of us have the perfect experience using them day and night in our home theatre setups.

I've done that countless times. my internet is 18mpbs so i know thats not the problem, I've reset the modem, router, atv. The ONLY thing I can think of is that my hdmi cable isn't good enough? thoughts?
 
Comment

Gubbz

macrumors member
May 2, 2010
55
19
Perth, Australia
I've done that countless times. my internet is 18mpbs so i know thats not the problem, I've reset the modem, router, atv. The ONLY thing I can think of is that my hdmi cable isn't good enough? thoughts?
I know your problem, I have a similar with my downstairs TV and it's the TV... Power off the TV, unplug the HDMI from the TV for a few mins, plug back in and switch the TV back on and the sound is back... I don't have it as frequently as you, mine can be fine fore a month, but it's been an issue with my old Apple TV and my Apple TV 2. Really screwed with my head the first couple of times.
 
Comment

monaarts

macrumors 65816
Jan 16, 2010
1,164
50
Kennesaw, GA
I've done that countless times. my internet is 18mpbs so i know thats not the problem, I've reset the modem, router, atv. The ONLY thing I can think of is that my hdmi cable isn't good enough? thoughts?
That shouldn't do it. Id think it was either too much bandwidth on your router (do you have 3 other apple tvs also streaming at the same time), or your wireless router has some interference (try changing it to another channel).
 
Comment

blacktape242

macrumors 68000
Dec 17, 2010
1,669
2,227
Sacramento, CA
That shouldn't do it. Id think it was either too much bandwidth on your router (do you have 3 other apple tvs also streaming at the same time), or your wireless router has some interference (try changing it to another channel).
well i reset the modem, and NOW it seems to be working, its been about 10 mins and no break in signal. Weird, cause i have done this so many times, maybe doing this AFTER the update fixed it?! my fingers are crossed! :D
 
Comment

unobtainium

macrumors 68020
Mar 27, 2011
2,343
3,248
Turn off home sharing in iTunes, restore your Apple TV and set it up as new, then enable home sharing again. If that doesn't fix it, swap the Apple TV if it's still under warranty. You could also try resetting your router.
 
Comment

blacktape242

macrumors 68000
Dec 17, 2010
1,669
2,227
Sacramento, CA
That shouldn't do it. Id think it was either too much bandwidth on your router (do you have 3 other apple tvs also streaming at the same time), or your wireless router has some interference (try changing it to another channel).
my current set up IS, modem plugged into my apple extreme, then i have the avt plugged directly into the apple extreme. well crap! I JUST lost sound again, but it came back on with in 10 seconds. This is driving me nuts.. :\

----------

Turn off home sharing in iTunes, restore your Apple TV and set it up as new, then enable home sharing again. If that doesn't fix it, swap the Apple TV if it's still under warranty. You could also try resetting your router.
i don't have home sharing on.
 
Comment

SandboxGeneral

Moderator emeritus
Sep 8, 2010
25,882
8,983
Detroit
I hope this fixes the badge notifications on podcasts that always read new podcasts and never go away after having watched them. :mad:
Nope. :mad: just updated my ATV3 and still have the same podcast issue. I watched all of these Apple Byte episodes and watched the latest one again after the update and still shows unwatched.

 
Comment

Laird Knox

macrumors 68000
Jun 18, 2010
1,773
937
I've done that countless times. my internet is 18mpbs so i know thats not the problem, I've reset the modem, router, atv. The ONLY thing I can think of is that my hdmi cable isn't good enough? thoughts?
It is possible that it is some weird HDCP or data issue. When all else fails it doesn't hurt to try the cable, wouldn't be the first time.

Between your modem and the ATV is there any wireless or is it all wired? I used to have a lot of trouble with my connection until I switched to the 5GHz band. There was just too much noise at the older frequencies.

If all else fails turn on closed captioning. :D
 
Comment

donlab

macrumors 6502
Jun 3, 2004
292
82
USA
I've done that countless times. my internet is 18mpbs so i know thats not the problem, I've reset the modem, router, atv. The ONLY thing I can think of is that my hdmi cable isn't good enough? thoughts?
That IS the problem. 18mpbs / 8 = 2.25 MB / s and that's probably at burst speed. What is your sustained speed when downloading an update from crapple?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.