MacRumors

macrumors bot
Original poster
Apr 12, 2001
53,445
15,173



Apple has released AirPort Base Station and Time Capsule Firmware Update 7.6.4.

The update is available for all Apple 802.11n Wi-Fi base stations including AirPort Express, AirPort Extreme, and AirPort Time Capsule.
airportupdate.png
AirPort Base Station Firmware Update 7.6.4

- Resolve an issue that may cause AirPort Time Capsule to report that the backup disk is in use
- Resolve an issue that may cause an IPv6 Tunnel error
- Resolve an issue that may intermittently cause a loss in Wi-Fi connectivity with iOS devices

Note: This firmware update is for all 802.11n AirPort base stations.
Thanks Radioactive!

Article Link: Apple Releases AirPort Base Station and Time Capsule Firmware Update 7.6.4
 

kenzbud

macrumors member
Oct 21, 2005
78
0
- Resolve an issue that may intermittently cause a loss in Wi-Fi connectivity with iOS devices

My iOS devices would intermittently drop Wi-Fi connections at random times. Didn't really think about it until I read that. It would do it a few times a month.
 

maestrokev

macrumors 6502a
Apr 23, 2007
875
8
Canada
Apple devices are now reporting excellent signal strength. Non-Apple devices like my WDTV are now reporting poorer to no signal strength!
 
  • Like
Reactions: ckeilah

3282868

macrumors 603
Jan 8, 2009
5,281
0
Just got it. Good support for 5th Gen model w/ new 6th gen router (no ac devices yet but definitely improved N devices). Now bring back OS X Airport app 5.6 features.

Originally Posted by sharbeen
Usually I dont get "Excellent" signal with my device in the next room. It's ALWAYS GOOD. never went to EXCELLENT. but with 7.6.4 it shows "EXCELLENT".

Spot on here. Have 2 Extremes: 6th Gen in media room (main), 5th Gen on second floor (bridge). 2.4GHz channel 6, 5GHz channel 161. Haven't had WLAN speeds this fast/reliable ever. Got a lot on my network (not bragging, just listing as routers are handling it perfectly):

6Th Gen w/ Cat 6 connections (TW modem/router in bridge mode for extra RJ-45's):
  • Synology DS211 Media Server
  • Mac Mini HTPC
  • Samsung BD
  • Pioneer Elite VSX-33

~14 Wireless Devices

5th Gen Airport Extreme 2nd floor w/ Cat 6:
  • Current Gen Mac Pro5,1 second floor, connected via cat 6 primary, wireless for AirDrop
  • Philips Hue
  • Synology DS212j Media Server
 
Last edited:

koen

macrumors member
Jul 17, 2003
77
2
Hmm, I keep getting a download error (-6721) for my Airport Express (1st gen). Probably will try it again later.

Good news on the iOS connectivity loss fix.


Edit: fixed it after resetting my AE to the factory settings.
 
Last edited:

sharbeen

macrumors member
Aug 13, 2013
48
9
United Arab Emirates
Apple devices are now reporting excellent signal strength. Non-Apple devices like my WDTV are now reporting poorer to no signal strength!

I dont know about WDTV. but I've currently 5 devices connected. Macbook, iPhone 5, Galaxy S4, HTC one and iPad. All of these are now showing brilliant strenght. Maybe something to do with the WiFi module equipped in WDTV that doesn't work well with Airport.
 

Tankmaze

macrumors 68000
Mar 7, 2012
1,689
326
meh, knowing the problem with 7.6.3 in apple forums, i'm glad I stayed in 7.6.1
will look on feedback on this new firmware before I upgrade.
 

dpace32

macrumors regular
Aug 24, 2008
222
29
This update is also available for the latest gen AirPort Express base stations (not completely clear by the article).

Note: Still having issues streaming to my Chromecast from any computer in the house... I think the AirPort is making causing these issues...
 

autumnsong

macrumors member
Oct 26, 2007
93
0
Western North Carolina
Didn't fix my problem

I've been having problems with my Airport Express disappearing from my network on and off all day. After the update, it worked for about an hour, then dropped out again :(
 

sharbeen

macrumors member
Aug 13, 2013
48
9
United Arab Emirates
I've been having problems with my Airport Express disappearing from my network on and off all day. After the update, it worked for about an hour, then dropped out again :(

This doesn't sound like a firmware issue but a hardware fault. Get it replaced. But just to make sure try trouble shooting with the following options

1. Try changing the channels for both 5Ghz and 2.4Ghz and see if that helps.
2. Did you check with other devices (if you own only 1 device i.e.)
 

maestrokev

macrumors 6502a
Apr 23, 2007
875
8
Canada
I dont know about WDTV. but I've currently 5 devices connected. Macbook, iPhone 5, Galaxy S4, HTC one and iPad. All of these are now showing brilliant strenght. Maybe something to do with the WiFi module equipped in WDTV that doesn't work well with Airport.

The same WDTV worked fine with the same Time Capsule running under previous firmware, pretty sure it is 7.6.4 that is causing a problem. Wouldn't be the first time new AirPort firmware did that.
 

sharbeen

macrumors member
Aug 13, 2013
48
9
United Arab Emirates
The same WDTV worked fine with the same Time Capsule running under previous firmware, pretty sure it is 7.6.4 that is causing a problem. Wouldn't be the first time new AirPort firmware did that.

Well what I meant was maybe WDTV isn't able to handle the NEW way of how airport deals with wifi.

----------

My Extreme seems to think it's running 7.7.1.

7.6.4 is for 802.11n devices. You own a 802.11ac device. So nothing to worry about :)
 

jthompson666

macrumors member
Aug 20, 2011
79
73
I have the 802.11ac AirPort Time Capsule with two latest generation AirPort Express' connected via Cat6 / 500Mbs HomePlug. Can anyone tell me if there are any marked improvements especially with iPads? My sister cannot get proper reception from either the Time Capsule or the Express and her room is less than 15M from both of them.

Never mind about the Time Capsule - Apparently this update isn't for ac devices! But any improvements on the Express - let me know :)
 

aplnub

macrumors regular
Nov 16, 2008
156
168
Hmm, I keep getting a download error (-6721) for my Airport Express (1st gen). Probably will try it again later.

Good news on the iOS connectivity loss fix.


Edit: fixed it after resetting my AE to the factory settings.

Same error here with the error when trying to install.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.