AppleTV only showing "Settings" and "Computers"

Discussion in 'Apple TV and Home Theater' started by bug, Mar 31, 2012.

  1. bug macrumors regular

    Joined:
    Feb 2, 2004
    Location:
    Vancouver, BC
    #1
    All of a sudden last night the interface on my AppleTV blinked for a second and then all my menu options were gone except for "settings" and "computer".

    I reset it, unplugged the cables, changed from wifi to ethernet and back, etc. The network test runs fine.

    The only thing that would fix it was doing a full restore - then everything came back but as soon as I turned on iTunes match it all disappeared again.

    I'm doing another restore now in the hopes I can get the other options back again, and I'll avoid turning on iTunes match until the next software update but its annoying.

    Anyone else having this issue or have any advice? I kind of wish I had just stayed on the last major version of the AppleTV software - I don't even like the new interface and it used to always work solidly. If I could roll back to a previous version I would happily do so.
     
  2. mlibrescu macrumors newbie

    mlibrescu

    Joined:
    Jul 30, 2008
    Location:
    California
    #2
    Common Problem

    This has happened to me twice since I purchased the Apple TV 3 (never happened with ATV2). The first time, I had to do a reset. The second time is right now and I'm trying that again. I tried restarting, physically implugging the device from the wall, rebooting my modem and router, nothing works.

    You can Google the problem to see that it is fairly common. :mad:
     
  3. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #3
    This has occurred with my ATV2. Usually it is a crash caused by Netflix in my experience. Usually it recovers on its own.
     
  4. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #4
    This just happened to me today. I restarted it and it fixed itself. Annoying though, especially since I plan on giving this to my dad next time I see him. He'd have no idea how to fix it.
     
  5. agrumke macrumors newbie

    Joined:
    Aug 22, 2012
    #5
    similar to common problem.

    This also happened to me. I moved to college and purchased an Airport Express. The router works and is set up (all devices connect to the internet). I turn on the Apple TV and it has only the Computers and settings. Even after connecting via ethernet and/or wifi i have the same problem. The problem persists after resets and a restore (while being plugged into iTunes). I cannot sign into the itunes store bc it says it is unavailable...which is the same reason I can't do a network test. The network works on all my other devices so i cannot understand what would be the problem. My router did have to be set to bridge mode because of DCHP and NAT? Anyways any help would be appreciated as this is frustrating.
     
  6. Aragornii macrumors 6502

    Joined:
    Jun 25, 2010
    #6
    I think what that means is when you see it your ATV has lost it's internet connection (if you check your setting you probably have a self-assigned IP). Rebooting your ATV or you router will probably fixit, or plugging in an ethernet cable.
     
  7. Spacecowboy1 macrumors member

    Joined:
    Jun 11, 2012
  8. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #8
    Jailbroken has nothing to do with it, the aTV pulls it's menus from the web. It's how hulu showed up one morning without doing a software upgrade. if it can't access the web, it can't get it's menus.
     
  9. boomhower macrumors 68000

    boomhower

    Joined:
    Oct 21, 2011
    #9
    That was my issue as well. Got it all the time when I used the ethernet port. Once I just said screw it and went wireless it's worked fine.
     
  10. Spacecowboy1 macrumors member

    Joined:
    Jun 11, 2012
    #10
    i wasn't saying the jailbreak had anything to do with it. I was just trying to help with the forum by adding what i've seen.

    ps...i also dont have hulu(uk)
     
  11. iBreatheApple macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #11
    My AirPlay crashes it once a week or so. And it goes out but when the screen comes back on my media is still playing but it's as if nothing is connected because it doesn't even have "now playing", it just says turn home sharing on even though it is outputting my music.
     
  12. Andrew*Debbie macrumors member

    Joined:
    Nov 6, 2010
    Location:
    North Wales, United Kingdom
    #12
    Ours does exactly that when it doesn't have a full internet connection.

    We use T-Mobile 3G for our home internet. After we've used up our month bandwith, T-Mobile restricts our connection to "Browse and e-mail" When that happens the ATV 2 only shows settings and computer.
     
  13. jtrenthacker macrumors regular

    Joined:
    Apr 12, 2012
    #13
    I just diconnect the power cord for a few seconds and plug it back in. Fixed.
     
  14. darcyjames macrumors member

    darcyjames

    Joined:
    Sep 21, 2012
    #14
    WTF, I always pay premium to buy 3d bluray combo packs with iTunes Digital Copy and now its seems UV is gaining traction! How? It is junk, I watched crappy downloads on my Pentium laptop decades ago and now I want, no, scratch that, NEED my 1080p ATV convenience.

    I liked watching it initially with the DTS Master HD audio (that destroys regular dolby digital) but now I'm being forced to choose...why??

    Ahh, that feels better, now I'm going to buy Amazing Spiderman in 1080p through iTunes; no DTS Master HD but $10 cheaper than the combo packs I became accustomed to buying. Scr*w you big six and your UV too! :)
     
  15. Jeffryyyy macrumors newbie

    Jeffryyyy

    Joined:
    Sep 9, 2015
    #15
    Ive fixed this problem twice by reverting my DNS Settings from Manual to Automatic
     
  16. jim f macrumors newbie

    Joined:
    Jun 21, 2016
    #16
    --- Post Merged, Jun 21, 2016 ---
    I tried restarting and resetting the Apple TV and did not work. I rebooted my router by unplugging it for 30 seconds and that solved the issue
     
  17. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #17
    - Software restart had no effect
    - changing my region settings worked for a little bit and then it reverted
    - Power cable restart no luck
    - router reset no luck

    Going to reset the whole box now..
     
  18. ganjaology macrumors newbie

    ganjaology

    Joined:
    Aug 4, 2011
    Location:
    Mendocino
    #18
    I too just had this issue. October 31/November 01 2016
    All I see is a computer and settings option. In the settings option I have access to everything except the main menu setting. There's absolutely nothing in there as an option. I've restarted my Apple TV as well as my AirPort Extreme. I've reset the Apple TV and I inserted all the info back in like my iCloud acct etc. it obviously is logging onto the Internet since I was able to connect my iCloud account. One other strange thing is that my iTunes won't recognize the Apple TV when I plug it in directly to my Mac mini via a USB cable. It just doesn't show up. What the heck happened? Apple do you have an explanation for this one?
     
  19. Krispies13 macrumors newbie

    Krispies13

    Joined:
    Nov 2, 2016
    #19
    I thought I was alone.. just happened to me today as well... been looking for a fix all night .. smh
     
  20. Gabbisonn macrumors newbie

    Gabbisonn

    Joined:
    Nov 2, 2016
    Location:
    Las Vegas
    #20
    THIS LITERALLY JUST HAPPENED TO ME.

    It kicked me off of Netflix randomly and now everything is missing except for Music, Computers, and Settings. I've restarted it several times, restarted my router, and I even restored my Apple TV. Still nothing. Is this just some sort of glitch with apple? Or am I missing something here?



     

    Attached Files:

  21. annawalks macrumors newbie

    Joined:
    Nov 2, 2016
    #21
    --- Post Merged, Nov 2, 2016 ---
    Go into settings, iTunes Store, Location, and change your location to Namibia. Back out of settings, go back in and change it back to US. It will restore all the apps.
     
  22. CassiusR macrumors newbie

    CassiusR

    Joined:
    Nov 2, 2016
    #22
    Just happened to me yesterday as well! HAS to be some kinda bug!
     
  23. annawalks macrumors newbie

    Joined:
    Nov 2, 2016
    #23
    From what I can tell it's common and is caused by the Netflix app.
     
  24. CassiusR macrumors newbie

    CassiusR

    Joined:
    Nov 2, 2016
    #24
    Worked partially. Some of my apps like ESPN are still missing. I literally have half the menu I normally do. #ATV3
     
  25. Adeclaire macrumors newbie

    Adeclaire

    Joined:
    Nov 2, 2016
    #25
    This happened to us yesterday, I tried the change of location thing but only a few (lame) apps came back up and Netflix. Hulu and hbo go won't show up. When I did a reset all the apps disappeared again and it went back to the screen with computer and settings as the only option. Is this because of an update?
     

Share This Page