Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

ravioli

macrumors newbie
Original poster
Nov 16, 2017
4
0
Hi there

So I got this problem with the Language of my AppStore on my iPhone 5s (iOS 11.1.1).

My iPhone Language is set to German (Switzerland). But my AppStore shows everything in english. Even the Apps I download are in english.

The Country/Region of the AppStore is Switzerland, but still it doesnt work.. On my Macbook the Language in the AppStore is German.

Thank you very much for any help!
 

friednoodles

Suspended
Feb 4, 2014
601
829
Have you changed your phone's language recently? For example, have you changed the language to English temporarily and also logged out of and in to iCloud or the App Store? If so, try restarting your phone.
 
Comment

ravioli

macrumors newbie
Original poster
Nov 16, 2017
4
0
No, I never changed the Language of the iPhone.
I logged out of and in to iCloud and the AppStore. I restarted the iPhone and also updated to iOS 11.1.1 (it is since iOS 10 i think)
 
Comment

friednoodles

Suspended
Feb 4, 2014
601
829
So there's a quirk here that can cause the language of your apps to not match the device's current language and it has to do with store location and Apple ID. The next steps in troubleshooting this are:

Terminal all open apps by swiping them away from the app switcher
Go to Settings
Go to iTunes & App Stores
Tap on your Apple ID at the top
Select View Apple ID and enter your password or provide Touch ID/Face ID authentication

At this point you may be prompted that the language doesn't match your location and you'll be taken into the App Store and then hopefully it should display in the correct language. If it does, at this point a restart should also result in the apps now being in the correct language as well.
 
Comment

ravioli

macrumors newbie
Original poster
Nov 16, 2017
4
0
So there's a quirk here that can cause the language of your apps to not match the device's current language and it has to do with store location and Apple ID. The next steps in troubleshooting this are:

Terminal all open apps by swiping them away from the app switcher
Go to Settings
Go to iTunes & App Stores
Tap on your Apple ID at the top
Select View Apple ID and enter your password or provide Touch ID/Face ID authentication

At this point you may be prompted that the language doesn't match your location and you'll be taken into the App Store and then hopefully it should display in the correct language. If it does, at this point a restart should also result in the apps now being in the correct language as well.
Hi and thank you!

But unfortunatelly it didnt work..

As soon as I press „View Apple ID“ in Settings/iTunes & App Store it changes to english. The Settings before are in german.

There I can change the Region etc. (Whole Menu is english) So i changed it once again to Switzerland, fill out my Adress and CreditCard Informations, but nothing changes after saving it.. still english AppStore.
 
Comment

friednoodles

Suspended
Feb 4, 2014
601
829
Next steps:

Go to Settings
Go to General
Go to Language & Region
Under Preferred Language Order, if you have more than one language, ensure that German (Switzerland) is at the top of the list. If it isn't, tap Edit in the top right corner and then move German (Switzerland) to the top of that list, then tap Done
 
Comment

ravioli

macrumors newbie
Original poster
Nov 16, 2017
4
0
Next steps:

Go to Settings
Go to General
Go to Language & Region
Under Preferred Language Order, if you have more than one language, ensure that German (Switzerland) is at the top of the list. If it isn't, tap Edit in the top right corner and then move German (Switzerland) to the top of that list, then tap Done

Still not working.. I show you some Pictures.
 

Attachments

  • BE9C9720-016D-4EC4-BC27-B74AA59BCC18.png
    BE9C9720-016D-4EC4-BC27-B74AA59BCC18.png
    81.4 KB · Views: 328
  • 47F739F4-9126-4AAC-9840-5E202181386D.jpeg
    47F739F4-9126-4AAC-9840-5E202181386D.jpeg
    106.4 KB · Views: 371
  • CF0A7FEF-85A4-4D83-8D08-1654272EAA21.png
    CF0A7FEF-85A4-4D83-8D08-1654272EAA21.png
    529.9 KB · Views: 322
  • D92690A2-E60B-4540-84AE-BD65FE3CAA9E.jpeg
    D92690A2-E60B-4540-84AE-BD65FE3CAA9E.jpeg
    92.6 KB · Views: 360
  • 2E1F43E7-A8F2-4928-BA79-A4ABA26E172E.png
    2E1F43E7-A8F2-4928-BA79-A4ABA26E172E.png
    79.5 KB · Views: 284
Comment

friednoodles

Suspended
Feb 4, 2014
601
829
The last suggestion I have that I've seen fix this issue is logging out of and back into the App Store in Settings - iTunes & App Stores, but it sounds like you've already tried that.

You're probably going to need to contact Apple Support (they have a good, free online chat system), because it's too hard to know the specific combination of accounts/region settings/store locales that are causing the problem.

The issue is related to logging in and out of iCloud/Apple IDs though, and it's not an iOS 11 issue (it happens in all versions of iOS - just Google for "app store language wrong" to see a lot of instances of the same issue). I most recently saw this with Japanese and English, where temporarily changing the system language to Japanese and logging in and out of iCloud resulted in the Japanese language sticking around in the App Store and in apps even once the system language had been set back to English (the solution was the aforementioned re-auth with the Apple ID to get the store language to update, then restarting).

I've also seen one person experience this on Twitter and they did an @AppleSupport who solved the problem for them quite quickly, so that's another option if you have Twitter, otherwise chat with Apple via https://getsupport.apple.com/ - choose your country/region, then select "iPhone", then "iOS & Applications", then "The topic is not listed", enter a summary like "App Store and app language does not match system language", then click "Continue" and choose whether you want to chat online or have them call you.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.