ATV3 is driving me insane with random disconnects

Discussion in 'Apple TV and Home Theater' started by shenan1982, Dec 21, 2014.

  1. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #1
    So I've had my Apple TV 3 for a while... it's now driving me nuts. When it was on iOS 7, it was flawless.

    Now that it's been on iOS 8, it's awful. Frequently it doesn't see any content shared from computers on the network. Frequently in the middle of a show it'll just stop playing and drop out to the menu. Frequently when I go into my library it'll just give me the spinning loading indication and never do anything.

    I've restored it and set it up as new without success in resolving the issues. I've tried moving it from the wireless to the wired network... it's just complete garbage ever since the 8.x update. I've read many people seem to be in the same boat, but as a pet project, Apple doesn't seem to interested in solving the problems.

    Not sure what to do at this point. Has anyone else been able to solve the issues?
     
  2. a1b2c3 macrumors newbie

    Joined:
    Dec 25, 2014
    #2
    Very strange as I don't have any issues at all, as I suspect most don't. The only other thing I can think of is uninstall iTunes, and reinstall and then add your content again. See if that helps. Also make sure you are using the newest iTunes. If you are then use a older version of iTunes. Sounds like to me that's where the issue is.
     
  3. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #3
    Most don't, MANY do. You're taking an issue and saying because it only affects say 5% of users, it's MY issue. That's an issue that a company takes that infuriates its users.

    The fact of the matter is it's not iTunes, and it's not the content. Of course I'm using the latest iTunes on all of the computers connected.

    I'm happy it works for you.
     
  4. bt22 macrumors 6502

    Joined:
    Feb 15, 2009
    Location:
    Alabama
    #4
    I'm having very similar connection issues with my Apple TV 3rd Gen and current software. I was playing Christmas Music yesterday and stopped for a little while. Then it took 30 minutes to get it to connect to my library again. I wanted to snatch it out of my cabinet. Apple's software is a mess right now.
     
  5. a1b2c3 macrumors newbie

    Joined:
    Dec 25, 2014
    #5
    There may be nothing wrong with iTunes as far as standalone but obviously the newest Apple TV software is having a hard time communicating with it. Try the last older version of iTunes and see if that helps. The newest Apple TV iOS may work better for you with an older version, especially if your connections and everything are solid. Just trying to help, never rule anything out until you have tried it. I think the newest iTunes still needs some tweaking as far as the being used with the latest AppleTV iOS. I know Roku ran into this issue with there latest firmware update not working very well for some people with the current PMS at the time. An update to PMS fixed the issue. PMS is essentially iTunes for the Roku.

    Best of luck!
     
  6. pheenix11, Dec 28, 2014
    Last edited: Dec 28, 2014

    pheenix11 macrumors regular

    Joined:
    Jul 13, 2010
    #6
    My ATV3 has been driving me up a wall lately. I was trying to play a movie from my iTunes library tonight and we could only get halfway through it with all the stops and constant buffering.
     
  7. Hustler macrumors 6502

    Hustler

    Joined:
    May 31, 2010
    #7
    Mine disconnects all the time as well. It's terrible.
     
  8. u49aa2 macrumors 6502a

    u49aa2

    Joined:
    Nov 3, 2008
    Location:
    Between Heaven and Hell
    #8
    i had an ATV 2 and had similar issues (exactly what you are describing), sold it and bought a Roku stick and downloaded the Plex server (synced with my iTunes library) and can't be any happier..not a single disconnection.
     
  9. kevo1011 macrumors regular

    Joined:
    Oct 3, 2010
    #9
    +1

    Add me to the list. 1 ATV3 wired & 1 ATV3 wireless. Home sharing has been almost impossible. I am constantly turning it off and back on again. I recently built a scheduled task that ends iTunes and restarts iTunes every 12 hours hoping to improve to connection. This AM the wireless ATV3 was disconnected from home sharing so I am not sure if there will by any improvement. I just wish I could play my non-iTunes purchased movies directly from my NAS. I am on the verge of buying a blue ray player and kicking the ATV to the curb for now.
     
  10. m11rphy macrumors 6502

    Joined:
    Dec 26, 2009
    #10
    having a similar issues here where apple tv keeps disconnecting from my iTunes content via home sharing, also have issues with air play
     
  11. joebalazek macrumors newbie

    Joined:
    Apr 15, 2013
    #11
    I'm in the same boat. Both ATV3 are wired, with really solid connections. Home sharing is hit and miss as far as connecting. Unplugging and plugging always fixes the home sharing issue, but is a huge pain. Yesterday, while watching an episode of homeland it disconnected 4 times. Gone Girl the night before was the same way.

    Very frustrating.
     
  12. BOR15 macrumors newbie

    Joined:
    Jun 13, 2014
    Location:
    Sydney Oz
    #12
    i have 2 ATV3 and both have the problem ... what i am finding is when it does it, the network is lost and its a bitch to get back again

    B
     
  13. Captain.Slow macrumors newbie

    Joined:
    Jun 7, 2014
    Location:
    Chester, England
    #13
    Wow, I thought it was just me having this problem! Glad to hear it's not just me!!!

    Are you guys finding this happens mostly with AirPlay or via the Home Sharing method too?
     
  14. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #14
    Happens to me on WiFi or Wired 100%... so it's not WiFi dropout because the computer is wired into the same router as the AppleTV ...

    The only way I'm able to get around it is to restart the AppleTV, which fixes it about 25% of the time... or to go on the computer, in iTunes disable Home Sharing then re-enable it (works about 50% of the time), and the other 25% of the time I just give up in frustration.

    The weird part is I NEVER had this issue before iTunes 12 and iOS 8 (I can't point to which of these 2 are the issue since they came at the same time with the issues).
     
  15. antiwindows macrumors newbie

    Joined:
    Aug 5, 2010
    Location:
    Bugtussel
    #15
    I've also had nothing but issues with IOS8 loosing connection between ATV and my Itunes. Apple is starting to loose its MOJO
    The only thing that works to make the connection is th reset the ATV.
     
  16. Crazy Badger macrumors 65816

    Crazy Badger

    Joined:
    Apr 1, 2008
    Location:
    Scotland
    #16
    I'm having more problems since the update to the point I bought a Raspberry Pi to try RasPlex. Not as slick as the aTV and PlexConnect solution but not suffering the random disconnects when watching my media.

    Hopefully something Apple can resolve on a future update.
     
  17. CairnsRock macrumors member

    CairnsRock

    Joined:
    Jan 9, 2013
    Location:
    Toronto
    #17
    Make sure that all of your devices are connected to the same wifi channel from your router. One of mine was on my guest channel. Also a router reboot is worth a try.
     
  18. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #18
    Mine are all hard-wired together so none of the wifi excuses will fly :)
     
  19. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #19
    My ATV2 was very flaky on Wifi, I thought switching to wired made it better but it was just a temporary fix. It frequently would disconnect, and lose all connectivity until restarted - I took it back and got a free replacement and it's been (almost!) perfect since.

    I still do get occasional problems when trying to use Home Sharing, but those often require restarting the Mac rather than the ATV.
     
  20. Futuresgreen macrumors newbie

    Joined:
    Mar 23, 2009
    #20
    Count me in as well, having problems. Ha had them on the ATV3 for some months, although its improved the last month.
     
  21. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #21
    Glad to hear everyone chiming in that the first response of "Nobody else has issues, it's you" is completely hogwash.

    I guess this is what we get for wanting to play in the sandbox with Apple's "hobby"... :-(
     
  22. CairnsRock macrumors member

    CairnsRock

    Joined:
    Jan 9, 2013
    Location:
    Toronto
    #22
    Oh I certainly experienced it. It drove me nuts. Have you tried a router reboot?
     
  23. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #23
    Yep. Even tried a different router. The issue isn't the router, that's the one thing in the whole setup that's remained unchanged (no update)... iOS 8.x on the Apple TV... Yosemite on the computer... and iTunes 12.x on the computer.

    One of the three are the culprit, or a combination of several... but certainly not the router. That's the only thing Apple hasn't has their hands on lately.
     
  24. Chalkster macrumors newbie

    Joined:
    Nov 22, 2009
    #24
    Ever since OSX8 and Yosemite, I've had problems with all devices. Seems to me the bugs are with the OS.

    I have Apple TV in two rooms. It was fine before Yosemite and the latest iTunes came along. Why they have to tinkle with iTunes when it wasn't broke and actually make it an inferior product is beyond me.

    Now with apple TV, when I switch it on it doesn't see my library. The iMac is on, iTunes is open and home sharing is on and signed in. As far as I know all the settings are ok, wake up etc. But I have to go upstairs turn off home sharing in iTunes then turn it back on and sign in again, ATV sees ,my library straight away. It is the same for ATV we have upstairs too.

    The router works fine as far as I know. I don't want to roll back to an earlier iTunes, I'd just like this bug sorted if anyone has an answer.


    Thanks
     
  25. tate16t macrumors newbie

    Joined:
    Dec 28, 2014
    #25
    I'm new to ATV3. So far I have no issues.

    I do have Amazon Prime for some time now and for what its worth I have seen network disconnects a few times while watching movies or TV shows.
     

Share This Page