Autocorrect driving me insane

Discussion in 'iOS 8' started by noobinator, Jul 17, 2014.

  1. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #1
    I'm not sure if this is iOS 8 related or just iOS related but it seems to be worse on iOS 8.

    My iPhone is constantly correcting legit words into something else. It always change "on" to "in". It changes "not" to "nit" These are just two examples but it is doing this all day, every day. Sometimes it changes to words that aren't even real words. Other times it changes real words to other real words. I'm constantly trying to re-teach it but it doesn't seem to take.
     
  2. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #2
    "not" to "nit" wow one would think that it would be the other way around, strange.
     
  3. crookadile macrumors regular

    Joined:
    Jul 2, 2013
    Location:
    Rotherham South Yorkshire UK
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    What pisses me off the most about auto-correct is when it suggests words or phrases that are not even in English. Sometimes I think the dictionary it goes to is from another country. :mad:
     
  5. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #5
    There is a really annoying bug in QuickType, sometimes, where you try to edit the first half of a word. Sometimes it will try to auto-correct the half word you've entered (cos it's not usually a word in its own right), so you tap the "literal" suggestion (usually the left most suggestion) so it doesn't auto-correct, but then it puts a space after what you've typed. So you backspace, but then it thinks you're typing again so it comes up with the suggestions again. Unless you tap the "literal" suggestion it will auto-correct, but then if you do that it adds a space again, and so on...
     
  6. mgipe macrumors demi-god

    mgipe

    Joined:
    Oct 6, 2009
    Location:
    CA
    #6
    I agree. It has been driving me mad for five years!

    It manages to mangle even simple stuff. Whenever I type 'you', it changes it to 'Yu'. Huh?

    It also changes correct grammar to incorrect.
     
  7. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #7
    Why don't you disable it..?
     
  8. Jr. Pac macrumors member

    Joined:
    May 23, 2014
    #8
    It is possible that you at one point typed those words in and it learned them in the keyboard dictionary. Try Settings>General>Reset>Reset Keyboard Dictionary.
    It may help.
     
  9. klamse25 macrumors 6502a

    klamse25

    Joined:
    Oct 25, 2009
  10. thedeejay macrumors 65816

    thedeejay

    Joined:
    Aug 16, 2012
    Location:
    Toronto, Canada.
    #10
    I think it's just post iOS 7. I feel like autocorrect has gotten worse from iOS 6
     
  11. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #11
    Please explain what I'm doing wrong to get my iPhone to change not to nit and on to in. I've never typed nit on my phone.
     
  12. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #12
    You were given 2 valid solutions to your problem - reset the dictionary or if the problem persists- disable the auto correct.
     
  13. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #13
    That is not user error but I will try.
     
  14. skyhawkmatthew macrumors member

    skyhawkmatthew

    Joined:
    Oct 1, 2007
    Location:
    Australia
    #14
    My autocorrect also seems to be quite overzealous in b3. It changes correctly typed words and phrases a few words later to what it "thinks" you are trying to actually say –*extremely annoying! Further, if you have the quick type bar up, because it usurps the old word-suggestion pop-up, there is no way to reject a suggestion if it thinks the word you are typing doesn't exist –*you have to let it correct it then go back with the cursor and edit it yourself, or backspace and re-type several times until it FINALLY gives up re-auto-correcting it every time you hit space.
     
  15. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #15
    For God's sake, disable it if you don't like it and stop posting!
     
  16. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #16
    you think that's what apple think? lol. mate.
     
  17. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #17
    I think this is what Samsung troll thinks ;)
    Lol mate ;)
     
  18. joejoejoe macrumors 65816

    Joined:
    Sep 13, 2006
    #18
    For God's sake, don't open this thread if you have nothing helpful to say and you just get annoyed!
     
  19. Armen, Jul 18, 2014
    Last edited: Jul 18, 2014

    Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #19
    I'm sorry, disabling auto-correct is not an option because all it does is kills the average Words per minute a person can type on a iOS keyboard.

    The guy has a valid point so stop beating him up for it.

    As Deejay said earlier auto-correct has gotten worse since iOS 6. I don't know what Apple has changed but the suggested words are mind boggling sometimes.

    I've reset my custom dictionary multiple times and still get suggestions that are not even in English. It's not random junk either. One of the suggestions I once saw I googled and it was a Japanese phrase.
     
  20. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #20
    I have given 2 valid options already, if that didn't help, than ignorance is a bliss... ;)
    ... Or are you trolling ;)
    Hey Armen, restore your iPhone, it looks like you have a corrupted ios...
     
  21. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #21
    Dude, I restored back to 7.1.2 the day after beta 3 was released. The suggested words are still goofy :p

    Just for kicks I reset my dictionary right now. Let's see what happens.
     
  22. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #22
    Just for kicks, how come thousands/millions of ios users don't have this problem...? ;)
    It must be ios 8 beta ;) LoL
     
  23. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #23
    I dunno man. I sometimes laugh at the suggested word because it sounds like an incantation from Ultima Online.

    Did you mean? "Kal Vas Xen Flam"?

    No Auto-correct, I'm not trying to summon a Fire elemental.
     
  24. joejoejoe macrumors 65816

    Joined:
    Sep 13, 2006
    #24
    The point of this thread isn't to ask how one can reset the dictionary.

    Nor is disabling autocorrect a "solution." While autocorrect works wonderfully for this guy most of the time, there are some bugs in it that are unacceptable and get in the way of his daily use.

    Lots and lots of posters on this thread can relate and back him up.

    The point of this thread is to talk about the bugs in autocorrect. Although a dictionary reset is a temporary solution, it does not get to the heart of the problem.

    That's why your posts haven't been met with praise, especially the ones yelling at others to shutup and take your advice.

    Chill out and let people discuss. If the discussion bothers you, don't bother opening the thread.
     
  25. atlatnesiti macrumors 6502a

    Joined:
    Sep 4, 2008
    Location:
    Sydney, Australia
    #25
    Yeah, I know what you mean.
    Personally I'm not a fast typist and I'm heavily relying on auto correct and quick type features of iOS 8... Love it :)
    Both make my "net life" so much easier :)
    Everything I type is relying on accuracy of auto correct and now with iOS 8 quick type as well :)
    Btw; Have I made any typos in this or previous posts..?
    You're looking at both of these features in action as I write this post ;)
     

Share This Page