Automatically remove junk mail

Discussion in 'OS X El Capitan (10.11)' started by Aquamite, Feb 9, 2016.

  1. Aquamite macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #1
    It's really annoying when a daily pile of junk mail appears in the junk inbox forcing me to repeat the same process of: open the junk mail inbox, select every message, move them to the trash, empty the trash, several times every single day.

    I'm tired of it. I want Apple Mail to delete the junk mail automatically or at least to move it directly to the trash so I only have to empty the trash. I've followed this steps: http://smallbusiness.chron.com/automatically-delete-spam-mac-os-x-52328.html but the junk mail keeps coming to the junk mail inbox.

    Does anybody know how to set Mail App on OS X El Capitan to automatically delete the junk mail?
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    What have you tried exactly? You could check “Perform Custom Actions” then change the action of Move Message from Junk to Trash or change it into Delete Message.

    Another option is to go to Accounts > Mailbox Bahviors and change the Delete junk messages section to 1 Day. You should also check the “Store junk messages on the server” option to make sure that this action is performed across your devices.

    The reason why this junk mailbox exists is because spam filters are fallible. If you’re getting lots of spam, you should consider setting up a new email address.
     
  3. Pndrgnsvc macrumors 6502

    Pndrgnsvc

    Joined:
    Jun 13, 2008
    Location:
    Georgetown, Texas
    #3
    I too had a problem such as yours. The details of how I resolved the issue can be found at http://bit.ly/1PiDVG8 (thread #26920).
     
  4. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #4
    That's what I did which is exactly what the link I liked on my first message is about. However I'm still getting junk mails in the Junk inbox instead of it being deleted:

    [​IMG]

    And please do not tell me that the solution to Mail not responding as expected is to change the email I've been using during all my life. That is as much of an ugly answer as Apple telling us that the antenna gate issue was about us holding our iPhones wrong... .-.

    Thank you but I rather not use third party software.
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    Junk-email filtering is like a predefined email filter. This means that Mail will only consider incoming mails in your inbox. If your spam is already sorted into the junk-email folder by your provider itself (which many providers do these days) then Mail will not do anything to those emails anymore, hence no automatic deletion. Try going to your junk-email folder, right-click on an email and select “Apply Rules”. See whether that makes a difference. If the emails are deleted, then your filter ‘works’. In that case you should follow my other suggestion: set the automatic emptying of junk email to 1 Day or when Mail quits under Accounts > Mailbox Behaviors.

    Also try to change the action into Move to Trash instead of “Delete message”, just to rule out that this action is not working properly.

    It is a serious suggestion. Once you receive spam from unidentifiable sources, your email address is pretty much garbage. There is no way this will ever go away again and you will have to sort out junk email forever. That is a waste of time. Junk-email filters are fallible and may delete genuine emails if you do not pay attention. I cut the cord years ago and set up a new email address that I do not disclose directly and used disposable email addresses for websites that I do not trust. Whenever spam comes in, I break the chain and it’s done. Spam has not troubled me since and it was so worth it.

    Just something to consider. ;-)
     
  6. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #6
    I've tried setting specific standalone rules in the Rules section rather than the Junk Mail section telling it to move the junk mail to the trash instead of deleting it and it still doesn't work.

    However I've sort of solved the problem setting the specific mailbox behaviour for each account in the Accounts section telling Mail to delete the trash and the junk mail for every account each time I quit Mail.
     
  7. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #7
    Rules only work for incoming mails in your inbox. They don’t do anything else. When the server does junk-email filtering also then it may be the case that your junk email never enters the inbox or is quickly moved out of it, bypassing Mails filter rules. It does work for me that way, so I am not sure what the problem in your case is.

    Does nothing happen when you click on “Apply Rules” either?
     
  8. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #8
    I can't find that button.
     
  9. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #9
    This does not work?
     
  10. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #10
    I'll try next time I see new junk mail coming in.
    --- Post Merged, Feb 9, 2016 ---

    Just tried and it does nothing. No matter how many times I click on Apply Rules the junk mail won't leave its Junk Inbox. :/
     
  11. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #11
    Then I suspect that Mail just does not consider these emails as “junk”. Can you verify this? Junk emails should have a brown header with a “Not Junk” button on the right side. Alternatively, when you right-click on such an email, the menu should say: Mark > As Not Junk Mail.

    Which provider do you use? Do you know whether your provider has spam protection?
     
  12. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #12
    They are white just like the normal email. The only difference is that they are in the Junk inbox instead of the normal inbox. They're all from a hotmail account. I'll check out what kind of spam filtering is set at the outlook mail web page tomorrow and tell.

    Thank you very much to all of you for your help btw.
     
  13. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #13
    This likely means that these emails were put into the junk-email folder by Hotmail itself. They were never marked as spam by Mail and it seems that it does not recognise them as spam either. Accordingly, the rule is not applicable. You should consider using SpamSieve or something else, rely on Hotmail’s spam filter and the auto-emptying of the spam mailbox that you just enabled, or turn off Hotmail’s spam filter (if you can) and use Mail’s spam filter.

    This is why I don’t want to deal with spam myself anymore. :(
     
  14. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #14
    Just look through the outlook options and couldn't find any option to deactivate the standard junk mail filtering of outlook or to apply rules of automatic deletion to the junk messages. But anyway that doesn't have anything to do with OS X El Capitan so I'll just leave the topic here by now.

    Thanks to everyone for your responses.
     
  15. slapppy macrumors 65816

    Joined:
    Mar 20, 2008
    #15
    I gave up also. Junk mail doesn't delete on its own. I can mark them JUNK 10 billion times and they keep coming in the junk folder, but not marked junk. Also the auto delete after a period of time doesn't work. I then tried the "rules" to delete any junk mail sitting there for 30 days and what happened next was terrible. Normal mail from my Inbox disappeared forever. Not showing up on any of my iOS devices either. I got rid of that rule and now these emails that I did not want deleted or marked junk are GONE! What a mess. All these updates and El Capitan is still full of bugs at the basic level.
     

Share This Page