Back-up Failure and exit code 8

Discussion in 'OS X El Capitan (10.11)' started by chrisandersen, Aug 25, 2016.

  1. chrisandersen macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #1
    My MacBookPro with a 500GB SSD and OS X 10.11.6 uses an external Synology for Time Machine back-ups. Everything was working just fine until a couple of days ago, when I noticed that the back-ups started failing. First thing I did was take it down to where the wifi is to improve the speed of download and no improvement. It keeps bombing out about half way through the back-up. My iMac and Mini are still backing up just fine, so I think it must be the laptop's SSD.
    I run a first aid from Disk Utility and it reports that there is an incorrect number of file hard links, Drive is corrupt and must be repaired, and file exit code is 8. Also says OK.
    I restart the machine and run disk util again, and this time it says nothing about corruption and does say feel exit code is 8, Operation successful.
    I force another back-up and get, 138 GB ion 537 GB available. Back up x of 543 MB. It starts off real slow (3 or 4 mb) then jumps real fast to 308 mb and then slows down again and fails.
    I'm at a loss at why it won't back-up and the exit code 8 kinda scares me.
     
  2. donlab, Aug 25, 2016
    Last edited: Aug 25, 2016

    donlab macrumors 6502

    donlab

    Joined:
    Jun 3, 2004
    Location:
    USA
    #2
    Applications --> Utilities --> Console
    Under “LOG FILES” on the left click the triangle beside "/var/log".
    Scroll down the list to "system.log". This should be the logs for today.
    what do you see logged concerning the backups?

    SSD...
    try rebooting into recovery mode, launching disk utility and running a check / repair against the ssd.
    what does disk utility report this time?
    manually copy your important files and data to a safe place

    found this older thread...
    http://forums.macrumors.com/threads/file-system-check-exit-code-8-disk-wont-repair.1819660/
     
  3. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #3
    The log showed a reference to a file on my gmail account. It stated that it copied 308 mb of data and then failed with error code 11.
    The SSD shows good after recovery mode reboot.
    I made a super duper copy.
    And, it still bombs out about half way through. It sure is slow and then speeds up and then slow and bombs.
     
  4. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
  5. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
  6. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #6
    Update:
    Did a reboot to single user mode (Command+S) and ran /sbin/fsck -fy and it found an invalid directory item count. It repaired it and when I rebooted and ran Disk Util again, I got a clean exit 0. Ran backup again (i had disabled it) and it started making a big 4.6 GB back up. It made it through 3+ GB when it bombed out again!
     
  7. donlab macrumors 6502

    donlab

    Joined:
    Jun 3, 2004
    Location:
    USA
    #7
    What did the logs say this time? what file did it fail on?
     

Share This Page