Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

jagooch

macrumors 6502a
Original poster
Jul 17, 2009
662
176
Denver, co
I've ran into an issue where my Airpods keep waking up my Macbook Pro because I have the "Allow Bt devices to wake up this computer" enabled. I want it enabled so that my BT keyboard and Mouse can wake up my Macbook from sleep, since my Macbook is always in clamshell mode, inside of a clamshell dock that prevents me from opening it up easily, and connected to external monitors.

I don't see a way to configure the Macbook to limit which BT devices can wake it up. But I am willing to unpair my Airpods from the Macbook to prevent it from waking up my Macbook.

However, when I go to "System Preferences->Bluetooth" to unpair the Airpod Pros, it warns me that it will unpair it from all of my devices. That is not what I want to do.

Is there a way to do this?
 

Attachments

  • Screen Shot 2020-10-16 at 10.14.16 AM.png
    Screen Shot 2020-10-16 at 10.14.16 AM.png
    288.5 KB · Views: 77

Night Spring

macrumors G5
Jul 17, 2008
13,545
6,553
One way I found is to disable handoff on your Mac, as that is how the AirPod pairing status is shared among your Mac and other i-devices. This may be problematic, if you use handoff for other features.
 
  • Like
Reactions: jagooch
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.