Cannot install macOS Mojave: error updating firmware.

Discussion in 'macOS Mojave (10.14)' started by drylight, Sep 26, 2018.

  1. drylight macrumors newbie

    Joined:
    Mar 29, 2007
    #1
    I just tried to upgrade to macOS Mojave (from the latest macOS version before Mojave) and I am getting the following error:

    macOS could not be installed on your computer.

    An error occurred while updating firmware.
    Quit the installer to restart your computer and try again.

    As it suggests, I tried again, but to no avail. I am on the latest MacBook Pro (2018) (no external GPU, or anything like that). Is there any work-around or fix for this error?

    Here is an image of the screen that shows the error:
    [​IMG]
     
  2. sumo.do macrumors regular

    sumo.do

    Joined:
    Mar 12, 2014
    Location:
    Australia
    #2
    How are you doing the upgrade? Via the AppStore upgrade option? And at what point in the upgrade is the error occurring?
     
  3. drylight thread starter macrumors newbie

    Joined:
    Mar 29, 2007
    #3
    Yes, this was via the App Store upgrade. After the download finished from the App Store, the Mac rebooted. At this point it showed the avatar of three users with accounts on the machine, and a mountain photo as the background. I entered my account password and it shows a message "Installing on 'Macintosh HD'", with a progress bar. When it reaches almost the end of the progress bar, that's when the aforementioned error happens.
     
  4. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #4
    I've read about this, can't find the source at the moment.

    So to prevent or fix security problems, Apple regularly updates the firmware of Macs. In the past, this sometimes failed but the software would continue to run. Except there would be a security hole. A security researcher found that a huge number of Macs run old firmware and since then, Apple is doing checks for this.

    It wouldn't surprise me that this is the cause of the problem. I think the solution is to visit the Apple Store, but of course you posted to not have to do that in the first place. So, not much help from me, just perhaps a clarification.
     
  5. sumo.do macrumors regular

    sumo.do

    Joined:
    Mar 12, 2014
    Location:
    Australia
    #5
    I have no single suggestion but a couple of options to try:

    Check there are no old firmware updates you missed https://support.apple.com/downloads/firmware

    Reset SMC and PRAM (google it if you don't know how)

    Try first aid checks on your OS hard drive booted in from an external boot disk

    Make sure not peripherals are plugged in.

    Try loading the OS from another profile on your Mac.

    More complicated options...

    Try a fresh install of Mojave from an external OS install disk and load in the profiles after the install. Diskmaker X is a good option if you don't know how to make a USB OS install disk.

    Try loading Mojave on an external drive to see if that works? If so, you can then use that OS from a Time Machine backup (to your primary had drive) and load in the profiles etc. Long way around...

    They are all just non-technical 'stabs in the dark' and not necessarily linked to your issue but sometimes those options create a 'side door' past a problem.
     
  6. drylight thread starter macrumors newbie

    Joined:
    Mar 29, 2007
    #6
    OK, I found a solution (at least for my issue). It's something I stumbled upon. I decided to connect an external drive to the MBP, so that I could back up its drive, and then do a clean install. I connected the drive, and pressed the Option key. Here I was shown the Startup Disk screen, showing me the internal and the external drive partitions, so that I could chose from which I wanted to startup.

    I then selected the MBP's drive, not the newly connected drive, and I was booted in to Mojave! I then restarted. But, it failed again. Back to square one.

    So, I thought that maybe the Startup disk was set to the macOS boot partition and not the main drive (Macintosh HD). Then I restarted pressing Option, Command, R, and then used the Disk Utility to set the Startup Disk to the MBP's drive.

    From then on, I've been able to boot the machine and log in to Mojave without issue.
     

Share This Page

5 September 26, 2018