Cannot install macOS or OSX in VMware Fusion!

Discussion in 'Mac Apps and Mac App Store' started by Thor774, Oct 6, 2017.

  1. Thor774 macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #1
    I have several Windows VMs in Fusion 8.5.8 working without any problems. I am needing to create a new VM with macOS or at least with OSX El Capitan. I have tried many times now and VMware is always giving me the same fail when starting the image for the first time before the installation. If I use the .app file from the Apple Store dropping it into the Create a New Virtual Image window I just get this error message: "Unable to create the installation medium". If I use the InstallESD.dmg from inside the package contents the VM simply cannot boot from it. I have tried with both macOS Sierra and El Capitan and the same is happening.
    I have googled this problem and found that it was present on the Fusion 8 beta but it supposed to be fixed long time ago via updates on Fusion.

    Any help is greatly appreciated.
     
  2. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #2
    Mount it as an image, then you'll be able to install Sierra (HS) in Fusion using it as a kind of ISO.

    GL & Cheers
     
  3. Thor774 thread starter macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #3
    I am trying to do what you say, mount it as an image, but am not getting anything. I am trying with "Install OS X El Capitan.app" for example:
    1. I don't find any way to mount this as an image directly so what I am doing is this:
    2. Show package contents and get the InstallESD.dmg file from inside the Shared Support folder.
    3. Mount the InstallESD.dmg file as an image on Sierra (my main OS) with Finder. It mounts fine.
    4. How do you now use this from inside Fusion to install it on new a guest VM?
    I have previously tried using the InstallESD.dmg file as the install source DVD on a newly created VM and it just doesn't boot.

    Thank you.
     
  4. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #4
    You can't use the disk image embedded in the OS X installer app directly in Fusion. The instructions here may work for you: https://derflounder.wordpress.com/2...on-and-esxi-with-create_macos_vm_install_dmg/
     
  5. Thor774 thread starter macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #5
    You have done it. This article was amazing. I could modify the 10.12.6 Sierra .app and turn it into a DMG for installing into a VM.
    What strikes me is that after reading all the help files and support articles for VMware Fusion this should not be necessary, the plain .app file should work fine. I do not understand why this complex script is needed when the software should support the installation without any of this hassle.

    Thank you very much for your help!
     
  6. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #6
    The script isn’t necessary. When I make a new Mac virtual machine, I just use the installer app and it’s worked fine for me every time. If you’re making a lot of virtual machines, you’d save some time by starting with a disk image but in general it’s not necessary at all.
     
  7. Thor774 thread starter macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #7
    Well, it was necessary for me. I could not install any macOS or OSX without modifying the .app file first with this script. It looks like there are many users affected by this fail, but not everyone.
     

Share This Page

6 October 6, 2017